Need help to modify forwarder !!

Discussion in 'Wii - Emulation and Homebrew' started by Benjay, Jun 14, 2009.

Jun 14, 2009
  1. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    Hi everybody !!

    I need help to modify a forwarder , i've spent the whole day trying to do it myself , but i still get the same result : the forwarder loads fine , but images are fuzzy..........
    I've followed a good tutorial , everything is ok , the forwarder loads fine etc....
    but the images i've replaced appear fuzzy , striated. [​IMG]
    My bmps are saved in 16bits mode , same dimensions as originals , and i've tried the fuzzyfixer thing , but still the same result..... [​IMG] [​IMG]

    So i've decided to ask help !!!!

    if someone can spend a little time to do it for me i would be very happy ^^
    here is an archive that contains the forwarder to modify , the images that i want to be in (in bmp format) , and the sound.bin to be in too.

    http://benjay.free.fr/mouarf.rar

    I want to mdify this forwarder so it matches with the theme i've made for Wiiflow loader.
    The forwarder i want to modify comes from Spayrosam , he posted it in the wiiflow thread (thanks to him).

    let me give you some details about transparency i want on images.

    in the banner folder :
    - clouds.bmp must stay as it is , no transparency needed.
    - nintendo.bmp must be fully transparent , so set black to transparent.
    - V-logo.bmp , i just want the white word being visible , so set black to transparent

    in the icon folder :
    - Fondnoir.bmp must stay as it is , no transparency needed.
    - Glowball.bmp must be fully transparent , so set black to transparent.
    - mi_Wii_Mini_Title.bmp , i just want the white word to be visible , so set black to transparent.

    Any kind of help would be really much appreciated , thanks in advance [​IMG]
     
  2. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada

    What program are you using to do this? I can take a look using wadstudio. Question, you have a note on the transparency for the images.. do you have it set already? If trancparency is already set i can try putting it together for you, i can't test though.. i won't be near my wii for 2 - 3 days.
     
  3. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada
    OK i looked at this. I need the sounds.bin as a wav or MP3 file. Then i should be able to do it. I won't be able to test the fuzziness, but i can play with it and post back until we get it. I just won't be near my wii.

    Finally. I will have to add my own forwarder code as i don't have the dol you are using in the channel..

    Do you want it to forward from SD:/apps/WiiFlow

    let me know if that works for you.
     
  4. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada
    OK so no music yet, but this will let me know what fuzzy fix level you need.

    Test files for Forwarder.

    There are 3 wads. one with no fuzzy fix, one with 16 byte and one with 32. Find out which one works for both the banner and the icon and let me know.

    Also provide the music as a wav or mp3 and i have the app location as SD:/apps/WiiFlow
     
  5. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    well , thx for your efforts , but you gave me my first banner brick...........
    i've tried installing the one with no fuzzy fix , and voila ^^

    So now i must find a way to debrick it (i'm on 3.2 with starfall installed and i have a wiikey inside , i should be able to do this i think)
     
  6. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada
    Sorry about that.. i usually test them, and as i said sadly, i am not near a wii for a few days.. should have been fine though.. Starfall is supposed to fix banner bricks, just need to get that wad uninstalled..

    I will try to see if i can test one and get it to you today, but sadly probably not until the weekend... again sorry about that.
     
  7. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    well don't be sorry [​IMG]
    i should say "it's the game" , it had to happen to me , i put a lot of things in my wii since 3 months , and i didn't encounter any problem , but there is a beginning for everything [​IMG]

    like i said , don't be sorry , i've found an autoboot iso of wadmanager and i've been able to launch it , and uninstall the wad , so everything is came back to normal [​IMG]
    it just gave me 10 minutes of stress ^^ (and now i know how to fix a banner brick on my wii)

    about the forwarder : take your time , it's not an emergency , i prefer to get something that works in 1 week , instead of a bad brick today lol

    and it will give me time to find the sound in wav format (it's a .bin i found in a topic here)
    to answer the questions of your first post , to edit the forwarder i used a bunch of tools as U8extractor , U8tool , tpl-edit-fe , tpl-converter and many others i don't remember the names ^^
    i don't have the .dol because i didn't need it with the method i used.

    and the forwarder should point to SD:/apps/wiiflow (lowercase)

    Thx for everything [​IMG]
     
  8. madtamski

    Member madtamski GBAtemp Fan

    Joined:
    Oct 15, 2008
    Messages:
    404
    Location:
    Glasgow, Scotland, UK
    Country:
    United Kingdom
    Nice on on getting your brick sorted!

    I take it you don't have BootMii installed?

    If you can, I would really say do it and create a NAND backup!

    You can then do just about anything to your wii without fear of bricking [​IMG]
     
  9. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    thanks for the info , i was actually thinking to do this , i'll give an eye on it tomorrow.

    PS : @JQE , i've been able to resample the soud.bin to sound.wav with Goldwave , so here it is [​IMG]

    http://benjay.free.fr/sound.rar

    (no loop required , because i don't plan on staying more than 3 seconds in the forwarder ^^)
     
  10. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada
    Things have sorted themselves out, i should be able to get this together for you tonight.. Tested and all...
     
  11. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    thank you very much !!
     
  12. JQE

    Newcomer JQE Advanced Member

    Joined:
    Apr 15, 2009
    Messages:
    68
    Country:
    Canada
    OK so it's all working now. Had to change some of the colors due to background confusion.

    Wad File.

    Let me know what you think.

    oh and i left the original forwarder file. So whatever directory it was before it still is.
     
  13. Benjay
    OP

    Member Benjay Hardstyle Addict

    Joined:
    May 25, 2009
    Messages:
    898
    Location:
    Amiens
    Country:
    France
    ok , i try this on noon and tell you what [​IMG] (don't know how many hours we have different ^^ something like 7 or 8 perhaps ).

    EDIT : just tried it and it's perfect for me [​IMG]

    again , thank you very much for the time you spent on it.
     

Share This Page