Hacking Need help running certain games on Luma 3DS

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
I've been seeking an answer for this for some time, but the internet seems to be fairly ambiguous when I have asked in the past. Does anybody have the technical knowledge to help me out?

Recently, I installed Luma 3DS custom firmware. I am running 11.2 Emunand on a 4.4 sysnand, both are Japanese firmwares on an original Japanese N3DS LL. All games seem to run perfectly fine, and I have accepted the EULA agreement for other countries via config.

However, I have encountered several issues.

1) I downloaded a US version of Fire emblem Birthright, with matching Birthright US DLC and updates, yet they do not appear on my game. Why?

2) Majora's Mask 3DS specifically shuts my 3DS down, and restarts it, saying that there is an error with the SD card after booting. It is the only game that does this.

3) Super mario maker and Bravely Second both will not appear in English, despite being downloaded as a US file. Why?

Extra information: I have examples of many other fairly new games, such as Animal crossing: welcome amiibo, Super smash brothers, xenoblade chronicles and more, which work correctly online and with their DLC, in the language native to the ROM's region. Why do the games I have listed not work?


Does anybody have any clues, or suggestions? I'm really at a loss with this.
 

wormdood

pirate booty inspector
Member
Joined
Jan 3, 2014
Messages
5,170
Trophies
0
Age
35
Location
behind a parental advisory sticker
XP
3,551
Country
United States
1) I downloaded a US version of Fire emblem Birthright, with matching Birthright US DLC and updates, yet they do not appear on my game. Why?
sounds like a bad dump and/or download . . . find a new source and try again
2) Majora's Mask 3DS specifically shuts my 3DS down, and restarts it, saying that there is an error with the SD card after booting. It is the only game that does this.
also sounds like a bad dump and/or download. . . find a new source and try again
3) Super mario maker and Bravely Second both will not appear in English, despite being downloaded as a US file. Why?
games that were meant for release in all regions often have all language packs inside and use the consoles language in this case Japanese
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
sounds like a bad dump and/or download . . . find a new source and try again
also sounds like a bad dump and/or download. . . find a new source and try again
games that were meant for release in all regions often have all language packs inside and use the consoles language in this case Japanese

Is there any way to change the language on games that go by the system's language, other than by reinstalling the sysnand?
I should add that Fire emblem DOES work, the dlc just doesn't appear. I should have been more specific. I'm installing from the freeshop, surely this ought to be a good source...? Can you suggest others, if not?

I have one further question. Despite owning a new 3ds, super nintendo virtual console titles downloaded from the freeshop also similarly do not seem to function. However, GBA, NES, and GBA titles work just fine.

Could you please perhaps elaborate a little further, using this information?
 

Xiphiidae

Member
Joined
Sep 13, 2009
Messages
2,106
Trophies
0
XP
1,647
Country
Australia
Is there any way to change the language on games that go by the system's language, other than by reinstalling the sysnand?
Luma Locale Switcher can do this, I believe.

I should add that Fire emblem DOES work, the dlc just doesn't appear. I should have been more specific. I'm installing from the freeshop, surely this ought to be a good source...? Can you suggest others, if not?
Are you downloading the DLC via FreeShop as well?

I have one further question. Despite owning a new 3ds, super nintendo virtual console titles downloaded from the freeshop also similarly do not seem to function. However, GBA, NES, and GBA titles work just fine.
Strange.Could you explain how is it they don't work?

What are your Luma settings? What version of Luma are you using? Also, may I ask why you're running EmuNAND in the first place, especially with such a low SysNAND?
 
Last edited by Xiphiidae,
  • Like
Reactions: wormdood

wormdood

pirate booty inspector
Member
Joined
Jan 3, 2014
Messages
5,170
Trophies
0
Age
35
Location
behind a parental advisory sticker
XP
3,551
Country
United States
Is there any way to change the language on games that go by the system's language, other than by reinstalling the sysnand?
nope . . . region changing the console is the only option (as far as i know)
I should add that Fire emblem DOES work, the dlc just doesn't appear. I should have been more specific. I'm installing from the freeshop, surely this ought to be a good source...? Can you suggest others, if not?

I have one further question. Despite owning a new 3ds, super nintendo virtual console titles downloaded from the freeshop also similarly do not seem to function. However, GBA, NES, and GBA titles work just fine.
you should try updating your luma3ds cfw
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
Luma Locale Switcher can do this, I believe.


Are you downloading the DLC via FreeShop as well?


Strange.Could you explain how is it they don't work?

What are your Luma settings? Have you made other modifications to your console? May I ask why you're running EmuNAND in the first place, especially with such a low SysNAND?


I simply followed the 3DS custom firmware guide. Having a low Synand allows for the installation of custom firmware, and the emunand allows you access to newer functionality. I'm not very tech-savvy, but it seems to be working (mostly) thus far.

I have made no physical alterations to my console, and the only technical alterations I have made are those listed in the 3ds guide.

I am downloading all of the items that have been listed, from the same place, which is the freeshop. some games work perfectly and some do not at all.

Futher information on how the super nintendo games do not work, would be that they DO boot, open up the virtual console, and then crash and force my ds to close and restart.

--------------------- MERGED ---------------------------

nope . . . region changing the console is the only option (as far as i know)
you should try updating your luma3ds cfw


I am currently running the latest version of luma3ds cfw my friend
 

Xiphiidae

Member
Joined
Sep 13, 2009
Messages
2,106
Trophies
0
XP
1,647
Country
Australia
I simply followed the 3DS custom firmware guide. Having a low Synand allows for the installation of custom firmware, and the emunand allows you access to newer functionality. I'm not very tech-savvy, but it seems to be working (mostly) thus far.

I have made no physical alterations to my console, and the only technical alterations I have made are those listed in the 3ds guide.

I am downloading all of the items that have been listed, from the same place, which is the freeshop. some games work perfectly and some do not at all.

Futher information on how the super nintendo games do not work, would be that they DO boot, open up the virtual console, and then crash and force my ds to close and restart.
Following 3ds.guide should leave you with A9LH and an updated SysNAND with CFW, and no EmuNAND. You must've done the guide a long time ago. Do you have A9LH?

I suggest you switch to just using SysNAND. Here's a section of 3ds.guide that explains how to do this (you will need A9LH to do this, of you don't have A9LH, follow this from the beginning).

I am currently running the latest version of luma3ds cfw my friend
The latest stable version of Luma is 6.6. Are you using this version?
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
Following 3ds.guide should leave you with A9LH and an updated SysNAND with CFW, and no EmuNAND. You must've done the guide a long time ago. Do you have A9LH?

I suggest you switch to just using SysNAND. Here's a section of 3ds.guide that explains how to do this (you will need A9LH to do this, of you don't have A9LH, follow this from the beginning).


The latest stable version of Luma is 6.6. Are you using this version?



I followed the guide about 2 weeks ago. Maybe I am running synand in that case... Sorry. I followed the guide to a T, but I am really not very good at understanding the terminology and whatnot. I realise how unhelpful that is. But i followed it extremely recently which must mean I'm running the latest version of whatever is available, right?

I updated luma yesterday using the in-app launcher. Is that okay? I do have AL9H by the way.

--------------------- MERGED ---------------------------

I am currently running the latest version of luma3ds cfw my friend[/QUOTE]
fyi when people say the 3ds guide on this forum they refer to this
3ds.guide you should use it btw

Yes, that's what i was referring to. I followed this guide 2 weeks ago
 

Xiphiidae

Member
Joined
Sep 13, 2009
Messages
2,106
Trophies
0
XP
1,647
Country
Australia
I followed the guide about 2 weeks ago. Maybe I am running synand in that case... Sorry. I followed the guide to a T, but I am really not very good at understanding the terminology and whatnot. I realise how unhelpful that is. But i followed it extremely recently which must mean I'm running the latest version of whatever is available, right?
Tell me what your Luma settings are, and go into System Settings and tell me what the version number is displayed as.

I updated luma yesterday using the in-app launcher. Is that okay? I do have AL9H by the way.
Ensure that the app that you're using is 'Luma Updater'. Check what your Luma version actually is.

Why did you think that you had EmuNAND in the first place, and why did you think that your SysNAND was 4.4?
 
  • Like
Reactions: wormdood

wormdood

pirate booty inspector
Member
Joined
Jan 3, 2014
Messages
5,170
Trophies
0
Age
35
Location
behind a parental advisory sticker
XP
3,551
Country
United States
I followed the guide about 2 weeks ago. Maybe I am running synand in that case... Sorry. I followed the guide to a T, but I am really not very good at understanding the terminology and whatnot. I realise how unhelpful that is. But i followed it extremely recently which must mean I'm running the latest version of whatever is available, right?

I updated luma yesterday using the in-app launcher. Is that okay? I do have AL9H by the way.

--------------------- MERGED ---------------------------

I am currently running the latest version of luma3ds cfw my friend


but . . . you know accuracy helps in troubleshooting . . . im confused as to how to proceed as im unsure of your specs
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
Tell me what your Luma settings are, and go into System Settings and tell me what the version number is displayed as.


Ensure that the app that you're using is 'Luma Updater'. Check what your Luma version actually is.

Why did you think that you had EmuNAND in the first place, and why did you think that your SysNAND was 4.4?

I guess i thought that's what the guide shows you how to do... i feel kinda stupid actually now lol.

https://3ds.guide/2.1.0-ctrtransfer

during this phase of the guide, it tells you to downgrade your 3ds to 2.1, that's what i was mistaking it for. I assumed that my system was still in an older firmware, allowing me to run cfw still.....

--------------------- MERGED ---------------------------

but . . . you know accuracy helps in troubleshooting . . . im confused as to how to proceed as im unsure of your specs

Ok it was my mistake, my apologies, I just didn't understand what I was doing at the time. It's 11.2 synand, not an emunand.

Sorry
 

wormdood

pirate booty inspector
Member
Joined
Jan 3, 2014
Messages
5,170
Trophies
0
Age
35
Location
behind a parental advisory sticker
XP
3,551
Country
United States
I guess i thought that's what the guide shows you how to do... i feel kinda stupid actually now lol.

https://3ds.guide/2.1.0-ctrtransfer

during this phase of the guide, it tells you to downgrade your 3ds to 2.1, that's what i was mistaking it for. I assumed that my system was still in an older firmware, allowing me to run cfw still.....
well then lets settle it take your sd card out boot the console enter settings and report back the firmware
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
Could you tell us what your Luma settings are?

It's also worth checking your SD with H2testw.

Luma updater v1.4.2
Payload type arm9loaderhax

current installed verson 6.6-b16d887 (dev) - ( i have devkit installed to help me play foreign titles)
 

wormdood

pirate booty inspector
Member
Joined
Jan 3, 2014
Messages
5,170
Trophies
0
Age
35
Location
behind a parental advisory sticker
XP
3,551
Country
United States
Luma updater v1.4.2
Payload type arm9loaderhax

current installed verson 6.6-b16d887 (dev) - ( i have devkit installed to help me play foreign titles)
power down
hold select and boot the console
lumasettings will open . . . tell me what has a (x) next to it

fyi at the top will be your luma version
 
Last edited by wormdood,
  • Like
Reactions: Xiphiidae

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
power down
hold select and boot the console
lumasettings will open . . . tell me what has a (x) next to it

fyi at the top will be your luma version



luma 3ds v6.6 configuration

default emunand 1(x)
screen brightness 4(x)
Splash off (x)
Pin lock: off (x)
new 3ds cpu: off (x)
dev featires: off(x)

(x) autoboot synand
(x) use sysnand firm if booting with R
(x) show nand or user string in user settings
 

GrandSnorlax

Active Member
OP
Newcomer
Joined
Jan 21, 2017
Messages
25
Trophies
0
Age
30
XP
39
Country
There's your problem. Change this to Clock + L2

You've pretty much told your console not to be able to load anything that uses New 3DS functionality (hence MM3D and SNES games freaking out).

I followed your instructions and it is still crashing. Perhaps more curiously, Xenoblade chronicles 3DS (a new 3ds exclusive) was working perfectly before this.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    kenenthk @ kenenthk: Does anything