NDS games refuse to boot on arm9loaderhax + Luma3ds

Discussion in '3DS - Flashcards & Custom Firmwares' started by RyDog, May 8, 2016.

  1. RyDog
    OP

    RyDog Lazy Animal Crossing hacker

    Member
    1,596
    1,149
    Apr 26, 2015
    United States
    When launching nds games on o3ds 10.7 sysnand with arm9loaderhax+luma3ds I get a blank black screen. They were working before I installed arm9loaderhax, and retail 3ds games boot. Does arm9loaderhax disable nds functionality? Or is there something broken that can be fixed?
     
  2. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    They do work (or at least they're supposed to) on Luma on a9lh, as long as you either have no boot manager before Luma or use the path patcher on Luma.
    Not sure if that's understandable, so basically, if your main arm9loaderhax.bin file (the one at the root of your SD card) isn't Luma, you need to patch Luma's arm9loaderhax.bin. See Luma's wiki.
     
    Last edited by Hayleia, May 8, 2016
    Searinox likes this.
  3. RyDog
    OP

    RyDog Lazy Animal Crossing hacker

    Member
    1,596
    1,149
    Apr 26, 2015
    United States
    I'm using luma's arm9loaderhax.bin
     
  4. nero99

    nero99 GBAtemp Advanced Maniac

    Member
    1,860
    838
    Sep 18, 2014
    United States
    Use sysnand CFW (a9lh) and you won't have that problem at all.
     
  5. RyDog
    OP

    RyDog Lazy Animal Crossing hacker

    Member
    1,596
    1,149
    Apr 26, 2015
    United States
    Just tested other NDS parts on the 3DS (ds wifi settings, ds profile settings) and they all give me the black screen. I'm guessing some file on my NAND is messed up. Which one is it though?
     
  6. Tomy Sakazaki

    Tomy Sakazaki GBAtemp Advanced Fan

    Member
    754
    204
    Oct 23, 2006
    Brazil
    Try patching your NAND with a non-patched/original TWL-firm.
     
  7. proflayton123

    proflayton123 悲しみ

    Member
    5,610
    2,059
    Jan 11, 2016
    Japan
    日本
    Do you have TWL patches?
     
  8. RyDog
    OP

    RyDog Lazy Animal Crossing hacker

    Member
    1,596
    1,149
    Apr 26, 2015
    United States
    I had it on emuNAND, which is basically what I'm running since I flashed emuNAND to sysNAND. I think this might be it.
     
  9. proflayton123

    proflayton123 悲しみ

    Member
    5,610
    2,059
    Jan 11, 2016
    Japan
    日本
    @Aurora Wright maybe can help ><
     
  10. jerrmy12

    jerrmy12 GBAtemp Regular

    Member
    240
    71
    Apr 8, 2016
    United States
    Reinstall stock TWL patches
     
    proflayton123 likes this.
  11. Drakia

    Drakia GBAtemp Maniac

    Member
    1,493
    1,746
    Mar 15, 2008
    Canada
  12. RyDog
    OP

    RyDog Lazy Animal Crossing hacker

    Member
    1,596
    1,149
    Apr 26, 2015
    United States
  13. Pikm

    Pikm Thy Lord and Savior

    Member
    642
    274
    Jan 24, 2016
    United States
    Delaware
    Do you have the latest hourly build of Luma3DS? That gave me some TWL issues, but I just downloaded an earlier build and that fixed it.