Multiple R4i Gold 3DS (original) not working?

Discussion in 'R4 DS' started by marcosxd, Nov 21, 2011.

Nov 21, 2011
  1. marcosxd
    OP

    Newcomer marcosxd Member

    Joined:
    Jun 14, 2011
    Messages:
    24
    Country:
    Mexico
    Hi, I recently purchased some R4i Gold 3DS (original) to resell them local, all of them booted correctly at the beginning (I updated them using the DSi 1.4.3 Patch in their official website r4ids.cn) and worked fine the first time but now I have sell quite a few and some of them are failing.

    For example, after playing Mario Kart (on a DSL) the system froze, when I turn it off and on, the system gets stuck (with the card in it) at the boot screen and freezes. When I insert it in a DSXL and 3DS it doesn't even recognize the card as it were inserted. I cannot find anything related online, nor a way to fix them.

    This have happened 3 - 4 times in the past week, I am using generic 4GB microsd cards with the same ROMs, but I am sure it is not a memory error.

    Any ideas? Thanks
     
  2. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    Possibilities:

    1) A contact issue. Try these solutions (these are solutions for acekard's contact issues, but it should apply to other flashcarts). From the fact that the cards can't be read in some systems, this is more probable than the other possibility. Freezes are also associated with contact issues.

    2) Your micro sd cards are very crappy/slow, which usually causes many problems in flashcarts. This mostly associates with freezes and having white screens. Try formatting using the panasonic SD formatter (make sure you back everything up before formatting because formatting will erase everything in your micro sd card). If that doesn't work, I suspect that the micro sd card is too slow to handle flashcarts to begin with; get better ones.
     
    1 person likes this.
  3. exangel

    Member exangel executioner angel

    Joined:
    Apr 20, 2010
    Messages:
    1,574
    Location:
    Tucson, AZ
    Country:
    United States
    Generic memory is very hit-or-miss.

    If this is Non-Class or Class 2 4GB memory, it's most likely the quality of the MicroSD's. The way you'd know the difference is an icon on the MicroSD that is a little number with a circle around it. Valid classes are (2), (4), (6), and (10) for SDHC. If there's no mark, it's considered unverified or may have been manufactured before class standards were set.

    Some will tell you that the class doesn't have any effect on read speed, and though that's true, for generic memory to be Class 2/non-class is still bad news, because that means it is bottom-of-the-line product and it probably does have poor read speeds compared to branded/verified class 4 or higher memory.

    Playback of games doesn't depend on write speed, only the game save process is affected, but the quality of the original file transfer to the MicroSD is also still important.

    As s4m said, the SD Association formatter (formerly known as Panasonic SD formatter) may fix things. The only time I had a problem that was definitely not a contact issue (this was apparent because I froze in the exact same place after loading the game every time) it was fixed by using the aforementioned formatting utility from http://www.sdcard.org -- However, I had to do a full format to completely fix that particular memory card, and, if I remember correctly, it took like 20 minutes for a 4 GB card to do a full erase-off format.

    MOST IMPORTANTLY, in regards to your correct use of MicroSD, MicroSD -> SD Card adapters are notoriously wonky, because data has to go through two sets of contacts that are more vulnerable to damage and misalignment than just using a USB reader. The ones that come with the carts are flimsy, but are better than an adapter. I'd recommend getting a proper one if, more than once, you get an alert when you plug in your MicroSD that you should scan it for errors.

    edit: made sure something I said was more accurate & fixed a link
     
  4. marcosxd
    OP

    Newcomer marcosxd Member

    Joined:
    Jun 14, 2011
    Messages:
    24
    Country:
    Mexico
    Thanks both for your suggestion, I find it odd because even without microSD inserted it won't show up the Sponge Bob icon or in this case (updated flashcards) the Hello Kitty icon, just freeze DS system and don´t show up in DSi and above. I will try tomorrow and get back to you guys, Thanks
     
  5. exangel

    Member exangel executioner angel

    Joined:
    Apr 20, 2010
    Messages:
    1,574
    Location:
    Tucson, AZ
    Country:
    United States
    Oh. I guess I missed that part in your original post.

    Because that really does sound like contact issues.
    Did you test the DS systems to make sure they work 100% properly with real game cartridges too?
    I did have a DS Lite that had to be repaired once because the Slot-1 actually had become damaged over time, causing similar problems that you have that weren't affecting my other DS systems.

    I've never had contact issues with carts besides Acekard 2i though, and I find it a little surprising that you have that problem with the r4ids/r4i gold cards because those are thick enough to get partially stuck in my DSi XL and 3DS systems. So be very careful not to make them too thick if you decide to look into fixing the contact issues.

    edit:reorganized my thoughts
     
  6. tranfeer

    Member tranfeer GBAtemp Advanced Fan

    Joined:
    May 23, 2010
    Messages:
    772
    Country:
    Austria
    You need to update your r4i gold 3ds(r4ids.cn).
    Please access www.r4ids.cn and download 3ds 2.2.0-4 patch to update it.
    Please read readme.txt carefully and just do the procedures lited in it.

    Attention:you should use 3DS22Patch_R4iGold3DS_NDSL.nds to repair your card.



     
  7. frederic

    Newcomer frederic Member

    Joined:
    Dec 28, 2010
    Messages:
    22
    Country:
    United Kingdom
    Make sure that you are using the latest Wood software 1.40b as version 1.40 had a bug that caused the memory card to be wiped. I had the exact same problem as you, with a card from R4idsn.com.
     

Share This Page