RELEASE mtp-server-nx - Open Source USB file transfer for Switch

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by m4xw, Sep 2, 2019.

  1. uyjulian

    uyjulian Homebrewer

    Member
    9
    Nov 26, 2012
    United States
    United States
    Use Android File Transfer or mtpfs
     
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Depending on the homebrew it could help to move stuff into folders if you have a lot of files on the root, also you can mark folders as hidden that don't need to be seen by homebrew, but I'm not sure if any homebrew actually respects the hidden flag.
     
  3. Sticker

    Sticker Advanced Member

    Newcomer
    3
    Oct 1, 2018
    Vietnam
    Android File Tranfer only show No Android device found
     
  4. SethPDA

    SethPDA Member

    Newcomer
    2
    Oct 13, 2018
    Hungary
    Code:
    filesystem error: status: I/O error [sdmc:/Nintendo/save/8000000000000124]
    filesystem error: status: I/O error [/atmosphere/automatic_backups/XAJ70010578851_PRODINFO.bin]
    filesystem error: status: I/O error [/atmosphere/automatic_backups/XAJ70010578851_BISKEYS.bin]
    filesystem error: status: I/O error [/log]
    Any idea how to fix this?
     
  5. uyjulian

    uyjulian Homebrewer

    Member
    9
    Nov 26, 2012
    United States
    United States
    It's a known issue
     
    Slim45 likes this.
  6. fearlubu

    fearlubu Newbie

    Newcomer
    1
    Jan 6, 2013
    United States
    Where exactly do I put these files? I'm new to the switch hacking scene and don't quite understand how to get this to work.
     
  7. RisingHopperZeroOne

    RisingHopperZeroOne Advanced Member

    Newcomer
    2
    Jul 31, 2019
    Australia
    Is the slow transfer speed a limitation of mtp?
     
    Last edited by RisingHopperZeroOne, Sep 13, 2019
  8. Kupie

    Kupie GBAtemp Regular

    Member
    4
    Jun 9, 2013
    United States
    MTP will always go slower than direct SD card read/writing from a PC.

    You put it in SD:\switch\, and you can then launch it from the homebrew launcher. After doing so, plug the Switch into your PC and it'll show up as an MTP device like your phone would.
     
  9. garco

    garco Member

    Newcomer
    5
    Jun 28, 2006
    Italy
    New Version Crash always, I'm on Atmos 9.4 emu 9.0
     
    mathew77 and aarti like this.
  10. RisingHopperZeroOne

    RisingHopperZeroOne Advanced Member

    Newcomer
    2
    Jul 31, 2019
    Australia
  11. Bowthorpe123

    Bowthorpe123 Member

    Newcomer
    1
    Sep 13, 2019
    United Kingdom
    Is there anyway to use this on 9.0.

    My SD card shows up, but then when I go to browse, Atmosphere blue screens.

    any other Homebrew that does a similar job that works?
     
  12. danfozzy85

    danfozzy85 Member

    Newcomer
    2
    Nov 18, 2018
    Barbados
  13. seeWood

    seeWood Member

    Newcomer
    1
    Jul 11, 2019
    Germany
    use Version 1.0! the Bluescreen Bug only exist in 1.1
     
  14. kornjaca200

    kornjaca200 Advanced Member

    Newcomer
    4
    Mar 2, 2017
    Netherlands
    But that one isn’t updated for 9.0
     
  15. seeWood

    seeWood Member

    Newcomer
    1
    Jul 11, 2019
    Germany
    thats right, but it works very well in 9.0.0 atmosphere because the workaround from SciresM is working very well too;-) give it a try.
     
    danfozzy85 and kornjaca200 like this.
  16. Bowthorpe123

    Bowthorpe123 Member

    Newcomer
    1
    Sep 13, 2019
    United Kingdom
    Sorry what workaround is this?
     
  17. octopus

    octopus Custom Title

    Member
    4
    Sep 6, 2013
    Somalia
    /
     

    Attached Files:

    hippy dave and danfozzy85 like this.
  18. seeWood

    seeWood Member

    Newcomer
    1
    Jul 11, 2019
    Germany
    SciresM has figured out how things go in 9.0.0 and adds a mitm that fixes the HID initialization issue

    so the Devs have more time to update and 1.0 works great again on 9.x ;-)
     
    Last edited by seeWood, Sep 22, 2019
  19. Bowthorpe123

    Bowthorpe123 Member

    Newcomer
    1
    Sep 13, 2019
    United Kingdom
    I’ve tried 1.0 and nothing launches, just get a black screen on 9.0 latest atmosphere
     
  20. seeWood

    seeWood Member

    Newcomer
    1
    Jul 11, 2019
    Germany
    It should work in latest ams. all drivers are installed?
     
Quick Reply
Draft saved Draft deleted
Loading...