MT-Card manual update with game?

Discussion in '3DS - Flashcards & Custom Firmwares' started by RyviusRan, Feb 25, 2015.

  1. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    I updated to 9.5 without realizing it disabled the select button for game selection.
    I forgot to back up my emunand so I had to go back to 4.2.

    Is there a way I can update it back to at least 8.0?
    I have a retail Monster Hunter 4 Ultimate cart, would I be able to use that to manually update it?
     


  2. rickycoe123

    rickycoe123 GBAtemp Fan

    Member
    389
    29
    Jun 23, 2014
    http://3ds.essh.co/

    Check which games run on your desired firmware and use one of them to update.
     
  3. sALMAn84

    sALMAn84 Advanced Member

    Newcomer
    64
    21
    Jan 14, 2015
    Malaysia
  4. sALMAn84

    sALMAn84 Advanced Member

    Newcomer
    64
    21
    Jan 14, 2015
    Malaysia
    But you can update your emunand in classic mode using mh4u cart that you own. It contain 8.0 firmware for us and 8.1 for eu. I'm prefer at least 9.0, so I can used theme.
     
  5. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    But how do I do that?
    I inserted the game cart while in classic mode but was given no option to update my emunand.
     
  6. sALMAn84

    sALMAn84 Advanced Member

    Newcomer
    64
    21
    Jan 14, 2015
    Malaysia
    sorry never try to update using classic mode before, never had retail cart thats has 6,7 or 8 firmware before. Can you do that in normal mode not the classic mode? Try enter normal mode then eject mt-card and put mh4u cart.
     
  7. sALMAn84

    sALMAn84 Advanced Member

    Newcomer
    64
    21
    Jan 14, 2015
    Malaysia
    When in classic mode with mh4u cart are inserted, did you try to run the game and it never asked you to update the firmware?
     
  8. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    With the mh4u cart inserted in classic mode I run the game and it doesn't ask to update the firmware.
    It just starts the game but stays on a black screen because the game won't run on emunand 4.2 which is what I currently have it on.
     
  9. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
  10. sALMAn84

    sALMAn84 Advanced Member

    Newcomer
    64
    21
    Jan 14, 2015
    Malaysia
    So it seem that mt-card owner like me cannot update emunand using retail cart even in classic mode unlike gateway which you can disable firmware spoofing so you can update emunand using rom or retail cart.

    The only choice is to update using cia. It's very easy to update emunand using cia just make sure to read and follow the tutorial properly.

    Or wail until MT-Card 9.5 update is release. The other way maybe using gateway launcher to create emunand, I'm not so sure whether gateway emunand works or not with mt-card, others say it works.
     
  11. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    I am a bit confused as I never mess with cia stuff before.
    Seems like these tutorials already linked here assume that I have installed something called devmenu.
    I have the update files which were in a zipped fw3DS-csv file.
    But the link VerseHell posted says that the update files contains updates for the new 3DS as well and to remove them but I don't see where those files are.
    It seems the numbers they give that have a "2" in them look like something you get from opening a file in a hex editor.
     
  12. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    - First if you don't have it, install Python 2.7 (and only 2.7) and add it to your path
    - Download make_cdn_cia.exe and put it on the UpdateCDN folder
    - Extract the fw3DS-csv zip file and put the csv of the firmware you want in the UpdateCDN folder (ex : 9.2.0-20.csv)
    - Hold Shift, Right click on the UpdateCDN folder an choose Open Command Window Here
    - type
    Code:
    UpdateCDN.py -USA 9.2.0-20.csv
    After that you can follow the rest of the tutorial. For 4/5/6 step, you can just use the 3ds version of BigBlueMenu instead (you should easily find it). And be sure to be on the emunand before starting the installation.
     
  13. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    I did what you said and under 9.4.0-21/USA I have two folders now.
    One is for cia and the other is raw.
    The cia folder has all the update folders but none of them have anything inside of them.
    The raw folder has all the update folders as well but has data in each of them.
    The tutorial you gave me seems to assume that I already have data in the cia folder for each update when I have none.

    This is what I currently have in the in the raw folder.
    [​IMG]
     
  14. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Did you put make_cdn_cia.exe on the right folder?
     
  15. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    seems like chrome is blocking me from download the file because it thinks it is harmful.
     
  16. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    Also I already had a make_cdn_cia file in the folder when I extract the UpdateCDN file from one of the links provided here.
     
  17. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    The make_cdn_cia provided is for mac/linux, not windows.
    Download FunkyCia2, and get make_cdn_cia.exe from it.
     
  18. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    ok it worked now.
    I am currently on 4.2 firmware for emunand.
    Do I have to install each update beyond that or do I have to install each .cia for each update in order from oldest to newest?
    I've already made sure to delete the new 3ds files.
     
  19. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    You have to install all the cias from 6.0 to 9.4 (excpet the n3ds one).
    It's easier if you put them all into one folder like the tutorial said.
     
  20. RyviusRan
    OP

    RyviusRan Advanced Member

    Newcomer
    64
    2
    Jan 14, 2010
    United States
    Ok I put them all in one folder and selected to import all cia in that folder.
    I was in emunand when I loaded the bigblue menu so I assume I am safe.