Moonshell2 issue/error

Discussion in 'NDS - Emulation and Homebrew' started by Nimbus, Jan 22, 2010.

Jan 22, 2010

Moonshell2 issue/error by Nimbus at 5:05 PM (2,031 Views / 0 Likes) 2 replies

  1. Nimbus

    Member Nimbus sudo /usr/bin make-me-a-coffee --nosugar --cream=1

    Nov 1, 2009
    Probably being lazy.
    United Kingdom
    Help, I am having some issues with moonshell.

    Whenever I boot it up, it attempts to load but after 1-2 seconds on diskcheck it spits out this error

    Can not handle disk format

    Disk size is too large, or
    cluster size is too small

    Recovery method:
    Try to reformat the card with a bigger cluster size.

    Application terminated.

    I'm using Moonshell 2.06 (Yes, I know it's outdated but I'm using an outdated version for a reason)
    My flashcart is a AK 2.1 (Genuine)
    I'm running AKAIO 1.5.1 and Official FW 4.21 (Used as one of my loaders)
    My MicroSD card is a PNY 8GB Class 4 (I know it's not the brand, storage size or class that is at fault as it works just fine in my M3DS Real.
    I have not DLDI patched Moonshell2 with the AK2.1 DLDI file (Do I need to do this, I thought AKAIO had auto DLDI patching)

    What is wrong? This is the same cluster size I have been using for ages on my M3DS Real with the same version of Moonshell2 (2.06), and it worked just fine on that. Why is it doing this on my AK2.1 (Running AKAIO+Official FW 4.21)? If it worked with the same cluster size as I used before on my M3 Real (Set to 32KB cluster size in Panasonic SD card formater), then why is it now deciding to not work with it on my AK2? This is what makes this error not make sense to me.

    have also tried using the official firmware and it does the exact same thing.

    I've tried deleting logbuff.txt or whatever that file is, as I have heard that is often the cause of errors, but it doesn't fix anything.

    So, if anyone could inform me as to what is wrong here if it really is the cluster size then I'm still going to be confused, as it hasn't changed at all since I used this with my M3DS Real (I always have set it to 32KB cluster size)

    At the same token I don't wanna bork my AK2's ability to load other stuff, or load at all.
  2. twiztidsinz

    Member twiztidsinz Taiju Yamada Fan

    Dec 23, 2008
    United States
    Don't hold me to it, but I believe the worst that will happen if you format your card correctly (meaning the format succeeds with no issues) but with incorrect settings is the card won't read it and you'll have to format it again with the correct ones.
    That is what SHOULD happen, but there is pretty much always a difference between what SHOULD and what DOES happen.
  3. jalmj

    Newcomer jalmj Newbie

    Dec 14, 2009
    United Kingdom
    I had same problem with my Acekard 2i. Solved it by emptying all files from my 8gb micro sd into a folder on my desktop. Then reformatted the micro sd card. Then added AKAIO 1.5.1 and Moonshell2 (including .nds files of course) onto the micro sd (4 files in all at this point). Then added the dpg files and transfered my games back onto the micro sd card. Worked a treat [​IMG]

Share This Page