Hardware Mayflash Magic-NS adapter LED isn’t lighting up / controller not working.

EddieGames

Member
OP
Newcomer
Joined
Jul 12, 2019
Messages
7
Trophies
0
Age
20
XP
113
Country
United States
I’ve looked everywhere on Google but can’t find an answer, I’ve asked on Reddit and that didn’t help, how do I fix this?
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
41
XP
1,870
Country
United States
If you're holding down the button on the side and nothing is lighting up whie it's plugged into Switch or PC, you have a dead product. Get a refund if you can or if you've had it awhile you'll have to buy another.
 

EddieGames

Member
OP
Newcomer
Joined
Jul 12, 2019
Messages
7
Trophies
0
Age
20
XP
113
Country
United States
If you're holding down the button on the side and nothing is lighting up whie it's plugged into Switch or PC, you have a dead product. Get a refund if you can or if you've had it awhile you'll have to buy another.
Are you sure it’s dead? It was working just fine like a month ago, and the controllers turn on when I plug them into the adapter, I just can’t figure out why the controller’s input isn’t working. I think it might just be the LED that’s dead.
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
41
XP
1,870
Country
United States
They're cheaply made and they die all the time, just look on the Amazon reviews. With all due respect they're $20 not $100 and you get what you pay for. You'll probably have to buy another one, and get the warranty next time. I'm only assuming you didn't or else you would be able to just get another one for free.

If it was just the LED it should still sync your controller but since it's not I don't see how it's the LED.

I actually just bought one myself for both my Switch and Wii U, but I'm not going to be shocked if it dies on me also.

If it's working only when plugged in there's something wrong with the wireless part of it.

There's not much troubleshooting in it it either works or it doesn't for the most part and it's obviously not working.
 
Last edited by EmulateLife,

ploggy

WAKA! WAKA!
Member
Joined
Aug 29, 2007
Messages
4,399
Trophies
2
XP
6,589
Country
United Kingdom
You can try flashing a firmware update to see if it helps ?
http://www.mayflash.com/Support/Download/

Update the Software
If you are having problems with the adapter, you can follow the below instructions to update the software.
1. Download the software from http://www.mayflash.com/Support/Download/ and install it on your Windows system.
2. Double click on the updater and leave the updater window open on your screen.
3. Connect the USB from your adapter into any spare USB port on your PC.
4. Please make sure your adapter is in the Nintendo Switch or PS3/Dinput mode (The LED indicator is in Red or Blue). If not, please switch the adapter to the Nintendo Switch or PS3/Dinput mode by pressing and holding the button located at the side of the adapter for 3-5 seconds.
5. As soon as the adapter has been recognized (LED indicator turns off), select “Update”.
6. Do not disconnect the device until you are informed that the updated was completed successfully.
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    M4x1mumReZ @ M4x1mumReZ: 200 degrees fahrenheit. It's burning at the speed of light. +1