Mark this forum as read...

Discussion in 'Site Discussions & Suggestions' started by cory1492, Dec 13, 2007.

  1. cory1492
    OP

    cory1492 GBAtemp Maniac

    Member
    1,497
    24
    Jun 23, 2005
    Canada
    Home, WhereElse?
    Mark this forum as read, a nice handily little button.

    Here (gbatemp) it keeps kicking me out of the forum and back to the portal when used in subforums... is this intended, something that only occurs to a dedicated firefox user, or is anyone else annoyed by this?

    I mean, I already looked at the front page before I went into the forum, is there any reason the server should be building it for me again ([ DB Queries: 17 ] [ Execution Time: 0.7315 ]) when all I want to do is stay in the forum, but mark the topics as read?
    [​IMG]
    Told ya it was a little teeny tiny gripe...
     
  2. Ace Gunman

    Ace Gunman ~••Lucky҉Shot••~

    Former Staff
    6,385
    18
    Apr 17, 2003
    Canada
    Wassamatta U
    Nah, happens to me too. I think it's how the feature is supposed to work. Either way, is a bit annoying. I use the feature quite often to check off areas I've fully moderated. In fact, after this post I'm going to check off this forum again as well. [​IMG]
     
  3. mthrnite

    mthrnite So it goes.

    Former Staff
    4,529
    944
    Jun 30, 2006
    United States
    th' south
    Happens in OmniWeb too, so, not a Firefox thing...
    .. it's not a bug, it's a FEATURE, lol.
     
  4. cory1492
    OP

    cory1492 GBAtemp Maniac

    Member
    1,497
    24
    Jun 23, 2005
    Canada
    Home, WhereElse?
    Just to illustrate why I believe there is a script error somewhere along the way and thus bothered to mention it...

    Going to:
    GBAtemp Forum > Nintendo DS Discussions > NDS - Flashing Hardware and Software > M3 Adapter
    http://gbatemp.net/index.php?showforum=91
    Clicking "mark as read" kicks it back to the portal (I presume it tries to find something, can't, and goes back to the regular domain... not that I have ever had access to whatever logging IPB gives though [​IMG] )

    But... going to (where there are posts down below the subforum list):
    GBAtemp Forum > Nintendo DS Discussions > NDS - Flashing Hardware and Software
    http://gbatemp.net/index.php?showforum=40

    kicks it back to (where there are no posts down below the subforum list):
    GBAtemp Forum > Nintendo DS Discussions > NDS - Flashing Hardware and Software
    http://gbatemp.net/index.php?showforum=37

    The "mark forum as read" in both instances have a link that is constructed like thus:
    http://gbatemp.net/index.php?act=Login&CODE=04&f=40

    So yeah, if it's a "feature" then it is implemented in a very retarded fashion as it doesn't often do what it is supposed to. I'd bet though, that there is a db inconsistency (from some previous update) which breaks how it is actually supposed to work.
     
  5. cory1492
    OP

    cory1492 GBAtemp Maniac

    Member
    1,497
    24
    Jun 23, 2005
    Canada
    Home, WhereElse?
    BIIIG bump...

    Just noticed what appears a dropdown box that provides "mark as read and return" or "* and return to index" and "subscribe to this forum", the thing is the dropdown only seems to be in the GBATemp Lite forum skin (which I am loving, thanks guys for pointing that switch page again out a couple days back.) Only thing that makes me sad is that it took 4+ months for me to find a already present solution [​IMG]

    So if anyone else is annoyed by the same omission as myself, follow the above link and use the lite skin, mark as read and return works extremely well there [​IMG]

    Thanks GBATemp, a little late but it made my easter finding that little egg [​IMG]