Mario Kart Save Data Not Working w/ VC Inject

Discussion in 'Wii U - Hacking & Backup Loaders' started by Overwrite_Pixel, Jul 10, 2019.

  1. Overwrite_Pixel
    OP

    Overwrite_Pixel Member

    Newcomer
    2
    Mar 25, 2017
    United States
    Hi! I'm going to try to make this post as short as I possibly can.

    So, I dumped a whole lot of my Wii games and injected them as VC titles. Since I have already played the games on my old Wii and I already did a system transfer, all of my save data was on the vWii. All of my games picked up the save data just fine, but Mario Kart Wii didn't.

    Its strange, considering that when I put the disk into the Wii U and launch it from there, the data loads perfectly fine. But when I launch it from the VC icon, it creates a whole new save file as if my pre existing one didn't exist.

    Now, does anyone know how to go about fixing this? I would prefer not to start from scratch on this game, since I put a lot of work into it.

    Thanks!
     
  2. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    If nothing else you could use SaveGame Manager GX to get the Wii save then use the same program to put the save on your vWii.
     
  3. Overwrite_Pixel
    OP

    Overwrite_Pixel Member

    Newcomer
    2
    Mar 25, 2017
    United States
    But that's the thing -- the save is already on the vWii. It just creates a new one because it doesn't pick it up for whatever reason.
     
  4. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    Try SaveGame Manager GX anyway. It's your only other option of getting it to work and delete the save that's already on the vWii. You can't magically make a save work that won't work.
     
  5. Overwrite_Pixel
    OP

    Overwrite_Pixel Member

    Newcomer
    2
    Mar 25, 2017
    United States
    Alright, I'll give it a shot! I'll report back once I do.
     
  6. Overwrite_Pixel
    OP

    Overwrite_Pixel Member

    Newcomer
    2
    Mar 25, 2017
    United States
    Alright, reporting back from playing around with SGMGX -- none of my Wii saves are showing up in the program, so there's not much I can do with it. I'm not sure if I'm just using it wrong or what...

    Edit: Nvm I downloaded and used the wrong file. Save games are showing up now, but I've hit two stumps. 1) There are two identical saves and there's no way I can tell which one is my old one and which one is the one the VC title created and 2) extracting saves only throws me an error. I'm not sure if it has to do with it trying to extract it to this "usb8:/" dictionary.
     
  7. Overwrite_Pixel
    OP

    Overwrite_Pixel Member

    Newcomer
    2
    Mar 25, 2017
    United States
    I got to the bottom of it! It was actually a silly mistake I made on my end. Turns out I foolishly dumped and injected the wrong copy of MK Wii. The one I dumped was a European copy (I couldn't return it and at the time my Wii was region locked so I got a US copy and just let the EU one sit around the house and collect dust). Because my saves were made by my US copy, the VC inject didn't recognize them and made a whole new save file. I dumped and injected my US copy and now my save data works!

    Anyhoo, thank you so much for trying to help, @EmulateLife!
     
    Last edited by Overwrite_Pixel, Jul 11, 2019 at 4:41 AM
Loading...