M3 Simply - dead?

Discussion in 'NDS - Flashcarts and Accessories' started by Lancer, Jun 16, 2008.

  1. Lancer
    OP

    Lancer Member

    Newcomer
    22
    0
    Dec 25, 2007
    Did M3 stop supporting firmware updates for the Simply chip?

    I got confronted with "No cartage found" problem when trying to play a game.

    Do I have to buy a new one?! As I can't find any "latest" download for M3 Simply at all...
     
  2. ojsinnerz.

    ojsinnerz. Damned

    Member
    3,152
    7
    Oct 27, 2007
    Canada
    Canada
    It gets updates whenever the R4 gets one. So if the R4 doesn't get one, the M3 doesn't either.

    You COULD get a new cart... There's lots of good choices for under 24 bucks. And they're all better than the R4/M3 simply.
     
  3. Lancer
    OP

    Lancer Member

    Newcomer
    22
    0
    Dec 25, 2007
    But all I want to do is to get support for the new games [​IMG]

    But I can't find any update anywhere?
     
  4. Calafas

    Calafas GBAtemp Fan

    Member
    341
    1
    Mar 29, 2008
    England
    I'm using 1.14 Firmware, and it plays the new games fine. Loving Soul Bubbles [​IMG]
     
  5. Lancer
    OP

    Lancer Member

    Newcomer
    22
    0
    Dec 25, 2007
    Link? I can't find it anywhere
     
  6. ojsinnerz.

    ojsinnerz. Damned

    Member
    3,152
    7
    Oct 27, 2007
    Canada
    Canada
    I believe GBAtemp download section has it. Not too sure though.
     
  7. Calafas

    Calafas GBAtemp Fan

    Member
    341
    1
    Mar 29, 2008
    England
  8. Lancer
    OP

    Lancer Member

    Newcomer
    22
    0
    Dec 25, 2007
    Nope they didn't ... boy are those updates old! when did the M3 simply fall really..



    Oh on the wiki thanks haha.. sorry :x
     
  9. Mr Noob

    Mr Noob Banned

    Banned
    9
    0
    Aug 20, 2008
  10. Toni Plutonij

    Toni Plutonij *has TrolleyDave & tiny p1ngy on moderating shelf!

    Former Staff
    8,153
    314
    Dec 22, 2007
    Croatia
    Depths of Nuclear powerplant
    You can use YSmenu....IT works on R4 and M3 Simply, it's kinda uglier than official firmware, but it plays the newer games...has far better compatibility..
     
  11. Swip

    Swip GBAtemp Advanced Fan

    Member
    557
    0
    Jan 29, 2008
    Try using YSMenu , I think its using the DSTT loader which gets updated and works with the newer games.
     
  12. Sjaool

    Sjaool Advanced Member

    Newcomer
    52
    0
    Aug 19, 2007
    Netherlands
    Noordoostpolder
    LinfoxDomain always a good resource for all your firmwareneeds. [​IMG]