M3 Lite broken?

Discussion in 'GBA - Flashing Hardware and Software' started by angahith, May 5, 2013.

  1. angahith
    OP

    angahith Newbie

    Newcomer
    3
    0
    Jan 30, 2008
    Gambia, The
    Hey guys,

    I recently found my old GBA SP and my M3 Lite again (I mostly used it for DS games back in the day) and thought it's time to finally play some of the GBA games I meant to play for ages.

    Now here's the problem. No matter if the games are patched or not, they always seem to run fine for like... maybe half an hour. After that, things go haywire. Sometimes it's just graphical or audio glitches, but sometimes the game plain locks up.
    I either case, it's pretty obvious that the game data the cart loads into its ram somehow gets corrupted.
    And this happens with every game I tried.

    Did anybody else ever experience this and possibly has a solution for it, or should I accept the fact that I have to get a new cart?

    Thanks
     
  2. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,935
    263
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    normal after long periods of no use. Sometimes it also means you need to replace the battery as well.


    ---

    Some older gba flashcarts use the battery as a circuit as part of the flashcart. A dead battery is the same as a short in the circuit making some games crash when trying to access the SRAM
     
  3. angahith
    OP

    angahith Newbie

    Newcomer
    3
    0
    Jan 30, 2008
    Gambia, The
    Hurm, battery voltage's fine. And it happens completely randomly. Has nothing to do with accessing the SRAM. In fact saving still works after the errors occurred, as long as the game didn't freeze complete.

    I don't quite see how this would be normal, then.

    Actually... thinking back, I think the one or two times I tried playing GBA games back then, this happened too and this is why I never used it.

    I guess I'll try to check if any contacts are bad, that can be resoldered.
    Considering this happens after a while, i.e. after the cart gets warm a bit, a bad soldering point isn't out of the question.

    I just wondered if other people had this issue too with the M3 Lite.