[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. Deathscreton

    Deathscreton GBAtemp Advanced Fan

    Member
    5
    Oct 1, 2009
    United States
    So I'm trying to get the Switch to stop asking if I want to update when I start a game, but the instructions on the first page didn't work. Has anyone else had these problems?

    EDIT: Nevermind. User Boa posted this:

    Worked for me!
     
    Last edited by Deathscreton, Feb 3, 2018
  2. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    13
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Celeste is pretty much 4.1.0 required due to being an eshop title. Great game by the way for those on 4.1.0
     
    B4rtj4h likes this.
  3. Nah3DS

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    10
    Feb 9, 2010
    Argentina
    Does anyone knows if this release list http://nswdb.com is trustworthy?
    It has a couple of differences with our list, e.g. Tiny Barbarian DX is listed as 2.3.0

    I can confirm that it asks for update on my 2.2.0 Switch. But that's all I know.
    If it's true, I would gladly update to 2.3.0 just to be able to play 1 more game on my Switch.
     
  4. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    As far as I know (can’t confirm it now while I only have One on 3.0.0 and 4.1.0) this is as it was back then.
     
  5. albion

    albion Member

    Newcomer
    1
    Oct 31, 2017
    Switzerland
    Does need Snipper Clips PLUS Cartridge Version 000 to update FW 3.0.1, I'm right?
     
  6. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    You are right! :)
     
    albion likes this.
  7. Nah3DS

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    10
    Feb 9, 2010
    Argentina
    I compiled a list using the nswdb.com release database. I listed only the games that are missing on gbatemp's list, and also the ones that have a different firmware requirement (those with * before their names).
    Warning: Spoilers inside!
    Maybe this list could be useful to reconfirm some of the games.
     
    B4rtj4h likes this.
  8. Resaec

    Resaec GBAtemp Regular

    Member
    2
    Dec 19, 2017
    Germany
    That could be added to B4rtj4h's "Games required Firmware" thread. (if they aren't already)
    For all the cartridge revisions I have a thread listing all (to me) known revisions.
    So ppl only need to use the search function ;)
     
    Nah3DS and B4rtj4h like this.
  9. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    I will compare this when I am at home and fill them in!

    EDIT: What was missing I filled in. What I had different and what I tested myself I let out... Troll and I is definitely NOT 1.0.0!
     
    Last edited by B4rtj4h, Feb 6, 2018
    Nah3DS likes this.
  10. Nah3DS

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    10
    Feb 9, 2010
    Argentina
    Great job maintaining the list and preventing accidental updates!

    Yeah, I found it weird they listed Troll and I as 1.0.0.
     
  11. Sabaku.D.Tonio

    Sabaku.D.Tonio Member

    Newcomer
    3
    Aug 19, 2008
    France
    Hi, any news about the minimum firmware required for Portal Knights (the physical copy just came out today)?
     
  12. dyerseve

    dyerseve Member

    Newcomer
    2
    Oct 11, 2013
    United States
    Anyone know about Dragon Quest Builders min firmware? I'd be willing to bet it's sub 3.0 but wanted to check before I attempt to launch it.
     
  13. Rauliki

    Rauliki GBAtemp Regular

    Member
    1
    Oct 24, 2016
    Poland
    Check the launch date of the game kart and system version available at that time. If it was close, game could be version-1.
     
  14. dyerseve

    dyerseve Member

    Newcomer
    2
    Oct 11, 2013
    United States
    That's why I asked, it was released yesterday. nswdb doesn't seem to have it yet, I'm very patient so i can wait but my wife isn't so patient. lol
     
  15. Rauliki

    Rauliki GBAtemp Regular

    Member
    1
    Oct 24, 2016
    Poland
    If it was released yesterday it would need newest firmware.
     
  16. B4rtj4h
    OP

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Does not work on 3.0.0. Works on 4.1.0. Tested today with secondhand cartridge. Serial on cartridge version 000.

    — Posts automatically merged - Please don't double post! —

    My guess is around 4.0.0. But can not confirm.
     
  17. ru5t

    ru5t Newbie

    Newcomer
    1
    Feb 12, 2018
    Italy
    hello everyone!
    i have a mario odissey cart PAL 001 -> it requires to update to 3.0.2.
    i didn't find this info on the forum, so it can be useful to everyone.

    bye
     
  18. Resaec

    Resaec GBAtemp Regular

    Member
    2
    Dec 19, 2017
    Germany
    See "Cartridge information collection", Mario is out quite some time and listed there.
     
    B4rtj4h likes this.
  19. panther666

    panther666 GBAtemp Regular

    Member
    1
    Nov 29, 2015
    Serbia, Republic of
    What version of software Monopoly require?
    I am on 3.0.0 and game asked me to update.
     
  20. ru5t

    ru5t Newbie

    Newcomer
    1
    Feb 12, 2018
    Italy
    ah... so please mods stick it !
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice