Issues with 9.2 N3DS and CFW

Discussion in '3DS - Flashcards & Custom Firmwares' started by ActuallyKoroSensei, Jan 15, 2016.

  1. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    So I'm new here.

    Anyway, I've had my Hyrule Edition 3DS XL for a few months now. I play it almost every day. Few weeks ago I ordered the Sky3DS because I heard a lot about it and at that time could not afford anything. So I ordered it, waited 3 weeks and finally put it to good use.

    I remembered that Ninjahax was still a thing, but my 3DS was on 10.3.0 28U. I wanted the Smash DLC since you can't transfer NNID between 3DS systems and I HAD the DLC on my original account. So I downgraded from 10.3 to 9.2.0 20U without any bricks or mishaps and continued with the Ninjahax setup (btw, I'm either running Ninjahax 2 or 2.5 as I see BOTH versions when the loader does that file check thing). My next step was getting CFW. And that's where it hits the fan:

    PastaCFW - Does not work. Tried 3 different versions (Lastest beta3, previous 1.2.1, and 0.1.4), they either froze when trying to reboot, forcing me to hard reset, or didn't boot at all. I had all the 3=.3DSX and corresponding files int he correct locations on the MSD card.

    Cakes - Does not work. Gave me an error about the files being unreadable.

    rxTools - Does not launch via HBL or through the web browser. From HBL it gives me a splash screen on the top screen and stays like that until I hard reset.

    Rei - Haven't tried yet

    miniPasta - SOMEWHAT worked. After beginning a tutorial for rxTools I went to install a CIA which never worked before. It was able to install so I rebooted with miniPasta and bam! I was able to use FBI and BBM straight from the home menu.

    FBI/BBM - After I installed an FBI cia from the HBL version of FBI, I went to transfer some Smash cia and after I quit MSD management and rebooted into miniPasta, nothing I installed was showing up despite being rebooted into miniPasta. So I decided to try booting from the standard PastaCFW loader. It rebooted to my amazement but still nothing showed up. I tried installing CIA files from the HBL FBI but I got an error about 'Title Not Found' when I installed to the SD card and a successful installation when installing to NAND but nothing showed up after rebooting into either miniPasta or PastaCFW. I see where it installed them because whenever I reboot I see 3 white blocks that vanish about 3-5 seconds after reboot.

    Sorry for this whole thing. Any help would be appreciated!
     
  2. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    Your downgrade did not complete from the sounds of it. There is a homebrew that is designed to check the downgrade to see if it completed fully. I don't know the name but you should get and run it.

    In addition, no matter where you got your downgrade pack from, it is technically incomplete because it is essentially just the original upgrade pack for that FW. Unfortunately for N3DS users, there are two titles that were not included in 9.0/9.2 update packs but that DID get updated in later revisions. I suggest you check the thread in my signature for details and consider locating and installing the proper versions of those two files.
     
  3. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    Okay, so I followed the ReiNand thing and finally got somewhere. I have both SysNAND and EmuNAND working and have my NAND backed up to my PC. I also did the FBI inject to H&S tutorial but whenever I boot into emuNAND and try to install CIAs from the injected FBI H&S app I get a 'Title_Not_Found' or an invalid signature error despite being on Rei9.2.0 20U.
     
  4. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    Sounds like the signature checks arent getting patched? That's weird.
     
  5. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    Any ideas? I'm gonna try to install the Smash 1.1.3 DLC to the SysNAND instead of SD since SD gives me the aforementioned errors.

    UPDATE - It seemed to install fine to the SysNAND with no error. Going to try and install the Cloud DLC next

    UPDATE - The DLC also installed fine to the SysNAND. Will post if something goes wrong.

    UPDATE - Despite both being installed successfully, neither seem to show proof of said installation. Smash still asks for the latest update and upon launching it I get no 'Cloud has joined the battle' or 'You got the so and so costume' popups.
     
  6. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    Okay, so now I have a problem. I wanted to switch the theme I was currently using. I remember reading that you shouldn't use the build in theme manager and instead use CHMM. So I did that and bam, can't use menuhax anymore! Great! System auto boots to SysNAND and the only way I can get back to EmuNAND and Reinand is via Ninjahax. I spent hours on this, I really don't want to redo it again. I know a common issue is your NANDS being linked but I did exactly what was said in the tutorial. And sometimes Reinand won't even boot, it will flash this line in the right side of the top screen and then stay black. I'm just going to let it sleep while it's still on EmuNAND.
     
    Last edited by ActuallyKoroSensei, Jan 15, 2016
  7. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    Ok, are your nands linked? Easiest way to tell is to turn off the device and take the sd card out and put it in the computer, then open the Nintendo 3DS folder. If there is only one folder present, your nands are linked.
     
  8. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    As I said, I followed the tutorial about wiping the system and unlinking the NANDS. They were unlinked before I changed the theme but now idk.
     
  9. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
    changing your theme disrupts menuhax unfortunately so you'll have to launch hbl through either browser exploit or some other exploit and reset up menuhax.
     
  10. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    Damn....is there any other way I can freely change themes without having to do this again?
     
  11. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
    well you can just use the normal theme changer settings in emunand, I once had black screen issue with running rxtools through menuhax until I changed my emunand theme to black which caused menuhax to not try to launch instead of rxtools.
     
  12. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    I managed to get Menuhax back but what if I have a custom theme that I wanted to apply to EmuNAND without breaking Menuhax, how would I go upon applying said theme?
     
  13. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
  14. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    Also, here's the error I get whenever I try and install any CIA to the SD/EmuNAND. The size shrunk for obvious reasons and I have around 700MB left on my EmuNAND and 300MB left on my SysNAND. I'm trying to install the 1.1.3 Smash update as well as the DLC for December 14th. I always get that error but when I install to SysNAND it always works but never shows, the game is never updated and the DLC never appears.
     

    Attached Files:

  15. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
    check to see if you have the title.db and other db file in the emunand folder under the Nintendo 3DS folder
     
  16. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    I do, inside a folder titled 'dbs' just as the tut said.

    Also, any idea why Reinand hates me? Sometimes it will freeze as soon as I press A. Sometimes it will say 'Start', load up, flash a line, and then freeze. Other times it will boot fully.

    — Posts automatically merged - Please don't double post! —

    Btw, I tried installing CHMM2 to emuNAND but still get this 'DESCRIPTION_TITLE_NOT_FOUND' error
     
  17. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
    in both folder under Nintendo 3DS folder? Did you go to data management settings and do the fix yet that pops up? It could also be that you downloaded a bad file or the file didn't download all the way.
    with the reinand problem I'm not sure as I don't use reinand.
     
  18. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    I double checked and for some reason one of the randomly numbered folders had 3 folders - exdata, dbs, and title. So I moved the 'title.db' from the dbs folder to the title folder. Will post after retry.

    UPDATE - Still getting Title Not Found
     
  19. Svaethier

    Svaethier GBAtemp Maniac

    Member
    1,303
    203
    Dec 2, 2013
    United States
    Sault Ste. Marie, Michigan
    the db files stay in db,go to settings,data management,3DS and do the fix that will pop up if you haven't after making the two db files in your emunand folder under Nintendo 3DS folder as that will fix your problem.
     
  20. ActuallyKoroSensei
    OP

    ActuallyKoroSensei Member

    Newcomer
    37
    0
    Jan 15, 2016
    United States
    Pennsylvania
    The fix about the files being corrupt and having to reset? I did that a while ago, whenever I go to the software section all my saves and stuff pop up, there's no error.