1. Amaymon

    OP Amaymon Newbie
    Newcomer

    Joined:
    Jan 27, 2021
    Messages:
    4
    Country:
    Portugal
    Hi all,

    First of all I’m very very very noob on the switch scene. I have a switch with sxcore since October last year. And I’m currently on FW11.0.0 and SXOS 3.1.0. For a few days now I have been trying to migrate from SXOS 3.1.0 to atmosphere without success.

    I’ve used All-i-One Switch updater, to update to atmosphere 0.17.1+hbl2.0.4+hbmenu3.4.0
    • But without emunand I got "ERROR Fatal error: [NXBOOT] Failed to mount eMMC!" as soon as the console reboots.
    • With emunand I can run Hekate but I have no option when I click when “Launch”.
    Also tried deepsea
    I run Hekate -> Migrate emuMMC -> Reboot -> and when I click on Launch CFW I get an black screen right after the first screen:
    **unfortunately i cannot add an image of the screen**


    Am i doing something wrong? May be a issue with the sd card?
    Im using a Micro SD SANDISK 128 GB Nintendo Switch version.
     
  2. GCS

    GCS GBAtemp Fan
    Member

    Joined:
    Sep 10, 2020
    Messages:
    441
    Country:
    Turkey
    Have you tried fusee-primary on Hekate (with EmuMMC created)?
     
    Last edited by GCS, Jan 27, 2021
  3. Amaymon

    OP Amaymon Newbie
    Newcomer

    Joined:
    Jan 27, 2021
    Messages:
    4
    Country:
    Portugal
    Hi.

    Just tried, and got the following error:
    FATAL ERROR : FAILED TO STAT STAGE2 (ATMOSPHERE/FUSEE-SECONDARY.BIN)
     
  4. kerelenko

    kerelenko GBAtemp Regular
    Member

    Joined:
    Jun 25, 2018
    Messages:
    237
    Country:
    United States
    Do not use all in one packages if you are not familiar with what is included.

    Follow the guide here https://rentry.co/mys8q

    You only need
    Atmosphere 0.17.1 files
    Fusee primary bin
    SX gear boot dat
    License.dat

    First step is you have to backup your 3.1.0 boot.dat and replace it with the boot.dat of sx gear.
     
    Last edited by kerelenko, Feb 18, 2021
  5. Amaymon

    OP Amaymon Newbie
    Newcomer

    Joined:
    Jan 27, 2021
    Messages:
    4
    Country:
    Portugal
    I did all the steps aside from the "exosphere.ini creation"

    I then migrated the emuMMC again (as i did a clean on sd before start) then i clicked on "Atmosphere CFW"
    After that i get the logo:
    HEKATE - IPL
    Custom NX Bootloader

    And after that. Black Screen.

    edit: you mention Fusee primary bin
    But that is not on the guide steps.
    I used fusee-secondary.bin
     
    Last edited by Amaymon, Jan 27, 2021
  6. Retroboy

    Retroboy GBAtemp Addict
    Member

    Joined:
    May 28, 2015
    Messages:
    2,646
    Country:
    United States
    your not having issues migrating from sxos, you simply arent setting up atmos properly.

    theres nothing about sxos that prevents you using atmos, you can run both side by side on the same sd card
     
  7. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    14,077
    Country:
    United States
    How is your SD card formatted?
     
  8. Amaymon

    OP Amaymon Newbie
    Newcomer

    Joined:
    Jan 27, 2021
    Messages:
    4
    Country:
    Portugal
    currently is fat32, i also tried with exfat
     
  9. urherenow

    urherenow GBAtemp Psycho!
    Member

    Joined:
    Mar 8, 2009
    Messages:
    3,812
    Country:
    United States
    Is your emummc raw, or file based? SX puts them all in sxos/emunand/ and names them boot0.bin, boot1.bin, full.00.bin, full.01.bin, etc.

    Nyx is supposed to move them and create emuMMC/emummc.ini.

    If raw, sector =0x2. If files, sector=0x0. nintendo_path=<whatever it should be>. You can point that to Emutendo. If Nyx already moved it, the new path is already in the .ini file. For example, my file based one got moved to path=emuMMC/SD00. Inside of SD00, there is a blank file called "file_based", and another folder called eMMC. This eMMC folder is where the nand files should be, named BOOT0, BOOT1, 00, 01, etc. This is also why you can't use the SAME emuMMC between sx and atmosphere/hekate at the same time. You would have to use your PC (and preferably a batch file or other appropriate script) to move and rename those files whenever you want to switch (again, you can point the .ini to Emutendo, and only worry about moving the eMMC files)

    Oh, and remember the file "file_based"? If you're using a partition, there should be a path emuMMC/RAW1, that doesn't need an entry in the .ini. In that folder is a 4 byte file called "raw_based". Just create a blank file, open it in a hex editor, and add: 02 00 00 00.

    At this point, you're looking at any other troubleshooting. Starting with out-dated software. Hekate is up to 5.5.4, with Nyx 1.0.1. Atmosphere is up to 0.18.0 (but has some cool commits under the hood if you build it yourself). Then, not knowing what you've installed, I'd say to grab BOTH the fusee and hekate packages from https://github.com/ITotalJustice/patches/releases, and put those on your card. At this point (freshly moving from sx to Atmosphere), I'll assume you haven't messed with themes or added ovlloader/tesla or any other modules with a boot2 flag. All of the above being good to go, try booting without a game card inserted.
     
    Last edited by urherenow, Feb 10, 2021
  10. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    14,077
    Country:
    United States
    Are you using the latest version of Atmosphere and Hekate if applicable?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Athmosphere, Migrating, Issues