1. Daroxx

    OP Daroxx Member
    Newcomer

    Joined:
    Jul 7, 2020
    Messages:
    36
    Country:
    Afghanistan
    Hey folks,

    since I have so many problems now I didn't want to spam the noob thread anymore. First of all I wanna thank everyone in here. The community around the switch homebrew scene seems pretty fucking nice!

    I'm new to all of this and I didn't understood everything yet, so bear with.

    I first checked for the correct sd-card and got myself a 128Gb Sandisk Extreme V30 A2, which wans't the cheapest and got recommended on some pages for the switch.

    I first started off with formating the sd-card to exFat (was recommended in the video guide). Then downloaded everything from sd . setup (hekate, atmosphere and some tools in one package). Installed everything , did my Nandbackup and loaded cfw from emuEMMC.
    But my only urge, while I wanted to have a hackable switch in the first place, was to play retro games and go for the emulation with retroarch. Well and here started the problem. Neither I could have tinfoil installed or run retroarch. Both gave me an error. I must confess, I didn't tried it w/o Applet Mode, since wasn't sure if this would cause any damage. Games worked fine when I copied them over to the sd-card and installed from there.

    When I posted in the noob thread about some problems with nca verficiation, ppl told me to format the sd-card in fat32 and get a clean atmosphere install via the files from github. Before I did that I installed checkpoint to get my save games copied (I ofc did try the new zelda :) ).

    Done everything and tried to run hekate as I was used from the previous installation. Well, I couldn't even boot into cfw due to no configurations in the hekate_ipl.ini. Found out that you have to write it yourself and even when now injecting fuseee payload I could boot directly into cfw. I did install everything as before (incognito, tinfoil, retroarch) and everything would start. Even now the installation via PC with tinfoil and nut went like a charm. But I soon realised that everyting I did was not in emuEMMC but in the systems Nand. And I read about traces of software and bans (never really intended to go online, but you can even install apps and games, so I thought I might go online some day --> ofc using incognito and 90dns). The only thing that didn't work was checkpoint. When I copied over my saves, opening the app would crash the system aswell. So no restore of the save game it seems.
    So I thought, when almost everything works in the original Emmc, I will give it another try and do everything as mentioned, but this time with the emuEMMC.

    So sdcard out, format and copying over the files. Inject hekate, do EMMC backup (takes like 3 mins longer with FAT32?!) and copied over the files for tinfoil and retorArch. But it doesn't work. When I try to run retroarch, I'm getting and error and the system crashs. When I try to install tinfoil I get an icon in the HB menu which looks like a waiting sign and I'm getting the error "the software can't be started". Tried it several times and it is always the same.

    And now I'm here, I have no idea what I did wrong or if the sd card is really the problem. I'd guess so, since everything worked when I was running it on the internal nand.

    I'm on the fw 10.0.4, using atmosphere 0.13 with the fusee bin from there. Using hekate - CTCaer mod v5.3.0 & Nyx v0.9.2.

    The only thing I want is to be able to install games via pc (tinfoil since that worked already) and getting retroarch to run snes, n64 and ps1 games (basicly only gran turismo 2). Is there a way to check if the card is really the problem or if smth else causes those errors). I mean when even the installation of tinfoil 8.0 fails, then I don't seem see this going to run in any way I want it .
     
    Last edited by Daroxx, Jul 17, 2020
  2. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    16,452
    Country:
    United States
    If you aren't presently using online play, there isn't much of a reason to be using an emuNAND. You could always restore a clean sysNAND backup and switch to an emuNAND later if you want to use online play in the future.
     
  3. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    15,559
    Country:
    United States
    How are you launching Retroarch? And which patches are you using?
     
  4. Daroxx

    OP Daroxx Member
    Newcomer

    Joined:
    Jul 7, 2020
    Messages:
    36
    Country:
    Afghanistan
    Hey mate. I did a full reinstall of atmosphere and retroarch but this time not via full package instead I installed everything one by one and it worked perfectly. Though I can't fully remember since I sold the device over a month ago and haven't gottan a new working one.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - installing, (errors, broken