Is my MicroSD dead?

Discussion in 'NDS - Flashcarts and Accessories' started by Kei-chan, Apr 4, 2008.

Apr 4, 2008

Is my MicroSD dead? by Kei-chan at 3:13 PM (953 Views / 0 Likes) 3 replies

  1. Kei-chan
    OP

    Newcomer Kei-chan Newbie

    Joined:
    Apr 4, 2008
    Messages:
    1
    Country:
    United States
    So, yesterday my EZFlash 3-in-1 finally came in, so I was eager to try the expansion RAM out with SNEmulDS. Sadly, whenever I started any game with the expansion RAM enabled in the emulator, it froze upon loading the game. Not the emulator, the game itself. So I switched my MicroSD to its weird little flash card thing that you slide it into, and replaced my version of the emulator with a newer one.

    I put my MicroSD back in my R4, and tried to load the emulator, only to have it lock up. Then, I tried turning my DS on and off, and everytime, my R4 freezes where it says "Loading..."

    I tried putting my MicroSD back in my computer, and now it simply doesn't detect it. This has me really panicked, as I was near the end of FF3, about two seasons into Rune Factory, and I had a buttload of progress in a bunch of games that is, possibly, now lost. This REALLY pisses me off because my MicroSD is barely two months old.

    Is it broken? Has anyone else experienced this? What the hell do I do?

    I've been putting it in and out of the flash card reader for almost the whole time since it screwed up, and it just... doesn't work. I lost the USB MicroSD adapter, but my friend is going to let me use hers later today, so that might be the problem. But it's weird that my R4 is freezing on the loading screen. I've had no prior issues like this, so...
     
  2. arctic_flame

    Member arctic_flame GBAtemp ATMEGA8 Fan

    Joined:
    Nov 4, 2006
    Messages:
    2,840
    Location:
    England land
    Country:
    United Kingdom
    Try (in any order): A few readers/adaptors, a few USB ports, a UNIX based OS, and some data recovery tools. It's unlikey that your card is dead, just corrupted by a dodgy reader. If you get it to be recognised, you should be able to get your saves back.
     
  3. Fieryshadowz

    Member Fieryshadowz GBAtemp Fan

    Joined:
    Feb 27, 2007
    Messages:
    398
    Country:
    United States
    Yeah your MicroSD could possibly have died on you. . .
     
  4. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    If possible, try formatting the memory card with a phone or camera; that sometimes works when Windows won't touch the card.
     

Share This Page