Is it worth me upgrading my Ezflash V

Discussion in 'NDS - Flashcarts and Accessories' started by azeluk, Nov 29, 2013.

  1. azeluk
    OP

    azeluk Advanced Member

    Newcomer
    54
    0
    Jan 18, 2010
    So I have an original ezflash V NDS cart this thing has never failed me plays pretty much everything apart from pokemon Black and white 2 but I'm looking for a patch for those (if any one can help).

    I'm planning on upgrading my dsl to a 3ds in the future but I'm not to sure when is there any point of me upgrading to a newer card like the dstwo or is it worth waiting until 3ds roms appear and a flash card that can actually plays them on the 3ds comes out.

    Azel
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,867
    9,780
    Nov 21, 2005
    United Kingdom
    The original EZ5 will not work on the DSi or 3ds. Similarly it will not support SDHC or several of the newer games as they stopped updating it, I believe there is a patch somewhere but I tend not to follow pokemon related things. Some day I might actually kick off http://gbatemp.net/threads/open-ds-...and-hardware-removal-database-project.355223/ or someone might do something similar but it has not happened yet.

    If you are getting a 3ds then the DStwo is probably the foremost of the DS playing carts still going and working on the latest firmwares.

    3ds flash carts already exist, http://gbatemp.net/threads/comparison-of-nintendo-3ds-flashcarts.358243/ being a thread that compares what is available.
    They are still very early stage and require you to have a 3ds at firmware 4.5 or below (presently we are at 6.something), such things becoming increasingly hard to get your hands on and the probability of a hack for later firmwares to come any time soon is not something I would put any money on.
     
  3. user64

    user64 GBAtemp Fan

    Member
    329
    48
    Aug 14, 2013
    Canada
    Well it depends on what you want to do in the future. If you're interested in running 3DS ROMs, and you're intent on finding a 4.x.x 3DS, then there is a selection of 3DS of cards, but they're still in their infancy. If you would perfer to wait for the 3DS scene to mature, or are not interested in playing 3DS ROMs, I think you should buy a DSTWO, as it reliably and quickly updates to be compatible for newer firmwares.