Is it safe to use an R4i with Kirby icon on an updated 3DS?

Discussion in '3DS - Flashcards & Custom Firmwares' started by turbby, Dec 8, 2012.

  1. turbby
    OP

    turbby Newbie

    Newcomer
    3
    0
    Dec 8, 2012
    Hi, I own a 3DS running Ver. 4.2.0-9E, and a R4i Gold 3DS Rev. C with the Kirby: Squeak Squad Demo icon, running Wood 1.54.

    My question is: is it safe for me to update my 3DS to 4.5 or should I wait for an R4i update? Thanks.
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    No it's not safe, wait for an update.
     
  3. Pluupy

    Pluupy Woof!

    Member
    947
    695
    Sep 13, 2009
    United States
    Well I dunno about "safe" per se... I have a rev C R4i 3DS Gold and using it on my v4.5 3DS didn't really do anything. It actually reminds me of the 002 error on the Wii when it comes to backups. All it'll ask you is to restart your system and that's it. ...and yeah, it won't work with 4.5 so you're going to have to wait for an update. Rev C R4is don't work with the new version despite what they say.
     
  4. NES SNES V.B. N64 G.C. Wii WiiU

    NES SNES V.B. N64 G.C. Wii WiiU Now with extra redundancy!

    Member
    859
    99
    Feb 10, 2011
    The EoF
    Depends whether you need to use the R4i with the 3DS. If you do, wait for the R4i update before doing anything with the 3DS.
     
  5. dronesplitter

    dronesplitter GBAtemp Advanced Fan

    Member
    595
    193
    Sep 30, 2007
    United States
    Rev C's work if you have a Deep Labyrinth bootloader version. Not many people have that one, true, and it's a bit curious as to why they haven't pushed a patch to revision C card users that have the Metroid Hunters Demo icon. If you don't have a DS lite to perform the upgrade in case of going ahead to 4.5.0, saying it isn't safe is a fair way to put it, IMO.
     
  6. Keo-Spin1080

    Keo-Spin1080 Member

    Newcomer
    26
    0
    Oct 22, 2009
    I personally wouldn't but if you feelin' particularly adventurous then be sure to put aside $40 for a SCDS2
     
  7. turbby
    OP

    turbby Newbie

    Newcomer
    3
    0
    Dec 8, 2012
    Bump as I noticed there's both a card update and Wood update.

    I'm still on 4.2.0-9E, am I required to update my R4i using another DS or can I do it with the 3DS? Or is this not required, so I can just update Wood R4 and then update the 3DS to 4.5?

    HW: R4i Gold 3DSb
    Sys: NDSi 1.44&3DS4.40-10

    That's with Wood 1.55 on the card.
     
  8. turbby
    OP

    turbby Newbie

    Newcomer
    3
    0
    Dec 8, 2012
    I went ahead and ran the DSi patch on my 3DS anyway and the icon is now some Japanese game title by Konami.

    Sys:NDSi 1.45&3DS4.5.0-10

    Does this now mean the 3DS can be safely updated?
     
  9. dronesplitter

    dronesplitter GBAtemp Advanced Fan

    Member
    595
    193
    Sep 30, 2007
    United States
    http://r4ids.cn/r4ids-e.html
    Scroll down that page until you see the various icons and firmware versions. If your icon matches the icon next to "Support 3DS V4.5.0-10 and NDSi V1.4.5" then you can safely update your 3DS.
     
  10. tranfeer

    tranfeer GBAtemp Advanced Fan

    Member
    776
    41
    May 23, 2010
    Australia
    Yes, you can update your 3ds safely now.