1. funnyguywiiu

    OP funnyguywiiu Member
    Newcomer

    Joined:
    Jun 6, 2014
    Messages:
    34
    Country:
    Netherlands
    Installed Immortals Fenyx Rising, plus update, running Atmosphere 0.16 plus updated sig patches.

    When I start up the game I get a ''the software was closed because an error occurred'' message.

    I'm surprised to not find any posts about this. Anyone else got this error message? Is there a fix for this?

    edit: my Switch is currently on 9.1 firmware
     
    Last edited by funnyguywiiu, Dec 3, 2020
  2. arianadark

    arianadark GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2016
    Messages:
    708
    Country:
    United States
    what firmware are you on? and i dont think there are sig patches for the newest atmosphere yet
     
  3. funnyguywiiu

    OP funnyguywiiu Member
    Newcomer

    Joined:
    Jun 6, 2014
    Messages:
    34
    Country:
    Netherlands
    Forgot
    I just now started thinking outdated firmware might be the reason. I'm still on old firmware. Guess I gotta upgrade to 10.2.0
     
  4. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    8,572
    Country:
    United States
    Game requires 10.0.0 for base game and 10.2.0 with the 1.0.2 update.
     
    flowlapache, KiiWii and peteruk like this.
  5. funnyguywiiu

    OP funnyguywiiu Member
    Newcomer

    Joined:
    Jun 6, 2014
    Messages:
    34
    Country:
    Netherlands
    alright upgrading now. thanks
     
  6. 1khanal1

    1khanal1 Member
    Newcomer

    Joined:
    May 10, 2020
    Messages:
    22
    Country:
    United Kingdom
    I had the same issues and nothing worked for me either. I randomly tried turning off SaltyNX and then it ended up working miraculously, might work for others having difficulty too.
     
    falcorr likes this.
  7. Nagaa

    Nagaa Newbie
    Newcomer

    Joined:
    Nov 8, 2020
    Messages:
    9
    Country:
    France
    In SaltySD/exceptions.txt add this line :
    ;Immortals: Fenyx Rising
    ;1.0.2
    01004A600EC0A000
    Restart your switch and the game should work
     
  8. angelo93

    angelo93 Member
    Newcomer

    Joined:
    Apr 18, 2018
    Messages:
    42
    Country:
    United States
    Worked like a charm, thank you so much!
     
    bonoboy, Nagaa and Hologram like this.
  9. beenii

    beenii GBAtemp Regular
    Member

    Joined:
    Mar 20, 2011
    Messages:
    145
    Country:
    Gambia, The
    I do have a similar problem:

    Got an EmuMMC on SYSFW 9.1.0/AMS 0.14.1/E. When I try to play Immortals I get an error msg most likely due to my EMUMMC not being on at least 10.1.0
    last time I updated Atmos (has been some time now), most of my games wouldnt start any longer and had to find sigpatches, which took me a long time
    Please, if someone can help. Do I have to update EmuMMC to play? If yes, what would be the easiest method? Thank you very much in advance!
     
    Last edited by beenii, Dec 3, 2020
  10. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    8,572
    Country:
    United States
    You need 10.2.0 firmware if you installed the 1.0.2 update. Base game requirement was 10.0.0, with the update was bump up to 10.2.0.
     
    Netossauro likes this.
  11. beenii

    beenii GBAtemp Regular
    Member

    Joined:
    Mar 20, 2011
    Messages:
    145
    Country:
    Gambia, The
    thank you very much. I dont really care about the Update if I can just play the 1.0 version. Still, the SYSFW on my EmuMMC is 9.1. What would be the easiest method of updating that, if needed and do I have to worry about something no longer working after the Update?
     
  12. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    8,572
    Country:
    United States
    If you going to update, update via daybreak to 10.2.0, not 11.0.0, Depends on how you load CFW if you use Fusee Primary ->Fusee Secondary you go with Fusee patches, if you are loading from Hekate-> Fusee Secondary.
     
  13. ucupetuks

    ucupetuks GBAtemp Regular
    Member

    Joined:
    Nov 4, 2020
    Messages:
    107
    Country:
    Indonesia
    i cant even play on 1.0 version with 10.1 fw
     
  14. beenii

    beenii GBAtemp Regular
    Member

    Joined:
    Mar 20, 2011
    Messages:
    145
    Country:
    Gambia, The
    [​IMG]
    I was able to Update to 10.1 with Daybreak, which still works with my AMS0.14.1 and am able to play the game in Version 1.0, so maybe there is something else interferring with your system, like sig-patches...
     
    bonoboy likes this.
  15. Ghost92

    Ghost92 GBAtemp Advanced Fan
    Member

    Joined:
    Jun 29, 2017
    Messages:
    933
    Country:
    Colombia
    Sorry. Do you know why ReverseNX crashes when I try to make a configuration or activate it? It always happens to me, even all the times that I have cleaned my MicroSD and reinstalled Atmosphere
     
  16. angelo93

    angelo93 Member
    Newcomer

    Joined:
    Apr 18, 2018
    Messages:
    42
    Country:
    United States
    Just as a PSA for this game, it is recommended to play on the the 1.0.2 patch as it has significant performance increases. You're still bound to crash, but not as often, the FPS is also more stable. Some reviewers were going to advice against getting this game before the patch happened.
     
  17. ucupetuks

    ucupetuks GBAtemp Regular
    Member

    Joined:
    Nov 4, 2020
    Messages:
    107
    Country:
    Indonesia
    i'm using sxos 3.0.5 on lite, with 10.1 sysnand, i tried so many file nsz,nsp,xci everything didnt work, so sad...
    or maybe some overlay like sysclk,fps plugin, reversert are intererring the game?
    and is sigpatches needed for latest sxos?
     
    Last edited by ucupetuks, Dec 4, 2020
  18. duckbill007

    duckbill007 GBAtemp Regular
    Member

    Joined:
    May 5, 2011
    Messages:
    239
    Country:
    Russia
    Just run it on 10.1.0|AMS-0.13.0|S with 1.0.2 patch.

    Check your sysmodules
     
  19. MrSco

    MrSco Newbie
    Newcomer

    Joined:
    May 23, 2018
    Messages:
    6
    Country:
    United States
    this worked for me on 10.0.2 and update 1.0.2

    thanks!
     
    Nagaa likes this.
  20. Ghost92

    Ghost92 GBAtemp Advanced Fan
    Member

    Joined:
    Jun 29, 2017
    Messages:
    933
    Country:
    Colombia
    SaltyNX does not support this title, so the ReverseNX and ShowFPS functions cannot be used. Adding it to exceptions (Disable SaltiNX when you run the title) solves the problem.

    Another problem that the community is commenting on is that it is not compatible with LayeredFS either.
     
    BorntoPlay likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Immortals, Rising, Fenyx