I have a new 3ds 1.1.0.0u (whats the best cart & should I update?)

Discussion in '3DS - Flashcards & Custom Firmwares' started by benson733, Mar 6, 2012.

  1. benson733
    OP

    Newcomer benson733 Member

    Joined:
    Mar 7, 2011
    Messages:
    33
    Location:
    Ontario
    Country:
    Canada
    Any options? I would like DS roms to run, I know 3ds roms are not possible at this moment... What card should I pick and am I able to update to the latest firmware?


    Thanks GBA temp users in advance...
     
  2. loco365

    Member loco365 GBAtemp Guru

    Joined:
    Sep 1, 2010
    Messages:
    5,459
    An AceKard 2i will do you fine. It's also updated to the latest firmware, however, you may need to update it before you update the 3DS.
     
  3. benson733
    OP

    Newcomer benson733 Member

    Joined:
    Mar 7, 2011
    Messages:
    33
    Location:
    Ontario
    Country:
    Canada
    that seems like a feasible option. hoping to get one already updated as I want to update my system. Would like to have the store and would like to play some 3ds games that are coming in the mail this week...
     
  4. Qtis

    Member Qtis Grey Knight Inquisitor

    Joined:
    Feb 28, 2010
    Messages:
    3,762
    Location:
    The Forge
    Country:
    Antarctica
    Some games may require you to update the firmware of the 3DS to play them. If your new flashcart isn't up to date, it may just end up as a paper weight if you don't have a DSL or DSi (with right firmware) available :)
     

Share This Page