How to update Luma Sys to a specific version ?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Aglae Pheryl, May 1, 2017.

  1. Aglae Pheryl
    OP

    Aglae Pheryl GBAtemp Regular

    Member
    213
    19
    Feb 25, 2014
    France
    My kids are running both Luma (a9hl) and Gateway (Yes they want to keep this Gateway part).

    It is pretty easy to update Gateway's emunand first booting with Dpad down and then Dpad up when the Gateway logo appears. I have updated emunand to 11.2 but I don't know how to update Luma to a specific version.

    Thanks for your help.
     
  2. fenixcumber

    fenixcumber Don't need's a 1UP

    Member
    203
    83
    Feb 5, 2017
    Spain
    inside me
    1 or 2 consoles?
     
  3. skullkeeper94

    skullkeeper94 Professional USB Corrupter

    Member
    264
    46
    Jun 21, 2016
    United States
    Go to the Luma GitHub, download the specific version you want, and replace the arm9loaderhax.bin file in your SD Card with the one in the Luma archive
     
  4. fenixcumber

    fenixcumber Don't need's a 1UP

    Member
    203
    83
    Feb 5, 2017
    Spain
    inside me
    seems like he/she is trying to update the system version (idk, gateway weird things), and if is only one device, afaik a brick may happen (booting gateway mode on 11.3+)
     
  5. skullkeeper94

    skullkeeper94 Professional USB Corrupter

    Member
    264
    46
    Jun 21, 2016
    United States
    Oh shat. Well, I'm assuming it's one console.

    They said they only wanted to update Luma, and that they've already updated their emuNAND. And yes, I believe using Gateway above a certain firmware results in a brick.
     
  6. Aglae Pheryl
    OP

    Aglae Pheryl GBAtemp Regular

    Member
    213
    19
    Feb 25, 2014
    France
    yes, the consoles are all the same for my kids. They are all O3Ds (apart from one) and are all running both emunand (Gateway) and Luma (Sys 9.2). I would like to update the Luma part to 11.2 (not further to prevent brick risk).
     
  7. fenixcumber

    fenixcumber Don't need's a 1UP

    Member
    203
    83
    Feb 5, 2017
    Spain
    inside me
    to clarify, multiple devices running both, luma sysnand and gateway emunand?
     
  8. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,067
    1,472
    Feb 13, 2015
    Italy
    Imola
    To get a specific version of the CFW, get it from github (official or https://astronautlevel2.github.io/Luma3DS/)
    However, it's rarely an advantage to use an outdated CFW (mainly due to the patches to go online on outdated system versions)

    To get a specific version of the operating system, you'll have to hunt down a sysupdater cia pack or a ctrtransfer image containing the version you want.
    For the specific case of 11.2, the 3Down topic can probably help you...
     
  9. driverdis

    driverdis I am Justice

    Member
    2,385
    901
    Sep 21, 2011
    United States
    1.048596β
    You can have Luma on 11.4 as Gateway will boot EmuNAND (11.2) by default unless you force it otherwise. as long as nobody forces Gateway to boot SysNAND and does not delete or update the EmuNAND to 11.4, the console will be fine.
     
    Last edited by driverdis, May 1, 2017
  10. Aglae Pheryl
    OP

    Aglae Pheryl GBAtemp Regular

    Member
    213
    19
    Feb 25, 2014
    France
    Correct.
     
  11. fenixcumber

    fenixcumber Don't need's a 1UP

    Member
    203
    83
    Feb 5, 2017
    Spain
    inside me
    I, honestly, don't have the confidence to say "you wiil not brick if you do X". Gateway things. But the sysupdater cia guy is right, there are a cia that with the necesary files let you update or downgrade to a specific system version
     
  12. Aglae Pheryl
    OP

    Aglae Pheryl GBAtemp Regular

    Member
    213
    19
    Feb 25, 2014
    France
    I'm not sure I can explain the kids how not to boot sysnand (this is still obscur to me). Booting not pressing any keys boots into Luma (Sys 9.2) while booting with Dpad down boots Emunand 11.2.
    I have always told the kids not to update the console when they get a message to do so. They stick to this.
    So how would I go about updating Sys to 11.2 (I'd rather not take the risk to go further since it could brick the consoles or remove emunand).
     
  13. Thelonewolf88

    Thelonewolf88 GBAtemp Regular

    Member
    174
    107
    Jun 11, 2016
    United States
  14. driverdis

    driverdis I am Justice

    Member
    2,385
    901
    Sep 21, 2011
    United States
    1.048596β
    it is the same, not reverse. the thread here is for the OP to use 11.2 EmuNAND on 11.2 SysNAND (via manual upgrading), of which I wanted the OP to use 11.4 Luma SysNAND instead.
    that would fit your situation
     
  15. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,067
    1,472
    Feb 13, 2015
    Italy
    Imola
    Turn off "autoboot sysnand" in the Luma options :)