Hosed WBFS partition

Discussion in 'Wii - Backup Loaders' started by martinip, Apr 1, 2011.

Apr 1, 2011

Hosed WBFS partition by martinip at 4:17 AM (929 Views / 0 Likes) 3 replies

  1. martinip
    OP

    Newcomer martinip Newbie

    Joined:
    Jun 13, 2010
    Messages:
    8
    Country:
    United States
    Hey,

    I was trying to copy all my games from one external HD to another using Wii Backup Manager, so I could resize the first one... On the original disk, I had two partitions, ~10GB FAT32 storing my USB loader configs and images, and the remaining ~230GB of WBFS, with somewhere between 50-70 games. On the second/target disk, I only created one partition and copied all the games over. 4 hours later, it was done, and I attached the target disk to the Wii to test it out (safety first!) before wiping the source disk. USB loader came up fine, and I could see my games (albeit without cover images, since the image partition was not there). I started a couple of games to make sure they worked, and then powered off the Wii and unplugged.

    I wiped the partitions on my source disk... Then I plugged in the target disk again and loaded up Wii Backup Manager once more just to see the games there. But, nothing came up - "This isn't a WBFS partition, you moron." I plugged it back into the Wii. Games are still there. Still playable. But, neither the Wii Backup Manager, nor the WBFS Manager 3.0 can read it.

    I downloaded Wiimms' tools and tried ANA/CHECK/REPAIR and even format --recover, with no luck. Any clues?

    ANALYZE finds the following:
    ------------------------------------------------------------------------------------
    HD SECTORS WBFS SECTORS DISCS (all values in hex)
    WBFS total sec total sec max inode
    NAME magic vrs num size num size num size ADDITIONAL INFORMATION
    ------------------------------------------------------------------------------------
    HEADER: ok 1 1d28b800 200 e945 400000 1f4 1400 WBFS header scanning
    INODE-TIM: ok 1 1d28b800 200 e945 400000 1f4 1400 2011-03-31 16:51:22 n=500
    DISCS: - 0 1d28b800 200 e945 400000 1f4 1400 51 disc header found
    ------------------------------------------------------------------------------------


    CHECK/REPAIR both return:
    ***** wwt: Wiimms WBFS Tool v1.28a r2336 x86_64 - Dirk Clemens - 2011-03-04 *****

    CHECK /dev/sdd1

    LS shows 69 games, not 51... I don't understand why ANALYZE shows 51 disc headers... are 18 of them corrupt?
    ...
    Total: 69/500 discs, 132404 MiB ~ 129 GiB used, 106460 MiB ~ 104 GiB free.


    I guess worst case is I could try to copy the games using wwt to a filesystem, then completely reformat the drive.

    I've also been trying to recover my partitions on the original disk, but no partition tool I've found so far has been able to autodetect the filesystems...
    It's strange, I know the approximate size... a little less than 10GB in the front of the disk, FAT32, and the rest WBFS...

    Also unable to reformat the target partition as WBFS using Wii Backup Manager or WBFS Manager 3.0.


    Thanks,
    Martin
     
  2. PsyBlade

    Member PsyBlade Snake Charmer

    Joined:
    Jul 30, 2009
    Messages:
    2,204
    Location:
    Sol III
    Country:
    Germany
    easiest: format drive to FAT and rerip all games

    recover target: sorry no idea but probably 2nd easiest

    recover source:
    to find the start of a lost partition the tool needs to understand its content - unlikely with wbfs
    but you can try by hand
    afaik WBFS partition include the string "WBFS" in its header
    try searching for it in the suspected area
    divide its adress by you sectorsize (512 mosk likely)
    round down to get a sector number
    then try creating partitions starting around that sector
     
  3. Wiimm

    Member Wiimm Developer

    Joined:
    Aug 11, 2009
    Messages:
    2,051
    Location:
    Germany
    Country:
    Germany
    LIST prints only the directory info of the WBFS.
    ANALYZE try to find valid disc headers, So its possible that the directory info is available for an invalid disc header or an invalid mapping table.

    Try VERIFY to verify the content of all discs. It will check all checksums and this can take much time.
     
  4. martinip
    OP

    Newcomer martinip Newbie

    Joined:
    Jun 13, 2010
    Messages:
    8
    Country:
    United States
    I thought of this last night as well, and this is what I ended up doing. After the repartitioning of the source drive, I rebooted my PC and installed the latest Wii Backup Manager, which was able to read the data. I just re-formatted the target drive and am using WWT now to copy the titles over.

    I couldn't get VERIFY to work when I tried it last night on the target drive. Have not tried on the re-partitioned source.

    Thanks!
     

Share This Page