Homebrew App store creates I/O errors on my SD card

Discussion in 'Wii U - Hacking & Backup Loaders' started by Pikachuk, Jul 9, 2016.

  1. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    when i try to use this homebrew on the wii u the homebrews are downloading but after that all the local homebrews disapear and when i connect to my pc i can see all the sd content but i can't modify anything so i must correct the I/O problems but it's really annoying (and the downloaded homebrews don't work because they're corrupted)

    what can i do ?
     
  2. kingraa777

    kingraa777 boom!

    Member
    1,050
    266
    Apr 17, 2015
    not use the homebrew app store?
     
  3. EclipseSin

    EclipseSin FullMental Trollemist

    Member
    1,813
    1,287
    Apr 1, 2015
    United States
    Vegeta's Hyrule
    First off, being someone that had the 5.5.x exploit early, I'm extremely sad you posted this in its own thread instead of the one for the app, so the developer could maybe help you and/or fix the bug.

    Secondly, try with a fresh formatted card. Maybe it doesn't like certain formatting (such as 64kb align ((not that it should matter in all honesty))). No way around it if it's the app other than reporting it to the developer and helping find the issue since youre the one having it.
     
    Logan Pockrus likes this.
  4. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,703
    Jan 3, 2016
    United States
    Are you using the wiiubru repo, or one of the others? Maybe you are having connection issues to whichever repo you are using, or you are using a repo that isn't configured correctly. The app should not make the whole card not work. Perhaps your SD Card is starting to fail.
     
  5. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    no, it's not wiiubru it's http://www.hackergen.com/wiiu/ and it works always perfectly
     
  6. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,703
    Jan 3, 2016
    United States
    No, I mean what do you use as the repo for the Homebrew App Store, that isn't a repo for the Homebrew App Store. If you never changed the repo for it, then it would be using the default, which is http://wiiubru.com/appstore/

    But if you did change the repo to be the other url, then that's your problem right there.
     
    Last edited by brienj, Jul 10, 2016
  7. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    i use the default
     
  8. rw-r-r_0644

    rw-r-r_0644 GBAtemp Fan

    Member
    333
    380
    Jan 13, 2016
    Italy
    It's strange as the app doesn't do anything strange with sdcard (only use normal fs functions) so if it doesn't work it means that also other file saving homebrews should have the same problem;
    some things you may try:
    -Check the sdcard for corruption
    -Check that there's no phisical lock to the sdcard (unlikely)
    -Check that apps on your computer (like antivirus) doesn't do strange things with the card (for example Panda AV do a "vaccination" to drives) (unlikely)
    -Check that contacts of both SD and Wii U sd socket are clean
    -Try to format the sd trying different cluster sizes/other configurations
    -Make sure the SDCard is fat32 formatted
    -Do a total cleaning of the sdcard (with diskpart)
    -Change sdcard :P

    Alternatively it could be because your wii u can't reach the wiiibru server and leaves the download thread open in background (unlikely)
     
    Last edited by rw-r-r_0644, Jul 10, 2016
    brienj likes this.
  9. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,703
    Jan 3, 2016
    United States
    Yeah, the most likely culprit is a bad SD Card or something on the PC that is messing it up, because it uses the exact same FS functions that HBL or Loadiine use.
     
    rw-r-r_0644 likes this.
  10. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    my sd card works perfectly on my pc

    i don't have i/o errors anymore but the app messed up all my homebrews when i tried to update them with it ;-(
    i must redownload everything

    i could make a video if you want
     
  11. Kafluke

    Kafluke GBAtemp Psycho!

    Member
    3,569
    1,763
    May 6, 2006
    United States
    Just do what they suggest and try a different SD card. If it works it's not that big of a deal to transfer the contents. I have a 128mb and had to reformat it to 64k clusters. It was full and moving it to my pc and back didn't take long. Just cause your PC reads your card fine doesn't mean the wii u will
     
  12. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    it will be longer than you could think because the sd contain all my smash mods and xenoblade chronicles x undubbed so more than 20go
     
  13. Kafluke

    Kafluke GBAtemp Psycho!

    Member
    3,569
    1,763
    May 6, 2006
    United States
    Sorry I meant 128gb not mb. So no, it won't
     
  14. Pikachuk
    OP

    Pikachuk GBAtemp Advanced Fan

    Member
    649
    149
    Mar 19, 2016
    France
    Bordeaux
    yes because 128 mb i was a little confused it's really small XD