Help with converting a save game from Emulator to VC

Discussion in 'Wii - Emulation and Homebrew' started by drtongue96, Jun 7, 2013.

  1. drtongue96
    OP

    drtongue96 Newbie

    Newcomer
    3
    0
    Jun 7, 2013
    Canada
    Hi. I'm trying to convert a save game (Paper Mario, originally played on Surreal64 on XBox) to the Virtual Console on my Wii.

    I was able to do almost all of it, but having one last hiccup. I managed to get the save file off of the Xbox, which is of the .fla type (flash?). I also made sure it worked by downloading Project64 and getting it to work on my pc when I renamed it correctly.

    On the Wii, with the VC version of Paper Mario, I made a save game, and then copied it over to SD and then FTP'd it over to my pc. I used FE100 to extract the data.bin file and it created a folder with a bunch of files in it. I noticed one of the files was exactly the same size as my .fla file, so I replaced it and gave it the same name.

    I then used FE100 to 'zip' it back into a data.bin file (which appeared successful) and put it back on the Wii.

    The Wii DOES recognize this as a Paper Mario save file. I tried to copy/move the save back into System Memory (first deleting the one in System Memory), and I get the message which is something like:

    "Data may not have copied" or "Data may not have moved" which is true. It didn't copy, or move.

    My .fla also works with Wii64, loading successfully.

    I would like to finish this game on VC, as the quality if much better than Wii64 or XBox, especially the sound.
     
  2. drtongue96
    OP

    drtongue96 Newbie

    Newcomer
    3
    0
    Jun 7, 2013
    Canada
    I almost have this figured out. The problem I had was that I didn't enter the NG-Priv key into the keygrabber program. It took me quite some time to find the right key etc, but I managed to do this, and then create the save file with fe100 and upload it into Wii system memory without that annoying message. But the bad thing is that it doesn't work. It doesn't load. Wierd. I have the same .fla file loading on my xbox, an emulator on android called n64oid and on my pc in Project 64. I just can't get it to load from wii VC. any tips?
     
  3. drtongue96
    OP

    drtongue96 Newbie

    Newcomer
    3
    0
    Jun 7, 2013
    Canada
    I finally solved my own problem. Lots and lots of googling, but I did it.

    I had to byte swap the .fla file from the emulator before repacking it into FE100 using a hex editor. And then it worked!
     
  4. Triumph627

    Triumph627 All sweet & honeycomb

    Newcomer
    84
    24
    May 21, 2013
    United States
    The Comatorium
    Congrats on figuring it out. Transferring save data to and from different emulators is a pain in the butt.