HELP PLEASE

Discussion in 'Wii U - Hacking & Backup Loaders' started by crobeinthehouse, Jun 17, 2017.

  1. crobeinthehouse
    OP

    crobeinthehouse Newbie

    Newcomer
    4
    0
    Jun 17, 2017
    United States
    Hello all,

    I am new to WiiU Hacking and I have been following the every so user-friendly guide for noobs @ https://gbatemp.net/threads/guide-noob-guide-to-wii-u-hacking.451297/.

    I decided to go the Haxchi route.

    I made sure I setup blocking my setting alternate DNS servers on my connections, formatted my 16 GB SD Card (SDHC/MicroSD adapter) to FAT 32 using the GUIFormat tool recommended by OP. Went through the file loading (verified three times that I did it correctly) for Haxchi, homebrew launcher, and homebrew app store.

    Popped the SD card in the Wii U & Bought New Super Mario Bros (USA) from eStore. (Had to revert my DNS settings back to auto to access store, then switched back to recommended DNS servers once download was completed). Launched game and exited to Home screen.

    Next step was to open the web browser and launch loadiine.ovh, choose the correct 1.4 option and click "Launch" or whatever it says. THIS IS WHERE I RUN INTO MY PROBLEM! Each time it tries to launch (when it doesn't just freeze to a white screen) it shows Wii U in the bottom and plays the little Wii U music but then after 2 seconds it pops up "FSOpenFile failed".

    I did some research about this error and it says that it usually means it doesn't recognize the SD card. So I figured since I was using a SD adapter to mini SD that was the issue so I pulled my regular SDHC card out of my camera and formatted it to FAT32 using recommended GUIFormat tool and went through the same procedure and still got the bloody FSOpenFile failed error!!

    Someone help me please because I am pulling my hair out over this because I am an IT guy and by no means is this anything over my head.

    The only thing I am thinking is, does it matter if you are using a USB card reader to hook up to your PC? Mine doesn't have internal SD card reader.

    PLEASE HELP! :)
     
  2. pwsincd

    pwsincd Garage Flower

    Member
    GBAtemp Patron
    pwsincd is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,377
    1,750
    Dec 4, 2011
    Manchester UK
    it is simply your SD card failing
    i have 2 relatively new class 10 32 gig sandisks here that work perfectly in everything but the wiiu.. they used too btw..
     
  3. crobeinthehouse
    OP

    crobeinthehouse Newbie

    Newcomer
    4
    0
    Jun 17, 2017
    United States
    Update: Tried 20 more times to make sure it wasn't just failing and this is the first time I got a different error but still seems native to the SD card?

    "FSGetMountSource failed"

    — Posts automatically merged - Please don't double post! —

    Can you elaborate/advise on what cards I need to purchase then? I guess I am a little confused... is it just a random thing whether they will work or not???
     
  4. bostonBC

    bostonBC GBAtemp Maniac

    Member
    1,181
    294
    Aug 17, 2011
    United States
    I've seen this happen if the SD card is not MBR with a single FAT32 partition.

    Download AOMEI Partition Assistant Standard Edition (it's free) and check the SD card.

    Make sure there isn't a hidden exFAT partition.

    The SD needs to be MBR and FAT32.

    If it shows as GPT or with a hidden exFAT partition you will need to change it to MBR and/or remove the exFAT partition.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,522
    5,474
    Mar 17, 2010
    Norway
    Alola
    You have homebrew_launcher.elf (not .rpx) in wiiu/apps/homebrew_launcher right?
    The .rpx won't work with the HBL 1.4 loader.
     
  6. RyanAnayaMc

    RyanAnayaMc GBAtemp Regular

    Member
    161
    63
    Oct 5, 2015
    United States
    Using the .rpx gives you a different error code. That says:
    Could not load file SD:/wiiu/apps/homebrew_launcher/homebrew_launcher.elf
     
  7. Felek666

    Felek666 retarded memekid which no one likes

    Member
    3,520
    4,004
    Jan 3, 2017
    Poland
    reddit.com/r/satania/
    Format SDCard to FAT32 32kb/64kb cluster size. If SDCard is above 32GB, use GUIFormat or SDCard Formatter Tool.
    Insert HBL v1.4 in wiiu/apps/homebrew_launcher/homebrew_launcher.elf
    Proper directory:
    Code:
    SDCard://
    SDCard://wiiu
    SDCard://wiiu/apps
    If still get FS error then try another SDCard. Wii U hates SanDisk for unknown reasons..
     
  8. crobeinthehouse
    OP

    crobeinthehouse Newbie

    Newcomer
    4
    0
    Jun 17, 2017
    United States
    I actually have .rpx but I followed the instructions... or so I thought... where did I go wrong? It is in the same directory as Felek mentioned above but I have the .rpx file and not.elf.

    Where do I get the elf file?

    EDIT: Face palm.... I see where I went wrong.. on the HBL step.... I didn't scroll down far enough.. saw the file that looked close enough to the one mentioned and just rushed... my bad folks.. thanks for the help. I will post and let yall know if that did the trick....

    EDIT 2: This solved my problem guys... thanks again for all the assistance and especially for taking the time to make/support the noob guides... it was a cakewalk once I figured out I was downloading the wrong package. Admin can close the thread. Resolution: Was clicking 'homebrew_launcher_rpx.v2.1.zip' instead of homebrew_launcher.v1.4.zip. Didn't scroll down far enough...
     
    Last edited by crobeinthehouse, Jun 18, 2017