Help Hans Gives me a black screen!

Discussion in '3DS - Homebrew Development and Emulators' started by ElyosOfTheAbyss, Oct 27, 2015.

  1. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    When ever I try to load something in HANS it gives me a black screen. I tried all my games and nothing works can someone help?
     
  2. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    If someone could help it would be appreciated It used to work now it just shows a Black screen
     
  3. Sykoh

    Sykoh Leader of the Brick Masterrace

    Member
    477
    57
    Aug 21, 2015
    Your Bricked SYSNAND
    Did you update your ironichax if not use the new install but install to a different slot.

    P.S It could crash the first time you turn it on.. So reboot your 3ds and boot the hax again.
     
    ferofax likes this.
  4. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Thanks ill Try that and let you know if it works. Someone should really make a Q & A for HANS Issues.

    Edit: Thanks it worked :)
     
    Last edited by ElyosOfTheAbyss, Oct 27, 2015
  5. Sykoh

    Sykoh Leader of the Brick Masterrace

    Member
    477
    57
    Aug 21, 2015
    Your Bricked SYSNAND
    :D Noice
     
  6. Justin20020

    Justin20020 GBAtemp Advanced Fan

    Member
    606
    118
    Jun 22, 2015
    Gambia, The
    It doesnt work for me on ninjhax 2.5. It show for me that I have 2.1 beta. I downloaded the ninjhax 2.5 files and it doesnt work for me
     
  7. Sykoh

    Sykoh Leader of the Brick Masterrace

    Member
    477
    57
    Aug 21, 2015
    Your Bricked SYSNAND
    Did you install new ironhax that comes with starter pack......
     
  8. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Can someone help me again. I try to launch Super Mario 3D Land on hans but it gives me a half glitched screen and stays like that :(
     
  9. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Anyone?
     
  10. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Are you definitely using the 2.5 payload? Also what hardware, firmware and hax are you using? Also where are you launching it from - which launcher, and is it a digital game or a cart?
     
  11. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    I'm pretty sure I am using the 2.5 Payload. When it was released on monday I deleted all homebrew items off my SD card and put the new starter kit on and reinstalled ironhax and says 2.5Hax (or something like that when booting the hax). I'm using a New Nintendo 3DS XL on 10.1 EUR with Ironhax. I'm launching it from Homebrew Launcher and it's a cart. Anything I'm doing wrong?
     
  12. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    That all seems fine in terms of the payload and the method of launching. Just a couple of other questions. Do you get the black screen if you launch it as a title without using Hans? Also, what settings did you choose in the Hans menu (CPU speed, FW spoof, language spoof etc)?
     
  13. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Plays normally without Hans and I didn't change any setting when booting it in Hans
     
  14. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Ok one sec. I've got the same HW and region as you and I'm on 10.2. I'm going to test with my SM3DL cart through HANS myself.
     
  15. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    OK and also I thought I would just mention other games other then ACNL works
     
  16. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Is this what you see when you try to launch SM3DL through HANS?

    IMG_2356.JPG
     
  17. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Yes
     
  18. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Ok, it's doing the same for me. I'll play with the settings and see if I can get it working.
     
  19. ElyosOfTheAbyss
    OP

    ElyosOfTheAbyss GBAtemp Addict

    Member
    2,214
    1,720
    Aug 20, 2015
    Ok thanks I'm hoping to mess around with file swapping with Hans
     
  20. mashers

    mashers Stubborn ape

    Member
    3,837
    5,157
    Jun 10, 2015
    Kongo Jungle
    Oh of course! I was going to suggest just using Region4 booting but yeah, HANS does the romfs stuff too. I've played with the CPU, region and FW spoof settings in all combinations and they all result in the same issue. This also happens in the gridlauncher. Like you, I am able to boot other carts from HANS, just not SM3DL. I suspect it's an incompatibility with HANS. If anyone with a different version/region console is reading, could you please try launching SM3DL through HANS and see if you get the same result?