Help getting a new flashcard for DSi

Discussion in 'NDS - Flashcarts and Accessories' started by Xalusc, Apr 20, 2013.

Apr 20, 2013
  1. Xalusc
    OP

    Newcomer Xalusc Newbie

    Joined:
    Apr 7, 2013
    Messages:
    9
    Country:
    Brazil
    Hey guys, I have a DSi and an Acekard 2i, which I want to replace since it's outdated. Anyway, I read a lot of threads saying the Supercard DSTwo is the best, but does it work on "DSi mode" (WPA network access, camera for homebrew, etc) or only "DS" mode? I heard that CycloDS works in DSi mode, should I get that one instead? Thanks in advance guys!
     
  2. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    http://gbatemp.net/t290097-which-flash-cart-should-i-get
    The Cyclo iEvolution is the only cart that works in DSi-mode, but without Wifi access due to the nature of the exploit it uses. If you are using DS ROMs, you have to use DS-mode and WEP security. Also the iEvolution stopped getting updated anyways.
     
  3. Depot4usales
    This message by Depot4usales has been removed from public view by Costello, Apr 26, 2013.
    Apr 22, 2013
  4. clauspatrick

    Newcomer clauspatrick Member

    Joined:
    Mar 6, 2013
    Messages:
    29
    Country:
    United States
    Get a DSTwo if you want GBA/SNES emulators or an R4i Gold from r4ids.cn if all you want is DS games/homebrew.
     
  5. superrainbow
    This message by superrainbow has been removed from public view by Costello, Jun 19, 2013.
    Apr 22, 2013
  6. Arm73

    Member Arm73 GBAtemp Addict

    Joined:
    Mar 4, 2006
    Messages:
    2,025
    Location:
    Zurich
    Country:
    Italy
    What's outdated about the Acekard 2i ?
    It runs all the games.
    Surely it hasn't been updated in a while but how many games have been released since the last update anyway ?
    I find it a really good card, and AKAIO 1.9.0 has never let me down.

    Go with the DSTwo only if you like to have ( less then perfect ) dedicated emulators and RTS, otherwise, there is really no reason to switch to another card, especially since ALL of them will always run in DS mode ( meaning the DSi features you are looking for are unavailable to ALL of them anyway ).
     
  7. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Dude, updates are not just for game compatibility. The Ak2i will not work at all in recent DSi/3DS models.

    You might want to read up on DSi/3DS firmware updates before saying the DSTwo isn't special, because they've become a serious problem for flash carts, and the DSTwo is the only cart that's been able to bypass them all without a hardware update (read: buying a new one).
    http://gbatemp.net/threads/flash-carts-and-dsi-3ds-updates.315784/
     
  8. Arm73

    Member Arm73 GBAtemp Addict

    Joined:
    Mar 4, 2006
    Messages:
    2,025
    Location:
    Zurich
    Country:
    Italy
    Yeah I understand, but since his AK2i is still working on his DSi ( he probably didn't update it ), and he doesn't plan on using his card on a 3DS, I really don't see the need for another card, especially since he's after DSi enhanced content which is anyway impossible to get on ANY other card at this point.

    If it ain't broken don't fix it, simple as that.
    I find that the AK2i fulfills my needs on my non-updated DSiXL.

    Of course, I understand that affiliation programs ( pushing the sales of new cards ) help sites to survive and I'm not against it.
    But the golden age of DS hacking (and GBAtemp ) when there was a new card out any other week and tons of money to be made trough flashcart sales and advertising are over.

    If anything useful comes out of the 3DS hacking, it's probably going to be SD card based, no wander is taking this long since not many people will make money off it.
    And until they don't find a way to sell us more additional made-in-China device, I don't see that happening any time soon either.
     
  9. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    lolno, this has nothing to do with any of that.

    Open your eyes and look around at all the people who end up with an updated DSi/3DS. Even if somebody else uses his DSi for a few minutes and tries to connect to the eShop and hits "A" when it asks for an update, that's all it takes because it can't be downgraded again, his AK2i will no longer work on that DSi. You can see this sort of thing happening with DSi and 3DS units all the time (seriously, have you not looked at these forums in the past two years or so?), and it's a major concern.
     
  10. Guysbiz
    This message by Guysbiz has been removed from public view by raulpica, Apr 23, 2013.
    Apr 23, 2013

Share This Page