[Help] Decrypt9WIP and EmuNAND9 not working

Discussion in '3DS - Homebrew Development and Emulators' started by NovaShadowX, Mar 6, 2016.

  1. NovaShadowX
    OP

    NovaShadowX Newbie

    Newcomer
    8
    0
    Feb 6, 2016
    United States
    I have a New 3DS on 9.2 U and I'm trying to backup my NAND, I've tried through both Decrypt9WIP and EmuNAND9 and both of them just cause my bottom screen to flash red a couple of times and then it takes me back to the homebrew launcher. How can I fix this?
     
  2. Just Passing By

    Just Passing By GBAtemp Advanced Maniac

    Member
    1,562
    594
    Jan 3, 2016
    United States
    Are you trying on sysnand or emunand?
     
  3. NovaShadowX
    OP

    NovaShadowX Newbie

    Newcomer
    8
    0
    Feb 6, 2016
    United States
    Sysnand
     
  4. Just Passing By

    Just Passing By GBAtemp Advanced Maniac

    Member
    1,562
    594
    Jan 3, 2016
    United States
    Shouldn't be a problem then if it's on 9.2 since it has the permissions it needs. Do you have a9lh?
     
  5. NovaShadowX
    OP

    NovaShadowX Newbie

    Newcomer
    8
    0
    Feb 6, 2016
    United States
    No
     
  6. pdapanda

    pdapanda GBAtemp Advanced Fan

    Member
    712
    241
    Nov 19, 2014
    Switzerland
    Do not use firmlauchhax to load into your sysnand
     
  7. NoGamer

    NoGamer Newbie

    Nvrmd.
     
    Last edited Mar 24, 2016
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    10,356
    5,467
    Nov 23, 2014
    Australia
    Canberra, Australia
    I am having the same problem, but I was trying it on an updated emuNAND. Does this mean it won't work?
     
  9. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    You can't launch Arm9 homebrew on an updated nand. Have to launch it from 9.2 (or from a9lh) for it to gain Arm9 privileges.

    Or, I think Cakes has arm9 hooks now which might allow Arm9 homebrew to work on 10.7, but I haven't messed with that yet.
     
    Last edited by FenrirWolf, Mar 25, 2016
  10. Quantumcat

    Quantumcat Dead and alive

    Member
    10,356
    5,467
    Nov 23, 2014
    Australia
    Canberra, Australia
    Thanks for replying. I was trying the guide to change your emunand's SecureInfo_A file - Ill read through the comments there as obviously someone else will have the same problem (guide just says "launch decrypt9 and...")
     
  11. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    It would be sufficient to run Decrypt9 from your 9.2 sysnand if you have one of those.
     
  12. Quantumcat

    Quantumcat Dead and alive

    Member
    10,356
    5,467
    Nov 23, 2014
    Australia
    Canberra, Australia
    Ah OK. I was thinking if I ran it in sysNAND I'd be editing the SecureInfo_A of my sysnand, but I see it has emuNAND options :-)
     
  13. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Yeah, that's a point of confusion for some people. Arm11 homebrew like FBI only sees the nand that it is launched from, but Arm9 homebrew can break out of the Matrix and see the world how it really is.
     
    Last edited by FenrirWolf, Mar 26, 2016
    zoogie and Quantumcat like this.
  14. Quantumcat

    Quantumcat Dead and alive

    Member
    10,356
    5,467
    Nov 23, 2014
    Australia
    Canberra, Australia
    That's pretty cool.
    Urg I can't do it anyway. I seem to have an awkward sysNAND version - 5.1.0-10. Homebrew launcher cia won't work (says it can't download the payload) and ninjhax won't work either (launches the browser). I have a gardening mama coming in the mail for other purposes so I'll just wait for that I guess - I wanted to try posting pics in Miiverse but don't want to risk a console ban with its real SecureInfo_A since it will be sold in the future, and don't want my customer complaining that they can't play online or use Miiverse :-(

    By the way if Ninjhax isn't going to support certain versions, there should really be a message on the ninjhax page to save people spending hours trying to find out why it won't work. I went through this a few months ago with a different console. (If anyone finds this message through Google, I believe it's versions above 4.5 with browser version less than 12).
     
  15. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Odd that Ninjhax doesn't work. I can't think of why it would fail to launch.

    Either way, you should be able to follow this guide to get up to 9.2 https://github.com/Plailect/Guide/wiki/9.2.0-Update

    Just be sure to use o3ds firmware if you're on o3ds (and it sounds like you are). Installing the n3ds update pack to an o3ds would be a one-way trip to bricksville.

    — Posts automatically merged - Please don't double post! —

    Or, there's bound to be some other way to launch Decrypt9 on your current firmware since other Arm9 stuff like rxTools is presumably working for you. Like, you should be able to put D9's Launcher.dat on your SD card and then go to http://www.reboot.ms/3ds/load.html?launcher.dat
     
    Last edited by FenrirWolf, Mar 26, 2016
  16. Quantumcat

    Quantumcat Dead and alive

    Member
    10,356
    5,467
    Nov 23, 2014
    Australia
    Canberra, Australia
    The link shows how to get into Decrypt9 without the homebrew launcher so I'll try that :-) (I have been using Gateway)