Hello there, quick question about upgrading to a 3DS

Discussion in 'Supercard' started by kabuto mushi, Jul 31, 2012.

  1. kabuto mushi
    OP

    Newcomer kabuto mushi Newbie

    Joined:
    Jul 31, 2012
    Messages:
    1
    Country:
    United States
    I apologize in advance if this post is in the wrong place or too confusing or something, but even after extensive poking around elsewhere I could only find half-answers to my question, and I want to make absolutely sure of what I'm doing.

    You see, I plan to update soon from my old DSi to a brand new 3DS XL. The only problem is, I don't want to go through with it if I can't take all the DS/GBA/GBC/GB on my microSD with me! I understand that firmware updates are made available very quickly on the DSTWO website after Nintendo updates the version on the 3DS, but I haven't really bothered updating my card in a long time because I haven't had any need to update my DSi.

    Anyway, long story short, I'd like to sell my DSi in order to help come up with the necessary scratch to purchase the 3DS. Will not owning an older model DS make it impossible to update my Supercard for playing on the 3DS? I can update to the newest version on my DSi now (before I trade it in), but will it be possible to use the 3DS to update the card in the future, even after Nintendo patches it? I just don't want this line:

    "...if you have the latest version console and can not run EOS system, sorry, you have to find one..."

    to ever apply to me.

    Again, sorry if this is too confusing of a question, and thanks for any help guys. :)

    -kabuto
     
  2. bazamuffin

    Member bazamuffin RESIDENT DILF

    Joined:
    Feb 1, 2009
    Messages:
    2,036
    Location:
    Shmashmortion Clinic
    Country:
    United Kingdom
  3. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Unlike other flash carts, the DSTwo can update itself to an extent after it's been blocked, but this doesn't always work and shouldn't be relied on.
     
  4. Terminator02

    Member Terminator02 ヽ( 。 ヮ゚)ノ

    Joined:
    Apr 10, 2010
    Messages:
    4,517
    Location:
    Somewhere near monkat
    Country:
    United States
    The simple answer for you would be to update to the latest firmware now on your DSi (and drop the latest EOS on your MicroSD card), then it will work on your 3DS. In the future when Nintendo updates the 3ds, you'll have to wait until the supercard team releases their latest firmware that is compatible and then update the firmware (same as you did on the DSi) of the DSTWO. It will then be compatible when you update your 3DS' firmware.

    Short answer: Update your DSTWO's firmware BEFORE your 3DS' firmware.

    If you do ever accidently update the 3DS firmware first, as long as you were on a recent firmware (1.12 or higher I believe, not sure, just stay on the latest to be sure), there is an upgrade method like Rydian mentioned, but it has more chance for error and isn't recommended.
     

Share This Page