Having issues with transferring WBFS files to USB flash drive

Discussion in 'Wii - Hacking' started by BoxBoy, Jan 26, 2015.

  1. BoxBoy
    OP

    BoxBoy Newbie

    Newcomer
    6
    0
    Jan 25, 2015
    I followed this guide in order to softmod my Wii (PAL 4.3e firmware) and did so successfully, and have been trying for about three days to transfer backups of my Wii game collection to a (FAT32 formatted) generic 128GB USB flash drive to no success.

    However, once I actually ripped copies of my collection I began to encounter problems with putting them on my flash drive in order to play them. I've used Wii Backup Manager to convert everything into WBFS files (splitting up my larger games) successfully, however when I transfer them to my flash drive the same procedure keeps happening:
    1. I transfer across my games successfully, they show up both when I look at the contents of my WBFS folder and through Wii Backup Manager and other tools properly.
    2. I plug my flash drive into the Wii, and attempt to use a USB loader such as WiiFlow or USB Loader GX to play a game.
    3. I'm told by all of the loaders that only about three or so games are actually on my flash drive.
    4. Upon plugging it back into my computer to check, I find that the space on it is still taken up as if the files were on it but that nearly everything has disappeared and cannot be found on it by any method I have attempted.
    5. I'm forced to reformat the drive in order to use it again since I can't clear it any other way and the process repeats itself as from step one.
    It seems entirely random which files do and do not display once I take out the USB, and I know that the USB itself is functional and compatible with my Wii since I've actually managed to play one or two of my games via it when they stick around on it properly. And I'm using the eject function every time, so I know its not like the files are getting corrupted from that or something similar.

    I cannot for the life of me figure out what the problem is here, as I believe I've followed all steps of the various guides I used correctly and cannot seem to avoid this problem no matter if I manually transfer the files via my computer or use programs like Wii Backup Manager/Wii Game Manager.

    I'd normally assume it was a problem with the WBFS files themselves if not for the fact that it seems random which ones fail to 'stick', and as far as I can recall they've all worked at some point or another - which to me indicates the problem lies somewhere else.

    Has anyone encountered a problem like this? Does anyone know what might be causing the issue? If there's any more info I can give to show what might be wrong please say so.

    Edit: Forgot to mention, USB Loader GX seems to recognize that the disappeared files SHOULD be present since it displays their cover art and names and such - but it takes me back to the Wii menu if I try to launch them and displays a black screen instead of the usual menu-video when I select them. I dunno if that's just because the folders themselves are still present, but I thought I should mention it.


    EDIT 2: If anyone finds this in the future with the same issue then sorry, I never actually got the issue sorted out. Ended up swapping over to using an external HDD with separate partitions for my Wii and Gamecube stuff and used that instead.
     
  2. BoxBoy
    OP

    BoxBoy Newbie

    Newcomer
    6
    0
    Jan 25, 2015
    Far as I can see it's fully functional, but I've done some testing since I made my post and ISO files seem to work with it fine (or at least none have randomly disappeared on me yet).

    Think I'm just gonna set up two partitions, one FAT32 for my Gamecube collection and an NTFS one for Wii ISOs, and will see if I have any luck trying that out.