Hacking vWii - IOS80 or IOS236?

Discussion in 'Wii U - Hacking & Backup Loaders' started by Samwix, Apr 5, 2017.

  1. Samwix
    OP

    Samwix GBAtemp Advanced Fan

    Member
    655
    80
    Dec 25, 2014
    France
    Hi,

    I just installed HBC on my vWii and I want to install cIOS and hack it.

    But should I patch IOS80 or IOS236 (I want to install Nintendont and USB Loader GX channels)?

    Thanks
     
  2. Litle_Bird

    Litle_Bird Member

    Newcomer
    34
    4
    Jan 1, 2017
    cIOS 236 (A patched vIOS36) Is useful for some homebrew applications, however for what you desire it's neither to patch vIOS80 or Install CIOS236.

    To play games from nintendont, nothing is required as it uses the stock vIOS 58. And to play wii games from a USB drive required you to have installed the d2x cIOS in Slots 249, 250 and 251.

    And I would like to give you a BIG WARNING not to patch vIOS 80 unless you really know what you're doing and ready to restore a potential brick. And as second, be careful not to install any old wii IOS, only install vIOSes.

    To install d2x cIOS there are guides for that here on GBAtemp. https://gbatemp.net/threads/the-definitive-vwii-hacking-guide.425852/
     
  3. Samwix
    OP

    Samwix GBAtemp Advanced Fan

    Member
    655
    80
    Dec 25, 2014
    France
    Ok thanks!! I can still install channels without cIOS236/Patched IOS80?
     
  4. Litle_Bird

    Litle_Bird Member

    Newcomer
    34
    4
    Jan 1, 2017
    Personally I would be very careful to install channels tbh... If the channel would have a bad banner that would cause a banner brick, which on the wii was quite easy to fix if you had priiloader installed, however on the Wii U such a brick is much harder to fix. Installing forwarders for Usb Loader GX and such that are in the guide I linked you earlier are okay to install, well since they're verified by alot of pepole to be working.

    A safer way to install channels, which you are uncertain of their safety would be in Emunand. Altough I don't have alot of experience on that, altough I can say that using USB loader GX emunand is quite neat.

    You could install cIOS 236, since there is a custom installer for that specific cIOS which is basically a click to run. But stay away from Patching vIOS 80.
     
  5. Olmectron

    Olmectron GBAtemp Addict

    Member
    2,127
    1,324
    Dec 31, 2012
    Mexico
    A game
    You can "unbrick" banner bricks easily by using the tool FIX94 released recently for accessing the Homebrew Launcher directly when going into vWii mode.
     
  6. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,107
    5,176
    Mar 17, 2010
    Norway
    Alola
    Patched IOS80 is only needed if you want to move pirated/fakesigned WADs to the SD card and run them from the SD card menu. You can also run WADs from the SD card without patched IOS80 by using emuNAND.
    IOS236 is used for installing certain WADs, but IOS249 can be used instead for the same purpose, so it's not really needed.
    Just install IOS249 (base 56) and IOS250 (base 57) using d2x beta10 v52 and you will be fine. Don't use v53-alt.
     
  7. Samwix
    OP

    Samwix GBAtemp Advanced Fan

    Member
    655
    80
    Dec 25, 2014
    France
    Why v53-alt is recommended then?

    Yeah, I meant I wanna install forwarders (I don't really know the difference with channels though)...
    I think I'm going to follow the Definitive Guide you linked!
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,107
    5,176
    Mar 17, 2010
    Norway
    Alola
    v53-alt supports both rear USB ports, which can be a benefit to some people, but it has worse compatibility with emuNAND and USB drives so I generally don't recommend it. If it works fine for you, there's nothing wrong with using it.
     
  9. Olmectron

    Olmectron GBAtemp Addict

    Member
    2,127
    1,324
    Dec 31, 2012
    Mexico
    A game
    I had problemas using v52 with EmuNAND through WiiFlow.

    Using v53-alt as the IOS for WiiFlow solved my issues.
     
  10. Samwix
    OP

    Samwix GBAtemp Advanced Fan

    Member
    655
    80
    Dec 25, 2014
    France
    Hm... If there's low compatibility with USB drives then it's pretty problematic since I use Nintendont with one...

    How to replace v53-alt by v52 if I need to?
     
  11. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,107
    5,176
    Mar 17, 2010
    Norway
    Alola
    I don't know exactly how much of a difference it makes. v53 seems to work fine for most. I wouldn't worry too much.
    Also, Nintendont isn't affected, it doesn't use cIOS.
     
  12. Samwix
    OP

    Samwix GBAtemp Advanced Fan

    Member
    655
    80
    Dec 25, 2014
    France
    Nice, thanks!