Hacking Suggestion Good news for Switch users running OFW 9.0.0

MonsterHunterJay

Member
OP
Newcomer
Joined
Sep 11, 2019
Messages
16
Trophies
0
Age
29
XP
158
Country
United Kingdom
Looks like atmosphere is nearly ready - just hold out a couple of days!

Whoop!
37d1ee9a8fbc283f53e8d37f6691b192.jpg


Sent from my Pixel 3 XL using Tapatalk
 

DominoBright

Well-Known Member
Member
Joined
Sep 21, 2009
Messages
295
Trophies
1
Age
40
XP
2,031
Country
United States
Looking at the second post, it seems like 9.0.0 broke homebrew, controller inputs specifically, and new versions must be made for inputs to work. Probably not a problem for RetroArch, but it kinda has me worried for pSNES...
 

urherenow

Well-Known Member
Member
Joined
Mar 8, 2009
Messages
4,360
Trophies
2
Age
46
Location
Japan
XP
2,941
Country
United States
Looking at the second post, it seems like 9.0.0 broke homebrew, controller inputs specifically, and new versions must be made for inputs to work. Probably not a problem for RetroArch, but it kinda has me worried for pSNES...
why wouldn't it be a problem for RA? EVERYTHING is effected that runs on the Switch FW. Unless you're specifically talking about Lakka... that's a different story
 

Rahkeesh

Well-Known Member
Member
Joined
Apr 3, 2018
Messages
2,151
Trophies
1
Age
41
XP
2,929
Country
United States
Because RA is being compiled every night and inactive devs aren't compiling anything.

Course if the source is up someone else can compile it, but they won't be able to post it to the original github page.
 

phillyrider807

Well-Known Member
Member
Joined
May 2, 2009
Messages
440
Trophies
1
XP
1,319
Country
United States
Sucks that all homebrew has to be recompiled. There's alot of homebrew out there people are using that are no longer supported.

Me personally as long as Goldleaf/Checkpoint and retroarch works im good.
 

reminon

Well-Known Member
Member
Joined
Feb 7, 2016
Messages
428
Trophies
0
Age
31
XP
748
Country
United States
Looking at the second post, it seems like 9.0.0 broke homebrew, controller inputs specifically, and new versions must be made for inputs to work. Probably not a problem for RetroArch, but it kinda has me worried for pSNES...
I don't see why you are worried about psnes. Cpasjuste has always kept their builds up to date when neccessary. Not to mention the Pemu source is up on github, and easy to find
 

evans05

Well-Known Member
Member
Joined
May 3, 2013
Messages
119
Trophies
0
Age
38
XP
342
Country
9.x update: as a stopgap measure, Atmosphere's support update will add a mitm that fixes the HID initialization issue. We'll remove it in a future Atmosphere release, after devs have had some time to re-compile their homebrew without having to rush. that was his latest tweet, about 4hrs ago
 

Rahkeesh

Well-Known Member
Member
Joined
Apr 3, 2018
Messages
2,151
Trophies
1
Age
41
XP
2,929
Country
United States
This does nearly jack to homebrew, if Nintendo were trying to screw anyone, it would be certain unlicensed 3rd party controllers. But its just as likely aimed at the Switch lite or the Hori split pad or some new controller they are cooking up.
 

smf

Well-Known Member
Member
Joined
Feb 23, 2009
Messages
6,312
Trophies
2
XP
5,206
Country
United Kingdom
funny how they only broke directional input and not every other input (ex touchscreen) I feel they were more targeting emulators than anything else

I doubt it was intentional. libnx probably just did something wrong.

The likelihood that nintendo would put out a system update on a game cart which stops someone who is offline from using their old game carts, is kinda low.
 
Last edited by smf,

michelb

Member
Newcomer
Joined
Sep 18, 2016
Messages
15
Trophies
0
Age
52
XP
247
Country
Canada
On OFW 9.0.0. Updated to Atmosphere 0.9.4 and now can boot to Atmosphere (thank you to all involved) but I can't launch any of my installed NSPs (just get "Unable to start software"). Do I need to update the keys or something? If so please point to instructions (or at least describe what I need to do (I thought after previous updates, I just had to update the Atmostphere).

Let us know. Thanks.
 

Dave_Chad

Well-Known Member
Member
Joined
Jun 29, 2016
Messages
723
Trophies
0
Age
35
XP
2,153
Country
On OFW 9.0.0. Updated to Atmosphere 0.9.4 and now can boot to Atmosphere (thank you to all involved) but I can't launch any of my installed NSPs (just get "Unable to start software"). Do I need to update the keys or something? If so please point to instructions (or at least describe what I need to do (I thought after previous updates, I just had to update the Atmostphere).

Let us know. Thanks.
You need the latest sig patches. Check the Sweet Patches for Atmosphere thread.

Sent from my VOG-L09/Huawei P30 Pro
 

You may also like...

General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: With that camera nothing is hidden lol