Giant error in the new A9LH guide...

Discussion in '3DS - Homebrew Development and Emulators' started by smileyhead, Aug 24, 2016.

  1. smileyhead
    OP

    smileyhead Bow ties are cool.

    Member
    GBAtemp Patron
    smileyhead is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,442
    5,061
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    In Part 2, we're instructed to:
    Now, here's the problem: using the newest version of Decrypt9, I was not prompted to backup sysNand to NANDmin.bin, the program just skipped this step, and after selecting the image, it immediately started checking and injecting it, thus I am now stuck on 2.1 without a backup. Brilliant.
     
    Last edited by smileyhead, Aug 24, 2016
    Quantumcat likes this.


  2. Razorzeto

    Razorzeto Darkness can not drive out darkness.

    Member
    182
    213
    Aug 27, 2015
    Currently living in Chile.
    Pick a 9.2 ctrtransfernand that match your region and inject that with decrypt9.
     
  3. smileyhead
    OP

    smileyhead Bow ties are cool.

    Member
    GBAtemp Patron
    smileyhead is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,442
    5,061
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    I'm already injecting my emuNand backup, but thanks. :)
     
  4. Razorzeto

    Razorzeto Darkness can not drive out darkness.

    Member
    182
    213
    Aug 27, 2015
    Currently living in Chile.
    Lol
     
  5. smileyhead
    OP

    smileyhead Bow ties are cool.

    Member
    GBAtemp Patron
    smileyhead is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,442
    5,061
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    I've installed A9LH and then made a new emuNand backup from there, and restored it as my sysNand.
     
  6. vb_encryption_vb

    vb_encryption_vb That hardmod guy....

    Member
    1,853
    891
    Nov 21, 2015
    United States
    Acworth, GA
    You had to be prompted... You have to press A or B to continue....Maybe you hit a button and didn't realise it.
     
    Xiphiidae and KiiWii like this.
  7. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,672
    1,220
    Nov 17, 2008
    United Kingdom
    Yep you have to press a button to do it or b to skip it.

    I did mine following the new guide today.

    My issue was I didn't have wifi settings on my handheld at all and going into settings on 2.1 and back out again black screened for about 3 mins and I feared the sleep mode brick. But it was fine after a hard reset.
     
    Last edited by KiiWii, Aug 24, 2016
  8. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    2,811
    1,680
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    At this point it's impossible for anyone to get stuck on 2.1. If someone does what OP does and accidentally skips the sysNAND backup (D9 does prompt, you just probably weren't paying attention and accidentally hit B, PEBCAK) you can always just download the 9.2 ctrnand transfer and use that to get back to 9.2.
     
    Xiphiidae and Quantumcat like this.
  9. Clector

    Clector GBAtemp Advanced Fan

    Member
    954
    228
    Mar 15, 2016
    Bangladesh
    Not here
    @TheCyberQuake Well after all a New 3DS it"s put in Sleep Mode in 2.1.0-X or if you make a System Format with a 2DS you will be stuck in the System Setup and Recovery Mode can"t be possible to update it. Also a System Format in 2.1.0-X in a New 3DS won"t be a good idea too.
     
  10. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    2,811
    1,680
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    But at that point it's considered a brick, and not just "being stuck on 2.1". If you aren't bricked you can't get stuck on 2.1. Now you can brick yourself in 2.1 if you aren't careful.
    Also, and this is just from my understanding and has not been tested nor verified, but if you format 2ds while on 2.1 after you install a9lh, you could probably use D9 still to transfer 9.2 ctrnand and potentially fix that issue, but that's just an educated guess based on my limited knowledge of how the 2ds works.
     
    Xiphiidae likes this.
  11. Clector

    Clector GBAtemp Advanced Fan

    Member
    954
    228
    Mar 15, 2016
    Bangladesh
    Not here
    Well even so there"s no CFW that run in 2.1.0-X but you will be able to use Decrypt9 if you install Arm9LoaderHax in 2.1.0 in theory, but if you make a System Format in 2.1.0-X as normal (that"s the only way to do because there isn"t a CFW that works in 2.1.0-X) that some people do for error you get stuck because the Setup wants you to turn on the 3D with the slider and there isn"t a way to turn it in a 2DS, this last happens with System Settings lower than 6.0.0-X in 2DS because that was the first Firmware for the 2DS.
     
  12. Pikasack

    Pikasack What is a title

    Member
    632
    203
    Apr 27, 2015
    Canada
    Doesn't RxTools support 2.1.0?
     
  13. Clector

    Clector GBAtemp Advanced Fan

    Member
    954
    228
    Mar 15, 2016
    Bangladesh
    Not here
    I don"t remeber personally about that since I don"t really use CFW, but even if RxTools doesn"t work in Arm9LoaderHax.
     
  14. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    2,811
    1,680
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Actually there is a A9LH version of rxTools (or one of the many variants of rxTools), though no one should really use it at this point.
    And from what I know rxTools won't run on 2.1 Otherwise Plailect and other devs would have said in the past to use that instead if people got stuck on 2.1 without a 9.2 nand backup.
     
  15. Jacklack3

    Jacklack3 ( ゚ヮ゚) buddie was here

    Member
    1,483
    1,888
    Oct 6, 2015
    Canada
    In your basement Dick Size: 5 meters.
    Yep, got the same thing. No "Would you like to backup sysNAND?" it just skipped it.

    But i have A9LH so i don't need it anyways now. :D
     
  16. vb_encryption_vb

    vb_encryption_vb That hardmod guy....

    Member
    1,853
    891
    Nov 21, 2015
    United States
    Acworth, GA
    Hmmm, everyone I've done so far has gotten it. It's literally after you select auto ctr or whatever it is.
     
  17. MsMidnight

    MsMidnight part time fe modder

    Member
    1,753
    1,308
    Oct 12, 2015
    kys
    no. the otp gets locked already hence no 2.1 cfw loaders
     
  18. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,314
    1,712
    May 30, 2015
    United States
    If people are looking to boot 2.1 on a9lh, look no further than Corbenik. It works fine to boot 2.1 (when using a proper NFIRM)

    On that note, why would system formatting on n3ds cause issues? It actually has a 3d slider, though we haven't tested a system format yet, I don't see an issue with doing it (knowing how the process works, it's rather obvious that it'll most likely work) anyways, there is no way to get stuck on 2.1 unless you don't have a functional browser or a9lh
     
    Last edited by dark_samus3, Aug 27, 2016
    peteruk likes this.
  19. Clector

    Clector GBAtemp Advanced Fan

    Member
    954
    228
    Mar 15, 2016
    Bangladesh
    Not here
    More than don"t work it can cause issues due to the System Settings and the whole Firmware being for Original 3DS as some others things also don"t work properly in a New 3DS in 2.1.0-X, so unless someone with a Hardmood test it to don"t cause issues, it will be very dangerous to do it.
    But saying a 2DS can literally get stuck with a System Format, without much to do than use Hardmod in case there"s a functional backup.
     
    Last edited by Clector, Aug 27, 2016
  20. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,314
    1,712
    May 30, 2015
    United States
    Well, testing was done. The results are in, the 3ds will get stuck in an infloop because it cannot access TWLN due to the NCSD header being different on 2.1 (the NCSD header contains the TWLN MBR, which is encrypted with a console specific key)
     
    peteruk likes this.