Hardware GBA GBA SP that had audio no longer does

binglet0n

New Member
OP
Newbie
Joined
Aug 23, 2023
Messages
2
Trophies
0
Age
22
XP
32
Country
United States
So I bought a GBA SP from a local game store, and it worked totally fine, even the audio. I then modded it with a GBA accelerator and a new shell + screen, but while testing I noticed the audio had disappeared after hearing a weird static noise from the speaker. I figured it was no big issue since it had been working so I continued, but it still isn't working and I'm at my wits end. I've tested the slider and it was fine, the speaker is good and the 2 other replacement speakers also don't work with this board, and I even replaced the AMP and audio capacitor to no avail. My guess is something in the audio circuit got shorted but I can't for the life of me figure out what it could be, as all of my continuity testing makes it seem like everything is perfectly fine. The board is an AGS-CPU-21 and is in what looks to be great condition before and after modding it.

I did use the circuit info from the Gekkio github page and while it's been helpful, I still can't pinpoint my issue. Any help would be appreciated. Also, I modded it with a Type-C Charge Mod and the audio still worked after that.
 

moon_rabbit

Well-Known Member
Member
Joined
May 6, 2022
Messages
157
Trophies
0
Age
34
Location
kor
XP
342
Country
Korea, South
This may be a 3.5mm stereo jack problem.

If there is a sound coming from the jack
The jack needs to be replaced.
 

binglet0n

New Member
OP
Newbie
Joined
Aug 23, 2023
Messages
2
Trophies
0
Age
22
XP
32
Country
United States
GBA SPs don't have stereo jacks; you have to buy an adapter for them to use with the transfer port. I did order one a day or two ago to test if there is audio coming from that, but the speaker had been working before so I'm almost certain the transfer port isn't the fault here.
 

moon_rabbit

Well-Known Member
Member
Joined
May 6, 2022
Messages
157
Trophies
0
Age
34
Location
kor
XP
342
Country
Korea, South
I forgot that SP doesn't have a 3.5mm.

I think the fastest way is to remove all mod and check audio signal with an oscilloscope.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • Veho @ Veho:
    "No points for grazing him, that's just amateur hour."
  • K3Nv2 @ K3Nv2:
    Some are saying the kid was paid off by a online terror group or whatever
  • Veho @ Veho:
    "Disturbed young man."
  • Veho @ Veho:
    "Iranian sleeper agent."
  • Veho @ Veho:
    "False flag."
  • K3Nv2 @ K3Nv2:
    I don't get people that make these attempts knowing they'll die just go in balls deep kamikaze style
  • Veho @ Veho:
    Too many meat shields in the way, sniping from a high vantage point is the only way.
  • K3Nv2 @ K3Nv2:
    But it was ar15 iirc
  • Veho @ Veho:
    AR-15, effective range 500 yards, and the guy was at 150 yards from Trump.
  • K3Nv2 @ K3Nv2:
    Still missed
  • Veho @ Veho:
    Skill issue.
  • SylverReZ @ SylverReZ:
    Take the L. :tpi:
  • K3Nv2 @ K3Nv2:
    Wouldn't be the first time Trump got red skeeted on his face
    +1
  • K3Nv2 @ K3Nv2:
    I was reading the kid failed shooting classes left and right imagine if it was a pissed off marine
    +1
  • Veho @ Veho:
    Or a pissed-on marine.
  • Veho @ Veho:
    There will be other rallies.
  • K3Nv2 @ K3Nv2:
    The story of how a new born took aim at trump
  • K3Nv2 @ K3Nv2:
    How could the secret service see this coming
  • Veho @ Veho:
    Doesn't the baby have the right to bear arms?
  • K3Nv2 @ K3Nv2:
    Raised by bears grew claws
  • Veho @ Veho:
    I choose bear.
  • Tofu_mommy @ Tofu_mommy:
    is there a way to hide my country? I can't find an option to do so.
  • Veho @ Veho:
    Set it to the South Pole or something.
    Veho @ Veho: Set it to the South Pole or something.