Gateway Save Bug

Discussion in '3DS - Flashcards & Custom Firmwares' started by Oracleofire, Jan 22, 2015.

  1. Oracleofire
    OP

    Oracleofire Newbie

    Newcomer
    9
    0
    Mar 14, 2009
    United States
    Hi guys, so i don't know if this has been posted here before or not but this bug just hit me like a meteor and i lost hours of gameplay. i was just done playing kirby: triple deluxe as i have many times before, exiting and letting the gateway transfer the save to the sd card. however, this time when i exited, the system stayed on the "closing software" screen. the audio and 3d slider still worked so i don't think the system froze. i waited for thirty minutes before i powered down the system, and when i booted up the game my save was lost! KIRBY@!!!! T_T.

    so yeah, this is just a warning to all you guys to not do ... um ... i don't know, exactly. i guess that's the problem. what happened here? hopefully someone knows what be going down. in the meantime, you guys can say a little prayer for my kirby save T^T.

    P.S: SO WHILE WE'RE HERE,, DOES ANYONE HAVE A SAVE FOR THE US VERSION OF KIRBY: TRIPLE DELUXE RIGHT BEFORE THE 6TH WORLD? i need to save dedede!! thanks :lol:
     
  2. samiam144

    samiam144 RĂ©gulier

    Member
    2,871
    935
    Aug 19, 2007
    Canada
    Your save got corrupted or overwritten with a new save because Gateway saves your .sav files to the SD card when exiting a game. But since yours crashed while trying to exit the game, it wasn't able to save. BUT, from what I can remember reading, I THINK your save is still saved within the chip in the gateway red card, and you can still load the save, AS LONG as you don't boot another game. You have to boot into Kirby, and as soon as you can, exit the game through the home button. That way, gateway should be able to copy the save in the chip to the SD card.

    Someone please correct me if i'm wrong lol
     
  3. Oracleofire
    OP

    Oracleofire Newbie

    Newcomer
    9
    0
    Mar 14, 2009
    United States
    i can correct you, because i just tried and it didn't work :cry:. the very first thing that pops up upon boot is "an error has occurred", I exited here and it closed properly. When I rebooted the game it told me the save data was corrupted and took me to three blank files. still, thank you very much for your suggestion. it was a better idea than anything i had :bow:. what a weird bug though... very ninja-like, like all is well, exited+saved with no problems before, and then ":toot: surprise! SAY GOODBYE TO YOUR SAVE SUCKA "
     
  4. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,002
    1,619
    Sep 5, 2013
    Brazil
    This only happened to me when there was a contact problem with the 3DS's SD card (I was using a microSD in an adapter).
     
  5. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    if it happens again, when you power down,take the SD out, backup what saves on there,then try going back to playing the game it froze on......only time anything like this happened to me it turned out i had filled my SD card up when dumping retail cards and forgot to delete them after transferring them.....idk if that was the reason, but im assuming it was something to do with the SD being full.......life lesson is just make regular backups of all your saves whenever you have you 3ds SD in your computer...just back them up takes a few seconds and will be a life saver if anything ever messes up :P

    yeah you may not get 100% back but better than nothing (just remember to only restore the back up of games you loose the save on....don't overwrite all your saves with old one's if you only lost a kirby save for example)

    although this has only happened to me once....so its probably very rare (and the time it happened to me it was back on 2.0b1 which was known to be a bit funny with saves)
     
  6. Oracleofire
    OP

    Oracleofire Newbie

    Newcomer
    9
    0
    Mar 14, 2009
    United States
    thank you for your suggestions! i did do some research and i found out the problem happened to a lot of people on older firmwares, but the weird thing is i'm on 3.0.1 and my sd card had a ton of space left and i was not using an adapter... so it's a very strange problem that just seemed to randomly happen. the sad thing then is that i can't find out what caused it, so i can't warn everybody what not to do :[. just backup your saves often like what gamesquest1 said, i will backup my saves more often too now. could this be a revival of the old bug? :mellow: anyway i found a save that is 98% complete, which is not bad because i was almost done with the game anyway, but it's like that feeling when your goldfish dies and your mom secretly tries to replace it, and for the most part you can convince yourself but deep down... YOU KNOW IT'S NOT THE SAME :cry:. luckily kirby is not a game with a lot of variables, but if it happened on an RPG, omg. destruction everywhere guys. i will rain destruction everywhere. :hateit:

    thanks again for the replies, and remember to backup your saves often everyone!! i know you might think people say that a lot and you brush it off, but when the save bug ninja comes and you lose your save, you're gonna turn into one of those people lol