Gateway NVRAM mod on 2DS?

Discussion in '3DS - Flashcards & Custom Firmwares' started by BaronFauntleroy, May 10, 2015.

  1. BaronFauntleroy
    OP

    BaronFauntleroy Newbie

    Newcomer
    3
    1
    May 10, 2015
    United States
    So, I noticed that Gateway can add the MSET exploit back into the New 3DS by using the old System Settings menu. (I'm actually kind of curious as to how that works, because the New 3DS has new settings for the new screen and Amiibos, right? I don't have a New 3DS, though, so I guess that's a question for another time.)

    Anyways, I understand why they don't have any instructions for classic 3DS models- if it weren't a 2DS, I'd just downgrade it. But it is, and a 2DS won't take anything below 6.0. So, can I install the old System Settings thing through the Gateway installer without bricking it? I already installed an 8.1.0 update from a Smash Bros cart by accident, scared myself half to death...
     
    2DSGamerdude likes this.
  2. Madao64

    Madao64 Really Useless Old man

    Member
    954
    666
    Dec 4, 2014
    Senegal
    South of the equator
    The MSET exploit does not work for O3DS for now, inclusive of 2DS, last i heard.
     
  3. BaronFauntleroy
    OP

    BaronFauntleroy Newbie

    Newcomer
    3
    1
    May 10, 2015
    United States
    The profile exploit? Maybe I called it the wrong thing, but for a long while, that was the only way to access Gateway on any O3DS... Or does it just not work with the Gateway downgrader thing on an O3DS right now?
     
  4. dedChar

    dedChar (ノಠ益ಠ)ノ彡┻━┻

    Member
    260
    66
    May 5, 2015
    Gambia, The

    No, the MSET downgrade only works with N3ds right now. Maybe later with o3ds/2ds too.
     
    Margen67 likes this.
  5. JaapDaniels

    JaapDaniels GBAtemp Fan

    Member
    361
    66
    Apr 22, 2012
    Netherlands
    i really hope so! would be fun!
     
    Margen67 likes this.
  6. gameus

    gameus Advanced Member

    Newcomer
    78
    16
    Apr 5, 2015
    United States
    Downgrading the systems is possible on O3DS but from what I remember reading, you can't launch the MSET exploit due to the current ROP loader, so gateway would have to modify their launcher in order for it to work.
     
    Margen67 likes this.
  7. 2DSGamerdude

    2DSGamerdude GBAtemp Regular

    Member
    208
    34
    Apr 6, 2015
    Greece
    Gamecube Land
  8. BaronFauntleroy
    OP

    BaronFauntleroy Newbie

    Newcomer
    3
    1
    May 10, 2015
    United States
    Thanks for the info, everyone! Aw, the 2DS gets no love... I actually sent a Gateway back to the distributor I got it from because I thought I broke it when I tried to use it with my 2DS. Nope, just flaky as heck. Works beautifully in my original 3DS with the broken charging port that I swap batteries with the 2DS to use, though!

    So, I'm taking a wild shot in the dark here (I might need to read more), but here's an idea- My Gateway won't play games reliably on my 2DS, but it will load EmuNAND and therefore DevMenu just fine. Isn't there a tool around here that lets you install CIAs? Isn't there also a tool around here that lets you write CIAs to SysNAND? If both of those are true, could I downgrade the System Settings app? I've seen people do that with the browser on 3DSs, but never on a 2DS.

    Hope I'm not working on a brick...
     
  9. Typhin

    Typhin GBAtemp Fan

    Member
    305
    101
    Jan 30, 2008
    United States
    DevMenu and BigBlueMenu would let you install CIAs onto whichever nand you're booting at the time. So if you boot sysNand and run them, you could install to sysNand. However, the issue with the 2DS is that there is not a version of the System Settings app that both has the exploit and runs correctly on a 2DS. (At least, that's my understanding of the issue.) It may be possible to modify the o3DS or n3DS versions so that it could be put onto a 2DS and work, but until that is done, downgrading the System Settings app is not possible.

    If you were to use these to install games to sysNand, you would still run into the problem of not being able to play them outside of Gateway mode, since the signatures would not be valid. If you can reliably enter Gateway Mode, then installing them to emuNand would be the better way to go.
     
  10. dedChar

    dedChar (ノಠ益ಠ)ノ彡┻━┻

    Member
    260
    66
    May 5, 2015
    Gambia, The
    Have to correct you on the system settings thing. You can downgrade the settings on 2ds and o3ds too, but the only thing is that gateway didn't implement it into their launcher.dat for 2ds/o3ds, only n3ds at the moment.
     
  11. Typhin

    Typhin GBAtemp Fan

    Member
    305
    101
    Jan 30, 2008
    United States
    Ah, seems like a bit of an odd oversight, then. I suppose they'll roll that into the next version of the launcher, most likely. On o3DS, I downgraded the entire firmware to 4.2, so I hadn't tried the mset.cia myself but had heard others say it didn't work for o3DS/2DS, so I assumed it was modified specifically for n3DS. Thank you for the information.