Gateway menu problem on n3ds

Discussion in '3DS - Flashcards & Custom Firmwares' started by VegaRoXas, Nov 2, 2015.

  1. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    So I'm trying trying I help a friend setting up a cfw. Browserhax already works fine. The problem would be the gateway menu now. Apparently you need to have cubic ninja or Zelda oot for that. Luckily we both have oot and I have a 2ds with cfw. So I booted up gw menu with the browser and imported the save and extracted it for him using svdt. He then imported it and tried to load the menu. Everything shows up, but when he presses A only that white screen is being showed at the bottom screen. We have tried it many times. Also using different sdcards, but sadly nothing works.
    We need the gateway menu because we want to create emunand.
    I also thought of booting up rxmode and then installing cn. The problem is that it fails whilst displaying that it failed to load native firm: 4. I / we reallz hope someone can help us!
     
  2. Quantumcat

    Quantumcat Dead and alive

    Member
    11,597
    6,234
    Nov 23, 2014
    Australia
    Canberra, Australia
    Can you add a picture of it showing the white screen? I can't picture it.
    Are you using the latest gateway launcher (3.4.1 I think it is)? And when you say you press A and it shows a white screen do you mean on the format emuNAND option?
     
  3. johnboyjr

    johnboyjr Advanced Member

    Newcomer
    57
    20
    Jul 24, 2011
    United States
    ok 2 things i think it could be

    1. did you put the gateway launcher on the sd card in the system (the one behind the back cover)

    2. if you press a to fast sometimes it wont load. let the game sit there for a few sec then hit a
     
  4. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    http://imgur.com/Tb7ykuE
    We don't even get to any option. When you start gateway the screen goes from left to right white. And yes we did use the latest version.
    1. We don't have the gateway card so yes it is in the back.
    2. We'll try that. Thank you. Edit: doesn't work
     
    Last edited by VegaRoXas, Nov 3, 2015
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,343
    5,349
    Mar 17, 2010
    Norway
    Alola
    You cannot extract the Gateway OoT save with svdt, SaveDataFiler or any other method, it breaks the payload.
    Simply import the .sav from Gateway's archive to the cart using the GW menu on your hacked 2DS. Nothing more is needed.
     
  6. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    Well I can do that. But he can't. He doesn't live near me so that wouldn't work. But why does it break the payload?
    Maybe we could boot up pasta and install cubic ninja? We don't have to import anything. We just have to scan the qr code so this could work right?
     
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,343
    5,349
    Mar 17, 2010
    Norway
    Alola
    Because Gateway made their exploit to read the payload from a specific address in the .sav instead of from a specific file, and when you extract and import it, the address is wrong.
    I don't know if the Gateway launcher will load from Pasta, it should. If he owns a DS flashcart he could downgrade mset and launch Gateway from the DS profile exploit.
     
  8. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,041
    1,066
    Jun 28, 2014
    United States
    Arizona Bay
    Load browser hax to load mini pasta to load fbi and install CN, then from there boot CN in pasta and install GW
     
  9. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    We'll do that! Thank you!
     
  10. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    Thank you very much! It does work now.
    We have setted up the emunand and now we want to boot into it with rxtools. It doesn't seem to really work. It says "failed to load native_firm: 4".
    I don't really find anything. https://gbatemp.net/threads/release...olkit-fw-2-0-9-2.382782/page-441#post-5614044 We are using the firmware.bin of reinand patched with that tool.
     
  11. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,343
    5,349
    Mar 17, 2010
    Norway
    Alola
    Try this version of rxTools, the latest one seems to be broken.
    https://www.dropbox.com/sh/blmecish...v4F5a/rxTools_10-02-15_19-07.9f48bb8.zip?dl=0

    Also, that post is very old, that firmware.bin might be outdated. Try with the firmware.bin from this reinand pack:
    https://mega.nz/#!Y8JmDQia!8BL9dW7j7_z7-UAPbTCwBLK62wl9dGNZz7_7S7YSMbg
    Rename it 0004013820000002orig.bin and put it in rxtools\data, if that doesn't work name it 0004013820000002.bin
     
  12. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    Thank you! Now we are in emunand! We have already successfully unlinked both nands and fixed the dbs.
    But whenever we try to install for example the cia of fbi (using fbi launched with themehax) it says "Wrong argument" and fails to install.
    Maybe you can help us one last time?
    EDIT: Same problem in sysnand.
    EDIT2: The only thing that works is pasta. Not even devmode in rxtools works.
     
    Last edited by VegaRoXas, Nov 3, 2015
  13. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,041
    1,066
    Jun 28, 2014
    United States
    Arizona Bay
    So mini pasta works?
     
  14. tivu100

    tivu100 GBAtemp Addict

    Member
    2,028
    438
    Jun 6, 2015
    United States
    Can you give a full error code and error description?

    So I did a quick search I came upon this

    https://gbatemp.net/threads/release-fbi-open-source-cia-installer.386433/page-21#post-5451082

    So my ignorant workaround would be: (You have to do the whole EMUNAND-creating process again):

    Browserhax/THemehax-> HBL-> Pasta CFW/mini Pasta -> BrowserHax/Themehax-> HBL -> FBI-> Install Devmenu CIA-> Browserhax/THemehax-> HBL-> Pasta CFW/mini Pasta -> Devmenu -> install FBI CIA -> Optional: Delete Devmenu-> Back up Nintendo 3DS folder from SD to PC -> Format EMUNAND -> Format System Memory (unlink NANDs) -> restore Nintendo 3DS folder -> install Rxtools.

    You can also create EMUNAND on your PC with the NAND back up using this https://gbatemp.net/threads/release-3ds-multi-emunand-creator.381603/
    (Make sure you delete the old Emunand partition before you can create new EMUNAND partition using this tool)
     
    Last edited by tivu100, Nov 4, 2015
  15. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    This is the error it shows: http://imgur.com/9kxAHfy
    So the CIA version of FBI will be able to install personal CIAs?
    Also, thank you very much! I think this will help us!
    Edit: @Ronhero yes it works.
     
    Last edited by VegaRoXas, Nov 4, 2015
    Ronhero likes this.
  16. tivu100

    tivu100 GBAtemp Addict

    Member
    2,028
    438
    Jun 6, 2015
    United States
    I am not 100% sure whether it would fix. The thing is when you use Devmenu to install the FBI CiA, it will give the FBI (CIA) full signatures patch to install personal CIA. Therefore, just try, it may help.
     
    Last edited by tivu100, Nov 4, 2015
  17. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,343
    5,349
    Mar 17, 2010
    Norway
    Alola
    That's not how it works. The permissions are preset in the CIA file.
    And it's a legit personal CIA, technically it shouldn't even need signature check patching.
    No one has figured out why personal CIAs can't be installed on most CFWs yet.
     
    tivu100 likes this.
  18. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    Ok we now had everything up and running! "had".
    Formatting emunand whilst devmenu etc is installed on sysnand didn't work. What we did is we installed devmenu using pasta whilst the nands were linked.
    That allowed us to install everything else in emunand. After that we unlinked them and everything was working fine. We set up autoboot (with some nice images :P) and it was done. The problem was that we still were on 9.0 so we updated the emunand. Problem is that it now doesn't boot up emunand anymore. It's just a black screen. We assumed it was because of themehax (which was still installed in emunand) so we deleted the theme extdata folder from the emunand.
    But unfortunately this didn't work :/
    Is there any way for us to fix it? Or just get a higher version than 9.2 in emunand?
    Also his newest cartridge game is Pokemon X so we can't update from the cart.
     
  19. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    DalvĂ­k, Iceland
    You cannot just insert random SD cards into the system. The original one you use is encrypted. So, only that one can be used. Unless, you back up the SD card and copy and paste it to a new one. Otherwise, not possible without a total SD card back up.
     
  20. VegaRoXas
    OP

    VegaRoXas GBAtemp Regular

    Member
    290
    158
    Mar 29, 2015
    Gambia, The
    Well we didn't do that. Also this was already fixed. There are new problems :/