Gateway Fragmentation Error. Please help!

Discussion in '3DS - Flashcards & Custom Firmwares' started by Starzboy77, Dec 22, 2015.

  1. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    My girlfriend left Ocarina of Time in sleep mode using my Gateway with a Class 10 Sandisk 32gb microsd card for at least weeks. It was charging the entire time. So without testing it at all I upgraded from 10.1 emu to 10.3 and Gateway 3.4.1 to 3.5.1. Now I get non stop frag errors when selecting a ROM in Gateway menu. I tried defragging the SD card using defragger, moving all ROMs to PC, formatting SD, moving back all at once. Even just one ROM after a format causes the error. What is going on? Please help.
     
  2. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    I should also add that I added Mario & Luigi Paper Jam EU version as well before testing. I have a US console.
     
  3. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,113
    May 31, 2013
    Belarus
    Caves
  4. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    When I try to run that tool a command prompt window appears for a split second and then closes. Using Windows 10.
     
  5. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    I was able to use the tool, and still no change. Used it without a ROM and with one. Still fragmentation error.
     
  6. OuahOuah

    OuahOuah GBAtemp Maniac

    Member
    1,000
    201
    Oct 2, 2006
    France
    France
    Copy all your microSD content to your PC.
    Format your microSD with Windows (choose exFAT).
    Copy back your content from PC to microsD.

    It occurs sometimes when you delete a game from microSD, then add, then delete, then add, etc.
    Too much fragmented though GW can't read it.
     
  7. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    Have tried that. Still get same frag error no matter what I do. Is it possible the SD card is bad now? It works fine otherwise .
     
  8. json

    json MUSCLEMAN

    Member
    693
    781
    Aug 9, 2013
    Burkina Faso
    What filesystem are you using? How was it formatted?

    Gateway rewrote their filesystem stuff, and this might be a side effect
     
  9. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    I formatted using Windows 10. Did a quick format. Using Exfat file system. Have tried 128 byte allocation, 32, auto default, same result with all. I have also tried using the tool that was linked earlier before and after formatting with different ROMs. Same frag error EVERYTIME. So annoying. Never had an issue before. Not sure it this has something to do with the console being left on for weeks in sleep mode while playing a ROM or updating the GW FW and/or Emu.

    — Posts automatically merged - Please don't double post! —

    I should add. I can see all ROM icons in the gateway menu. As soon as I press A to run one I get he fragmentation error.
     
  10. vegaskid

    vegaskid Member

    Newcomer
    19
    1
    Dec 23, 2015
    United States
    Frag errors in games best use program came with gateway firmware were you split rom works all the time w en if it's a 1 gb game if says frag error you don't need to to do anything to your sd card just use the program came with your gateway firmware download enjoy your games works everytime gw rom splitter tools. Run any frag error games in it and it will fix it everytime no need to format memory chip enjoy !
     
    Last edited by vegaskid, Dec 23, 2015
  11. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    Just tried to split star fox 64 and frag error.
     
  12. vegaskid

    vegaskid Member

    Newcomer
    19
    1
    Dec 23, 2015
    United States
    Then you need new memory chips buy new ones if do t work then format your 3ds I get frag errors I use split Roma it works for me get new chips then post up bye
     
  13. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    896
    Sep 17, 2010
    Belfast
    yeah sounds like the sd card is failing, its a known bug with leaving the 3ds in standby for large periods of time especially in games that are on sd
     
  14. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    Well I found another micro SD and tried it. Frag error still! I guess I'll format the SD card with the emu on it and start over and see if that works?
     
  15. v18281

    v18281 Member

    Newcomer
    41
    7
    Jul 6, 2015
    Afghanistan
    try changing the icon size on the home menu
     
  16. Starzboy77
    OP

    Starzboy77 GBAtemp Regular

    Member
    124
    3
    Feb 4, 2004
    United States
    Well formatting the Emu worked. Too bad I have to start all over but at least it works and I didn't waste money on another micro SD. Thank you to everyone who responded.
     
  17. Xinaman

    Xinaman GBAtemp Regular

    Member
    251
    94
    Sep 21, 2015
    Brazil
    Delete your Nintendo 3ds folder on the 3ds's SD card, worked for me.
     
  18. Varia

    Varia GBAtemp Fan

    Member
    454
    117
    Nov 19, 2010
    Well just so you know for next time - if defragging doesn't work, usually changing the icons sizes or changing the theme fixes the problem.