Games that update the firmware?

Discussion in 'PSP - Games & Content' started by Inunah, May 28, 2010.

May 28, 2010
  1. Inunah
    OP

    Banned Inunah The Female Mistaken for a Male.

    Joined:
    Sep 14, 2009
    Messages:
    2,679
    Location:
    USA
    Country:
    United States
    I'm thinking of getting a PSP soon, and I've heard you can't play UMDs that update the firmware if you want custom firmware.....

    What are these games, so I can avoid purchasing them at gamestop (I want at least a retail copy of SOME games.....)?

    I mean recent games that would update the firmware to above the recommended level and would make cfw start involving pandora batteries and shit.
     
  2. Zerousen

    Member Zerousen 【=◈︿◈=】

    Joined:
    Jun 30, 2009
    Messages:
    1,948
    Country:
    United States
    Well, some of the newer games like Prince of Persia require FW 6.20, which is the most recent. If you are planning to hack your PSP, KHBBS, Prince of Persia, and God eater are the only games that I know of. The safest bet is to hack the psp before playing any legit games, and I think they ask if you want to update the PSP or not first.
     
  3. ProtoKun7

    Global Moderator ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Joined:
    Jan 3, 2009
    Messages:
    7,480
    Location:
    Gallifrey
    Country:
    United Kingdom
    Yeah, they won't force update, they'll always have to ask if you want to update.
     
  4. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    My advice to you would be to look at Metacritic for the games you're interested and if you're worried about them being too recent and requiring to high a firmware then ask again here.
     
  5. Inunah
    OP

    Banned Inunah The Female Mistaken for a Male.

    Joined:
    Sep 14, 2009
    Messages:
    2,679
    Location:
    USA
    Country:
    United States
    Well....... Hmmm.... So I've been told I should avoid firmware over 3.something........

    So when was firmware that low made, so I know dates to look for in gamestop when I go looking for PSP games?
     
  6. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,998
    Country:
    Those games all work with the Prometheus method, though there is still no way to play them from UMD with CFW yet.
     
  7. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    Just dump the UMD and play them from Memory Stick with Promethues method..
     
  8. Inunah
    OP

    Banned Inunah The Female Mistaken for a Male.

    Joined:
    Sep 14, 2009
    Messages:
    2,679
    Location:
    USA
    Country:
    United States
    :\ But I want legit copies of SOME games...... Because what if the PSP crashes back to ofw or accidentally updates?!
     
  9. BoxShot

    Member BoxShot Chiyo-chan :3

    Joined:
    Dec 18, 2008
    Messages:
    3,447
    Location:
    Middle of the ocean.
    Country:
    United States
    That never happens. That is also impossible. Provided you have perm CFW.

    Only way it updates is you intentionally allowing system updates.
     
  10. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    Dumping your own roms shouldn't be illegal in the US. You are protected by Copyright Law over there. You still are technically playing a legit copy of a game.
     
  11. dgwillia

    Member dgwillia The Bacon Lover

    Joined:
    Mar 9, 2008
    Messages:
    2,171
    Location:
    Columbia Station, Ohio
    Country:
    United States
    Hopefully we dont end up like other countries soon
     
  12. Jamstruth

    Member Jamstruth Secondary Feline Anthropomorph

    Joined:
    Apr 23, 2009
    Messages:
    3,456
    Location:
    North East Scotland
    Country:
    United Kingdom
    Or here's an idea.
    CFW yourself to 5.50GEN-D3 which has an in-built decrypter which works with UMDs. Once there install the KHBBS plugin (which works perfectly with all 6.20 games I have tried in ISO format) and the games that require 6.20 should, in theory, work perfectly.
     
  13. xeronut

    Newcomer xeronut Advanced Member

    Joined:
    Oct 4, 2003
    Messages:
    74
    Location:
    Ohio - Land of the Lost
    Country:
    United States
    I'm a 5.00 M33-6 mainstay, and I've been patching my ISOs manually for it (as most of the releases I've found are for Gen-D3, and don't seem to want to boot for me). There are some places you can get pre-patched images from, and I'm sure there are better sources than mine. You can still own your UMDs for conscience's sake and play backup ISOs that are patched to work for you (or, just dump your own ISOs), whatever firmware you run. Self-patching really isn't that hard, just time-consuming and a somewhat more involved process than NDS piracy (if only it were so easy as to wait for a patch). Games started requiring a patch to run on older CFW (or in general got complicated to run) about a year ago - around when Soul Calibur: Broken Destiny came out. So far I've not seen any releases that don't work even on M33-6 yet (English releases anyhow) and even Kingdom Hearts, with all its anti-piracy bells and whistles, works flawlessly on M33-6.

    My advice would be to get on a CFW 5.00 or above, buy what you absolutely know you want to own, and download the rest to sample/demo them. Let your better judgment go from there on future purchases.
     

Share This Page