Hardware Freshly replaced SD card reader doesn't work again

KiwiDuuude

New Member
OP
Newbie
Joined
Jun 27, 2019
Messages
1
Trophies
0
Age
19
XP
19
Country
Germany
So today, after having a broken sd card reader for almost year I finally ordered a new one. I managed to replace it with only one broken screw lol. It worked fine at first: I was able to boot into Nyx and do a complete NAND backup. After I did that, I decided to restart Hekate, but once it loaded up again, I got a message that the SD card is in 1 bit mode or something. So I opened up the Switch again, pressed a little more onto the connector and closed it up again. Once I restarted, it stopped working. Completely. OFW doesn't see the SD card anymore, neither does Hekate. I tried everything: disconnect the reader, reconnect it again, loosen the screw on the reader so it has a bit more room - nothing works. The pins on both the reader and the board seem to be intact, so I'm really confused as to what is happening. Any help?
 

BaamAlex

S̶̥͝l̷̹̀͗e̶̼̖̩̅͊e̷̛̦͉̦p̷̘͌͝i̵͇̠̞̿̌n̷̰͚͌̓͝g̷̦̲̍̆͝
Member
Joined
Jul 23, 2018
Messages
4,194
Trophies
1
Age
26
XP
3,501
Country
Germany
It's what you read on the pop up.
Your sd card reader is either not properly seated or a pin broke on the motherboard connector because of many ejections/insertions. You can still use CFW and OFW. But the sd performance will be a mere 5MB/s until you repair that.
 

LyuboA

Unknown Entity
Member
Joined
Jun 1, 2018
Messages
525
Trophies
0
XP
811
Country
Bulgaria
better get to a repair shop they can fixed Not Nintendo one of course or a technician that you may know have you checked the pins with magnifying glass and also the traces around the connector on the motherboard
 
General chit-chat
Help Users
    Julie_Pilgrim @ Julie_Pilgrim: if you throw your amp into the water maybe