Firmware Version

Discussion in 'NDS - Console and Game Discussions' started by bensons, Mar 12, 2011.

  1. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK
    Only ever had a a DS before, but broke my DSi out of it's hiding place a few days ago. The Firmware Version is 1.2.E

    Do I have to update it/Does it update when I play a new game or whatever?

    If I decide to get n Akekard, do I not have to get one of the up to date ones? (Sort of want to get an EZ Flash VI though.- but will probably go with the crowd!)

    *SORRY*
    I'm sure this has been asked a thousand times already, I did use TFSE without finding an answer though.
     
  2. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
    The firmware updates on the DSi have exclusively been there to block flashcards.
    But if you get an AK2i, you would be able to update the DSi to 1.4.1 and still be able to use the AK2i, provided you updated the Acekard to 1.4.1 beforehand.
     
  3. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    It has nothing to do with games at all.
     
  4. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK
    Sorry if I'm being dumb, but what's the point of updating from my 1.2.E to the latest firmware?
     
  5. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    So that you can use the shop.



    Yes, that's it.
     
  6. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK

    I see, thanks. So people think one should just go for the Acekard2.1? I've been an EZ Flash fan for years now, but I'll go with the crowd.
    [​IMG]
     
  7. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    The 2.1 does not work on the DSi.
     
  8. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK
    Oh, so I DO have to upgrade!? sorry for being stupid! Like I said, I've only ever been a DSLite user and am only just breaking out the DSi
     
  9. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    No, you do not need to update your DSi.

    However if your flash cart is an Acekard 2.1, it will not work on the DSi. The 2i does, the 2.1 does not.
     
  10. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK
    It took a while, but I'm with you now. Thanks for all your help.

    Ok, I've decidede to fh ool kids ndget an acekard 2i and not a EZ-Flash IV (even though they've served me SO well for all these years- I suppose it's right, once a cheater- allways a cheater as I didn't think twice about getting an R4.)

    My only real worry now are all the imitation cards floating about on the market- even being found in some of the reputable outlets. Any way to tell in advance? Any more crimson wolf-like advice? (In the UK by the way, but don't mind waiting a while to get a cheap one from China or wherever as long as I know it's kosher.)

    Thanks again.
     
  11. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,110
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Idunno' about UK shops, sorry.
     
  12. bensons
    OP

    bensons Newbie

    Newcomer
    9
    0
    Feb 1, 2011
    UK
    *SORRY DOUBLE POST*

    Delete if possible.