EZFLash IV not working on GBA SP

Discussion in 'GBA - Flashing Hardware and Software' started by MegaManXis, Apr 28, 2012.

Apr 28, 2012
  1. MegaManXis
    OP

    Newcomer MegaManXis Member

    Joined:
    Sep 18, 2010
    Messages:
    18
    Country:
    United States
    Hey there. I just bought an EZFlash IV and it does not work on my GBA SP. I can boot it up properly on my Game Boy Advance, but my GBA SP will not read it. It boots up as a GBC game, with L and R changing the width. Any help?
     
  2. elgarta

    Member elgarta GBAtemp Fan

    Joined:
    Jan 2, 2012
    Messages:
    421
    Country:
    United States
    Does your SP have problems reading any other GBA carts? Mine loads on the original SP without problems
     
  3. MegaManXis
    OP

    Newcomer MegaManXis Member

    Joined:
    Sep 18, 2010
    Messages:
    18
    Country:
    United States
    I tested out two other GBA games and it booted them up with no problem whatsoever. Could it be a problem with the flashcart? Mine came with a somewhat loose right side. it isn't attached properly and pops off.
     
  4. Catastrophic

    Member Catastrophic Perfectly Normal

    Joined:
    Apr 28, 2012
    Messages:
    659
    Location:
    Somewhere
    Country:
    Iceland
    Same as elgarta. Mine works on my SP just fine!

    Try cleaning the contact pins with rubbing alcohol or something like that.
     
  5. MegaManXis
    OP

    Newcomer MegaManXis Member

    Joined:
    Sep 18, 2010
    Messages:
    18
    Country:
    United States
    I have some more information. I tested 8 GBA games total on my SP and they booted up fine. I tested the EZFlash IV on my GBA and my DSLite and it worked fine. But the SP will not read the EZFlash. I'll take the suggestion and try the rubbing alcohol.
     

Share This Page