EZFlash IV Corruption Issue

Discussion in 'GBA - Flashing Hardware and Software' started by jk102393, Nov 9, 2016.

  1. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    Hi,
    I recently got my EZFlash IV in the mail. I'm having a ton of problems getting games onto it though.
    Every time I add games to the flashcart and go to play them, I'm greeted by a bunch of Chinese characters and broken text where the games should be. Trying to select one of these freezes the system.

    Afterwards, when I put the sd card back into my computer, it pops up as being corrupted and needing to be reformatted. I've tried the official and third party patchers, but it didn't make any difference.

    Could this be an issue with my SD card or is my EZFlash just a dud? Please let me know if anyone can help. I've been stuck trying to figure this out for days.

    Thank you
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,341
    9,121
    Nov 21, 2005
    Sounds like a connection issue. Clean the pins of the cart, also the pins of the SD slot and the SD card. Contact cleaner (not the automotive stuff) if you have it, otherwise a solvent that will not leave anything behind. You can also take out and insert your SD card a bunch of times.

    There are some instances on older loaders with some odd characters and the like but this seems more like dodgy connection somewhere.

    It could also be a dodgy SD card, does it work fine in normal use in a computer?
     
  3. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    So would something like rubbing alcohol work for that? I've never cleaned contacts before and I don't want to ruin them lol.

    The SD card seems to work okay for moving files between computers. Nothing gets corrupted when I do that. Only when I boot up the ezflash. It is pretty old though. I just pulled it out of an old cell phone and its the only spare I had to test out the ezflash. I could try getting another one next time I go to the store.
     
  4. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,341
    9,121
    Nov 21, 2005
    Rubbing alcohol, assuming it is the unscented and not moisturising stuff (you don't want to clean it and then leave stuff behind to render it pointless), was the usual suggestion for US peeps as it doesn't really exist outside the US but is readily available and in a lot of houses already. Use a cotton bud/qtip, don't got hard across the pins. Just make sure it is dry when you power it back up.

    Quick question. Is this a miniSD EZ4 or a micro one? If it is a miniSD then some of the ones from phones were tiny (32 megs and such) and do pose some problems.
     
  5. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    It is a microSD version. Judging from the cartridge and the fact that it shipped with the newest kernel version, it should support SDHC as well right? The SD card I've been using is 4gb. Maybe I should try a non-hc card?
     
  6. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,341
    9,121
    Nov 21, 2005
    Normal SD can be tricky with these. Many have got them to work but many have also struggled. Best not to introduce that if you are already having issues.
    I assume you cleaned the microSD slot and contacts as well, might also be worth inserting and ejecting it a few times.
     
  7. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    I will try cleaning it and putting the card in and taking it out a few times later tonight. Haven't had a chance to do anything with it because of work.
     
  8. Gyron

    Gyron GBAtemp Regular

    Member
    278
    88
    Dec 10, 2014
    Don't forget there is a 77 rom per folder limit. If you go above this number some roms will have corrupt looking or Chinese lettering for their names. If you have a lot of roms, split them into separate folders like so:
    bluenight.jpg
     
  9. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    Well it looks like cleaning the contacts didn't do anything. I guess my next step is to try a new sd card.

    Gyron,
    I've been transferring 1 rom at a time to see if it works so having too many roms shouldn't be the problem
     
  10. jk102393
    OP

    jk102393 Member

    Newcomer
    23
    1
    Feb 15, 2010
    United States
    I got it to work finally. Bought a new microsd as well as a new card reader. Everything added very smoothly and nothing corrupted.
    Thanks for the help