EZ Flash Omega: White screen/Micro SD initial error! (after kernel update)

Discussion in 'GBA - Flashing Hardware and Software' started by Weirdman, May 11, 2018.

  1. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    Hello, I'm new here, but I have a serious problem about my EZ Flash Omega. He came two days ago and before I've upated to new kernel, sometimes the EZ doesn't start, make me rebooting my DS. But now, when I start the cart, just show the EZ Flash logo and a white screen. When I press "R" button to update the kernel, appears "Micro SD initial error!" message. I swap 3 SD Cards, each one of them works fine in other things like my Wii or my R4 Gold, but when I put in the Omega, not work, even when I format to FAT and FAT32.

    And I followed the instructions to reboot the recovery, but the white screen still appears.

    ERROR MESSAGE:

    ZE-FLASH UPDATE MODE

    Micro SD initial error!

    Plz, EZ-Flash team, help me!

    (Sorry for my bad english, I'm from Brazil)
     
  2. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    let us make it clear

    Did you boot the card into kernel interface successful? Even if it is only once.
     
  3. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    Hi,

    Specs:
    Device: DS Lite
    Micro SD: Toshiba 16 GB Micro SDHC class 10 (been working all this time)


    I've been lurking around the forums to see if anyone's been experiencing the same problem as me.
    I got the Omega out of the box with the initial firmware so I updated it to the latest firmware/kernel back then which was omegakernel20180404.
    Everything worked fine and dandy.

    Updated to omegakernel20180427 (v4) after it got released and it worked for a while. I got a little busy so I wasn't able to play that often.
    Then all of a sudden, my Pokemon Emerald froze. I rebooted and it worked okay and I didn't think much about it afterwards.
    Then I tried playing Summon Night Craft Sword Monogatari - Hajimari no Ishi and it froze at the character selection screen.
    I thought it was just corrupted from file transfer, since I hooked up my card to the PC again and retransfered and the ROM worked.

    Put my DS lite aside for a couple of days, then when I tried to play it again, I got the same error as the topic starter.
    I formatted as specified in the manual, even tried the official card formatter, no dice.
    Tried another card (RiDATA 4GB SDHC class 4), same thing.

    Hasn't booted at all since. Tried holding R, still getting the same "initial error".

    When I play, I always wait around 5 secs after saving. The data in both MicroSDs are also intact, so I backed them up just in case.
    Only problem is my Omega keeps giving me that error to any SD card I throw at it. (All cards work fine elsewhere)

    I'm worried that a new kernel can't fix this since the Omega won't even read my cards. If ever, I hope I can still get a warranty replacement for it.
     
  4. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    Yeah, I hope that too. My EZ Flash IV works fone when I put the SD Card.

    — Posts automatically merged - Please don't double post! —

    Yes, but some games they freeze. When I reboot, that error appears. And that problem begin since when I updated the kernel.
     
  5. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    except this "initial error", you card can boot into kernel and play game, right?


    Can you boot into kernel right now?
     
    Last edited by EZ-Flash2, May 12, 2018
  6. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    I can't do anything. I can't get past this screen.

    If I hold R I get the blue screen's error.
     

    Attached Files:

    Last edited by locokoko, May 12, 2018
  7. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    I got that some error.
     
  8. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    Before we get a solution, please try the ways to fix:
    1. disassemble the card
    2. reposition the PCB board
    3. assemble the card
    4. screw it in tightly
    5. try the different format and allocation unit size. ie. exfat
     
  9. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    Tried that again, it didn't work.

    And for the record, I tried it again without any SD card in, and it gave the same error. It's strange since the only thing I did was upgrade the kernel and I didn't really tamper with it physically when things started acting up.
     
  10. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    It works for me in some situations:

    I've cleaned the SD card and the SD slot and works at the point I tried downgrade the kernel to the older version, and works. The cart freezes when I press "Select" to see screenshots and he freezed in loading screen when I play Mother 3 in "Boot with addon". And now I'm back in that error.
     
  11. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    Please tell me your console type and microSD card brand, size and purchase date.
     
  12. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    Already stated everything above. Bolded them for emphasis.
    Purchase date was April 3, arrived on April 19.
     
  13. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    DS Lite
    Micro SD SanDisk 8 GB/16 GB/32 GB

    Purchased: April 4
    Arrived: May 08
     
  14. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    OK,now the situation is your card working well before upgrade to firmware V4, at least you can boot into the kernel. But after upgraded to firmware v4, you meet the microsd initiation error every time. right?
     
  15. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    Yes. After v4, I got random freezing, then eventually the initial error. Now I can't use the card at all. Happens everytime for me regardless or not whether I have an actual SD card inserted.
     
  16. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    for your situation, we made a FW3 downgrade, please try to boot into kernel at least one time, downgrade the firmware and see.

    @locokoko please try to change different microSD card until it boot into kernel. sorry for the inconvenience.

    download link
    Warning: Spoilers inside!
     
    Last edited by EZ-Flash2, May 15, 2018
  17. locokoko

    locokoko Member

    Newcomer
    1
    May 11, 2018
    Japan
    Like the OP, I tried cleaning the contacts of the SD card reader in the Omega and the SD card itself before booting it up and I was finally(!!) able to access the kernel. Thanks.

    I downgraded it now. Just a question though, the ezkernel.bin I have in my root folder's from v4. Should I keep it there or do I need to use an older version? (Yes, I'm getting the update prompt, but I'm cancelling it)

    I'll report back after I play some games longer to see if they still freeze, but might take some time since I'm pretty busy with work again.
     
  18. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    you can delete ezkernel.bin for now.

    but you will be asked upgrade to fw4 every time when you boot up.

    please skip it and stay fw3, test the problem which you reported.
     
  19. Weirdman
    OP

    Weirdman Member

    Newcomer
    1
    May 11, 2018
    Brazil
    Yes. After that v4 update.
     
  20. EZ-Flash2

    EZ-Flash2 Official EZ-FLASH Stuff

    Member
    6
    Jul 16, 2003
    China
    please try to downgrade the firmware v3, read above post to find the download link
     
Loading...