EZ Flash IV not saving with GBA

Discussion in 'EZ-Flash' started by marukuru, Nov 2, 2011.

Nov 2, 2011
  1. marukuru
    OP

    Newcomer marukuru Newbie

    Joined:
    Nov 2, 2011
    Messages:
    2
    Country:
    Japan
    Hi GBAtemp,

    i hope someone here has an idea what i'm doing wrong:
    I bought an EZ Flash IV Card to use with my GameBoy Advance SP AGS-101 and a MemoryStar MiniSD 2GB (tried a 2GB SanDisk MicroSD+MiniSD Adapter as well). The EZ Flash IV Card came with the latest firmware version pre-installed (1.720). I formated the memory card with FAT16 (mkfs.vfat -F 16), copied some clean (also some SRAM-patched (gbata)) roms (such as Zelda Minish Cap, Super Mario Advance 2, Golden Sun, ...) to the root of the SD Card, created a folder 'Saver' in the root of the SD Card and created blank sav files (touch romname.sav) for each rom i copied (zelda.gba -> zelda.sav) in the 'Saver' folder.
    After booting up the EZ Flash IV Card all roms show up in it's filemanager (as well as all zero-byte-sav-files in the Saver folder), all games start perfectly, saving (in game) works without any problems (no error messages...). After switching the console off and on again, shortly the save-in-progress notice pops up. After restarting a game, the savedata is present (probably from the SRAM), but my save files on the sd card a still 0byte in size. After starting around 5 to 7 games and turning the console off and on again, the savedata (in sram) gets corrupted (in game error message on start up). So here's my problem: i tried everything to get the EZ Flash IV Card to safe to my MiniSD Card...
    • Used 8.3 filenames
    • Named the zero-byte-sav-file-dummys as romname.sav (tried with and without keeping the original .gba extension (romname.gba.sav))
    • Tried saver, Saver, SAVER as foldername
    • Reformated my Mini- and MicroSD Card over and over again
    • Tried several games

    Any ideas?

    PS: I'm on linux, tried the windows client at a friends place, no luck there either...

    [​IMG][​IMG][​IMG]
     
  2. Ammako

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    Use EZ4Client on Wine.
    Either that, or get save files of the proper sizes.
     
  3. marukuru
    OP

    Newcomer marukuru Newbie

    Joined:
    Nov 2, 2011
    Messages:
    2
    Country:
    Japan
    OK, i managed to get the EZ4 Client working with wine...
    1. Download EZ4 Client from here (incl. config file and all needed dlls)
    2. Unpack and copy drive_c_windows_temp/EZ4Para.ini to ~/.wine/drive_c/windows/temp/EZ4Para.ini
    3. Start winecfg: select 'Windows 98' as Windows Version and add the root of your MiniSD-Card as 'D' to the drive list
    4. Start EZ4Client using wine EZ4_Client.exe
    Works fine for me... I noticed one limitation: the apps crashes when opening a second rom after patching a first one.
     
  4. Eral123

    Newcomer Eral123 Newbie

    Joined:
    Feb 25, 2013
    Messages:
    1
    Country:
    Switzerland
    Hey Marukuru,

    I do not know, if you will even read this question but..... However I have also Linux (Ubuntu) running on my computer and I have the same problem that I cannot open the EZ-Flash-V-Client. I installed Wine on my computer but when I try to open it by typing " wine EZ4_Client.exe" in the terminal, the program says: " The program EZ4_Client.exe has encountered a serious problem and needs to close. We are sorry for our inconvenience." I put all the Dll-Files and the Client into my desktop but whenever I try to open it, this problem appears. It seems that you solve this problem and you are the only one I found which solved the problem on Linux. So please help, if you read this question!
     
  5. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,745
    Country:
    United Kingdom
    Did you set up a drive with the letter d: in the WINE options? You can do that or edit the EZ4client exe file in a hex editor to make it think it wants another drive but it is usually easier to just give it a drive.
     

Share This Page