1. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    Hey all! I'm trying to upgrade my DSTwo with the latest firmware patch, 1.25, but the update prompt doesn't pop up when booting up the flash cart. I've placed the .dat update file onto the root of the micro SD card, and have loaded the latest EOS (1.14) _dstwo folder and files. Under the Help menu in the DS_GAME, it shows that I'm still on 1.11, so I know it's not already updated.

    The DSTwo menu loads fine on both my up-to-date N3DSXL and my old DS Phat, but the prompt for update doesn't appear on either. Any ideas? Thanks!
     
  2. Mikemk

    Mikemk GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 26, 2015
    Messages:
    1,894
    Country:
    United States
    There's not an update prompt. It's more like 3DS updates. If the file is there, it uses the updated firmware. Otherwise, it doesn't.
     
  3. dekuleon

    dekuleon GBAtemp Advanced Fan
    Member

    Joined:
    Oct 1, 2010
    Messages:
    613
    Country:
    Brazil
    Actually yeah it should prompt you to Update... i did this yesterday hehehe
    Try using a diferente sd card
     
    adilucky3 likes this.
  4. Mikemk

    Mikemk GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 26, 2015
    Messages:
    1,894
    Country:
    United States
    Really? I had the same issue years ago and was told it just needs the update on the sd card
     
  5. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    Thanks! I gave that a shot, reformatted to FAT32, but no luck. :(
     
  6. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    It should indeed prompt to actually bind the update from the SD card to the DSTwo. It's strange because the DSTwo works fine and loads everything else. It just doesn't recognize that the update is there.
     
  7. wormdood

    wormdood pirate booty inspector
    Member

    Joined:
    Jan 3, 2014
    Messages:
    5,084
    Country:
    United States
    . . . then stop . . . if its not broken, dont fix it
     
  8. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    Well no, I'm sorry, TempGBA has a known input lag issue that is corrected with 1.14 - that's why I want the update. I just meant that everything loads, so I know it's not the SD card.
     
  9. Tomy Sakazaki

    Tomy Sakazaki GBAtemp Advanced Fan
    Member

    Joined:
    Oct 23, 2006
    Messages:
    876
    Country:
    Brazil
    If you used the B-method it doesn't prompt you since it's a forced update. The proper update method prompts if you want to continue.
     
    adilucky3 likes this.
  10. wormdood

    wormdood pirate booty inspector
    Member

    Joined:
    Jan 3, 2014
    Messages:
    5,084
    Country:
    United States
    k . . . but as you are having difficulty just getting the update to boot then you will likely have problems updating as well . . . but if you want to risk bricking the scds2 then by all means pursue that update
     
  11. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    B method didn't work for me either unfortunately. Most others with this issue are getting an error prompt at startup that I don't get, which is usually where B method comes in.
     
  12. DeadSkullzJr

    DeadSkullzJr Developer
    Developer

    Joined:
    Sep 28, 2017
    Messages:
    1,066
    Country:
    United States
    What is your current firmware? I mean the OS not the EOS.
     
  13. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    My 3DS is on Nintendo's latest firmware. But I've also tried updating on my old DS Phat and the issue is the same - it loads fine, but doesn't prompt for the update.
     
  14. DeadSkullzJr

    DeadSkullzJr Developer
    Developer

    Joined:
    Sep 28, 2017
    Messages:
    1,066
    Country:
    United States
    I was meaning the DSTWO firmware lol.
     
  15. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    Oh! Isn't that the 1.11 listed under Help in DS_GAME? If not, how do I see that?
     
  16. DeadSkullzJr

    DeadSkullzJr Developer
    Developer

    Joined:
    Sep 28, 2017
    Messages:
    1,066
    Country:
    United States
    That is not the firmware. I have a DSTWO+ which automatically has the latest firmware, it too says 1.11. There is no initial way to see it. Is your game icon on the DS menu screen Alex Rider Stormbreaker?
     
  17. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    Yes.
     
  18. DeadSkullzJr

    DeadSkullzJr Developer
    Developer

    Joined:
    Sep 28, 2017
    Messages:
    1,066
    Country:
    United States
    Then you are up to date then. The latest DSTWO firmware is 1.25, its icon is Alex Rider Stormbreaker. The latest EOS firmware is 1.14.
     
  19. Hugheserton

    OP Hugheserton Member
    Newcomer

    Joined:
    Oct 3, 2017
    Messages:
    14
    Country:
    United States
    My understanding is that the EOS firmware is indicated by the menu version number in DS_GAME, which is shown on my DSTwo (and yours) as 1.11. Is this not correct? So my EOS is updated? I've updated three times since owning my DSTwo, and it's always shown up as Alex Rider on all versions.

    TempGBA is having input lag issues for me that I know were a problem in EOS 1.11 that were corrected on 1.14. So if I'm updated, what might be the cause of the issue? Thanks for any further insight!
     
  20. DeadSkullzJr

    DeadSkullzJr Developer
    Developer

    Joined:
    Sep 28, 2017
    Messages:
    1,066
    Country:
    United States
    You have to understand that the DSTWO is unfinished, it was a late blooming flashcart that came around when the 3DS took the spotlight. I downloaded and used the 1.14 EOS however the firmware number wasn't changed in the menu so even though it says 1.11, it actually is 1.14. The problem is the SuperCard Team for some reason went very quiet. The only thing people can really say is they went out of business. The other problem is we don't have any decent coders willing to help continue the DSTWO firmware updates for us, let alone the emulators (I have been trying to get coders for Catsfc for the past week now).
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Recognize, Update, DSTwo