DSi with 1.4.1

Discussion in 'NDS - Flashcarts and Accessories' started by Ruparn, Dec 8, 2010.

  1. Ruparn
    OP

    Ruparn Member

    Newcomer
    12
    0
    Apr 4, 2009
    United States
    just bought a DSi, and it came with firmware ver. 1.4.1

    to my understanding, there are only a few cards that support it, and EZ Flash Vi is one of the ones i've used and am probably going with. I've read a few places that the way it works, is you apply the patch, and then update the DSi. will this/other cards will work if it already has the older firmware loaded? Or rather, is there any other card I should go for, for ready to work/ready to play?

    Also, it should be stated, i'm not new to DS/DSi homebrew.

    Also, also, I did google around and couldn't really figure out how to word what i'm asking, so i decided to come here, after lurking the boards, for a bit.


    thanks!
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,106
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    The Supercard DSTwo can update itself even if the DSi won't start it.

    For other carts that were blocked by 1.4.1,m you need to run the update on another system first.

    EZ Flash Vi wasn't blocked by this update.
     
  3. Ruparn
    OP

    Ruparn Member

    Newcomer
    12
    0
    Apr 4, 2009
    United States
    Ok, so I should be gold if I bought an EZ Flash Vi? (sorry, not trying to be redundant, I just want to make sure before I order this thing and possibly waste my money.)