DSi Update with R4i SDHC 3DS?

Discussion in 'NDS - Flashcarts and Accessories' started by adreneline, Oct 22, 2013.

  1. adreneline
    OP

    adreneline Newbie

    Newcomer
    3
    0
    Oct 22, 2013
    Canada
    Hi, I got a DSi as my 3DS update made my R4i SDHC unusable.

    I want to link it with my Nintendo club account for points, but I need to go on eShop on DSi to do this, and have to update it.

    Is the latest DSi firmware compatible with the R4i SDHC still?

    This is the one I have, comes in the red box:
    [​IMG]
     
  2. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,391
    464
    Jul 29, 2013
    United States
    沖縄県
    You need to buy a new flashcard.
     
  3. adreneline
    OP

    adreneline Newbie

    Newcomer
    3
    0
    Oct 22, 2013
    Canada
    So this won't work when I update the DSi to newest firmware?

    Just to confirm, this R4 works right now, just not sure if it will after update.

    Thanks.
     
  4. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,391
    464
    Jul 29, 2013
    United States
    沖縄県
    Any pics of card?
     
  5. adreneline
    OP

    adreneline Newbie

    Newcomer
    3
    0
    Oct 22, 2013
    Canada

    Yep, it's in the original post. If you can't see it, it's the"R4i 3DS" - also known as SDHC, comes in a red box. Got it about 2 yrs ago.
     
  6. Xexyz

    Xexyz GBATemp's™ Official Xexyz

    Member
    1,391
    464
    Jul 29, 2013
    United States
    沖縄県
    You need a new flashcard. I recommend Supercard DSTwo (the best card) or R4i Gold 3DS. (r4ids.cn)
    You can buy from here.
    nds-card.com
    zhuzhuchina.com
     
  7. ipwndeveloper

    ipwndeveloper GBAtemp Regular

    Member
    276
    68
    Jun 3, 2013
    United States
    San Fransisco, CA
    I'm Sorry but I think the only cards that work on the latest DSi/3DS FW are Supercard DS Two or the R4i Gold. As an Acekard 2i user we stopped receiving updates after 1.4.4 as there wasn't enough space for the spoofing that allowed the card to work on newer firmwares. But hey, you have a flashcard, which in my opinion is so much better than the eshop/dsishop. There is a massive wealth of DSHomebrew out there, some professional grade stuff, so I would hold off on upgrading your system.
     
    Xexyz likes this.