Downgrade emunand A9LH?

Discussion in '3DS - Flashcards & Custom Firmwares' started by RMZK, Apr 1, 2016.

  1. RMZK
    OP

    RMZK Member

    Newcomer
    21
    18
    Oct 22, 2015
    Mexico
    Hello and sorry for the n00b question but I'm confused

    I know there is a way to downgrade a emunand from 10.7 to 9.2 after the A9LH instalation but the thing is that my nands are linked because of the emunand injection.
    is it as simple as downgrading emunand with sysupdater? or do I have to do more steps in order to achive a 9.2 emunand to run arm9 hombrew like Retroarch?

    Thanks for your attention
     
  2. driverdis

    driverdis I am Justice

    Member
    2,410
    919
    Sep 21, 2011
    United States
    1.048596β
    why do you need to downgrade EmuNAND to 9.2?

    If you are trying to do the EmuNAND to SysNAND part of the OTP, guide, you can turn on the Updated SysNAND mode, force A9lh detection, pre-patched FIRMs, and show version options on then start to save them
    afterward, update SysNAND to 10.7 via system settings, then move data from EmuNAND to SysNAND using the OTP guide.

    EDIT: You can downgrade EmuNAND from 10.7 to 9.2 with Sysupdater to 9.2 just fine. afterward, you can move EmuNAND data to SysNAND (The OTP guide mentions how) then you can update SysNAND to be on 10.7 while having a 9.2 EmuNAND.

    Before updating SysNAND, make sure to turn on Updated SysNAND mode, Force A9LH detection, Use Pre-Patched FIRMS, and show version info.
     
    Last edited by driverdis, Apr 1, 2016
  3. Omegapsy

    Omegapsy Advanced Member

    Newcomer
    99
    22
    Feb 20, 2012
    United States
    Unlink your nands and run sysupdater on your emunand. That should give you the results you want.
     
  4. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Better question is why downgrade?

    Retroarch provides CIA's for almost all of it's cores that run in any sig-patched environment.

    What ARM9 homebrew are you trying to use?
     
  5. RMZK
    OP

    RMZK Member

    Newcomer
    21
    18
    Oct 22, 2015
    Mexico
    I already have A9LH but i though I needed to be on 9.2 to run Retroarch (PSX) the official thread implies that you have to be on 9.2 to take advantage of the ARM9 processor (N3DS only), and as far as I know updated sysnand 10.7 has signature patches but no arm9 exploit, the arm9 exploit runs before the Sysnand launches.
     
  6. driverdis

    driverdis I am Justice

    Member
    2,410
    919
    Sep 21, 2011
    United States
    1.048596β
    I see no reason why not to run 9.2 SysNAND and 10.7 EmuNAND with A9LH, this is what I do. you can flip it to 10.7 SysNAND and 9.2 EmuNAND but I see no reason to do so for your situation.
     
  7. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    I'll have to read up on that. I was under the assumption that the 9.2 requirement was more for the fact that on CFW you have access to all services (CIA) where the HomeBrewLauncher was limited to ARM11 (3DSX) which was heavily crippled.
     
  8. driverdis

    driverdis I am Justice

    Member
    2,410
    919
    Sep 21, 2011
    United States
    1.048596β
    9.0-9.2 was for homebrew that needed more than even CIA can give them, which is ARM9.
    however, all the main ARM9 homebrew you would use 9.0-9.2 for have A9LH payloads now (Decrypt9,EmuNAND9,Uncart, AGBSave9, and the new GodMode9).

    There is no reason anymore to run 9.0-9.2 unless you have an old 3DS and use it for Pokemon ram injection (for wondercards and save injection/dumping)[outdated now, people use JK Save Editor now, which works on 10.7] or for VC game ram injections (which is pointless now on CFW).